I have a VPS running Ubuntu 10.04 LTS with Zimbra, syncing the calendar with my Android phone and a OS X Lion notebook (iCal) via CalDAV.

After upgrading zimbra to 7.1.3 (from 7.1.2), neither CalDAV sync works anymore; no errors were given during the upgrade.

In an attempt to fix this issue, I removed the calendar from iCal and tried to re-add it. It no longer automatically finds the calendar, and when I manually add the URL (/principals/users/olivier/) it gives the (dutch) error "De accountinformatie is niet gevonden", which translates to "The accountinformation has not been found."

When I use a browser to browse to the URL it does list a XML like page:

Code:
Request

	Authenticated user:	olivier@olivierfaber.com
	Current date:		Wed Oct 12 12:14:49 CEST 2011

Resource

	Name:			USER_ROOT
	Path:			/
	Date:			Wed, 02 Mar 2011 15:26:04 +0100 (CET)
	Owner account name:	olivier@olivierfaber.com

Properties


<D:prop xmlns:D="DAV:">
  <D:getlastmodified>Wed, 02 Mar 2011 15:26:04 +0100 (CET)</D:getlastmodified>
  <D:getcontentlength>0</D:getcontentlength>
  <D:owner>
    <D:href>/principals/users/olivier/</D:href>
  </D:owner>
  <D:displayname>USER_ROOT</D:displayname>
  <D:getetag>"1-1"</D:getetag>
  <D:href>/dav/olivier/</D:href>
  <D:group/>
  <D:principal-collection-set>
    <D:href>/principals/users/</D:href>
  </D:principal-collection-set>
  <D:inherited-acl-set/>
  <D:current-user-privilege-set>
    <D:privilege>
      <D:read-current-user-privilege-set/>
    </D:privilege>
    <D:privilege>
      <D:read/>
    </D:privilege>
    <D:privilege>
      <D:write/>
    </D:privilege>
    <D:privilege>
      <D:write-content/>
    </D:privilege>
    <D:privilege>
      <D:write-properties/>
    </D:privilege>
    <D:privilege>
      <D:bind/>
    </D:privilege>
    <D:privilege>
      <D:unbind/>
    </D:privilege>
  </D:current-user-privilege-set>
  <D:current-user-principal>
    <D:href>/principals/users/olivier@olivierfaber.com/</D:href>
  </D:current-user-principal>
  <D:supported-privilege-set/>
  <D:acl/>
  <D:resourcetype>
    <D:collection/>
  </D:resourcetype>
  <D:principal-URL>
    <D:href>/principals/users/olivier@olivierfaber.com/</D:href>
  </D:principal-URL>
  <D:acl-restrictions>
    <D:grant-only/>
    <D:no-invert/>
  </D:acl-restrictions>
  <D:creationdate>2011-03-02T15:26:04+01:00</D:creationdate>
</D:prop>
I assume i am not the only one with this setup so there must be something wrong with my server.. Any clues?