Results 1 to 8 of 8

Thread: Calendar Sync via Caldav to Thunderbird (Lightning) stopped working

Hybrid View

  1. #1
    Join Date
    Oct 2013
    Posts
    8
    Rep Power
    2

    Question Calendar Sync via Caldav to Thunderbird (Lightning) stopped working

    Hi forum

    today all over sudden the sync via Caldav to Thunderbird (Lightning and Caldav Plugin) stopped working. I know a lot of people here might say the same "I have not changed anything" ;-) but I really didn't change one piece on my Zimbra for the last weeks. I use the following zimbra version
    Code:
    su - zimbra
    [zimbra@webmail1 ~]$ zmcontrol -v
    Release 8.0.6_GA_5922.RHEL6_64_20131203103705 RHEL6_64 FOSS edition.
    I use a URL like this to access caldav: https://mydomain.tld:4433/dav/user@mydomain.tld/Calendar
    Port 4433 is forwarded to zimbra's LAN IP on port 443. But I also tried with https://lan-name/dav/user@mydomain.tld/Calendar
    Same effect: Thunderbird cannot access the calendar. The strange thing is that TB does not even ask for the password. I deleted the stored password from TBs password-manager but does not help. TB does not ask for a password. I deleted the calendar from TB, removed and reinstalled the two plugins (lightning and caldav) and at the end even re-installed Thunderbird but all does not help.
    But when I call one of the URLs above in the browser I get asked for a password as expected and I get the txt file with the calendar definition stuff. I use TB 24.5.0 on fedora 20

    Thanks a lot for any input as I'm running out of ideas :-)

    tobi

  2. #2
    Join Date
    Aug 2010
    Location
    England
    Posts
    39
    Rep Power
    5

    Default

    If you enable trace logging for dav for the user using something like:

    zmprov addAccountLogger user@mydomain.tld zimbra.dav TRACE

    does that give you any useful information in mailbox.log?
    Gren Elliot
    Lead Engineer - Server
    Zimbra | Community & Collaboration

  3. #3
    Join Date
    Oct 2013
    Posts
    8
    Rep Power
    2

    Default

    Hi

    thanks for the advice. Will try it today after working.
    But actually I think it's only a Thunderbird problem. As caldav with my smartphone works fine.
    I checked the error console of TB and saw that TB believes that there is no valid DAV collection. And TB throws several times the DAV_NOT_DAV error

    Cheers

    tobi

  4. #4
    Join Date
    Oct 2013
    Posts
    8
    Rep Power
    2

    Default

    The trace gives me not one line when I try to connect from TB. As reference I checked with my smartphone which gives me the loglines expected. With tpcdump I can see that my TB sends pakets and that the zimbra server replies back. But not one line in trace log with TB. Unfortunately the connection is SSL only so I cannot look into the pakets.
    So it's for sure no zimbra problem. Hope it's still okay to have this problem here in the zimbra forum. I have the hope that some TB users might have experienced similar problems :-)

    Thanks

    tobi

  5. #5
    Join Date
    Aug 2010
    Location
    England
    Posts
    39
    Rep Power
    5

    Default

    Very happy for you to use the Zimbra forums for that kind of thing - other Thunderbird with Zimbra users may be interested too
    Best of luck,
    Gren
    Gren Elliot
    Lead Engineer - Server
    Zimbra | Community & Collaboration

  6. #6
    Join Date
    Oct 2013
    Posts
    8
    Rep Power
    2

    Default

    @gren
    but it seems not to be a very widespread problem
    Because I was courious I just bootet my Win7 for the first time in months. Has TB 24.3 installed. Same there no connection to zimbra caldav anymore. TB in Win shows same DAV_NOT_DAV errors in the error console. So I guess the problem is not OS related as I have the same effects on Win7 and Fedora20. To only constant is TB itself and the lightning+caldav plugins. Although I have different TB versions between Win and Fedora. But if TB or the plugins are the reason then more people should have this problem ...
    I think Mr Murphy does not like me at the moment
    Will try and make a VM with a new Fedora20, then install TB and the plugins and see what happens

    If anyone here has any idea what else to try to solve this problem I'm glad for any input

    Cheers

    tobi

Similar Threads

  1. Thunderbird/Lightning: CalDAV vs. ICS
    By stannenb in forum Administrators
    Replies: 5
    Last Post: 03-23-2011, 12:50 AM
  2. Configuration of Thunderbird Lightning and Zimbra CalDAV
    By boardstretcher in forum Installation
    Replies: 2
    Last Post: 06-22-2009, 12:26 PM
  3. problems with thunderbird/lightning sync
    By the_dude_75 in forum CalDAV / CardDAV / iSync
    Replies: 0
    Last Post: 09-15-2008, 03:33 AM
  4. Zimbra with Thunderbird an Lightning Calendar
    By wolli in forum Administrators
    Replies: 15
    Last Post: 01-16-2008, 12:57 PM
  5. thunderbird w/ lightning - can't connect to calendar
    By ikiini in forum Administrators
    Replies: 16
    Last Post: 10-26-2007, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •