Results 1 to 10 of 20

Thread: Developer Builds UPDATED 21-Dec-2005

Hybrid View

  1. #1
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default Developer Builds UPDATED 21-Dec-2005

    Something we've wanted to do for some time now is make our very latest code available. Today we've released the first of many devloper builds. These builds are the same builds we are running internally for our @zimbra.com mail. We plan to update these about once a week but don't hold us to it.

    Notes:
    Developer builds are not designed for production use. They've had little or no-testing. Use these at your own risk. They may cause your computer to stop working and burst into flames. They will not work or install over a Network build. That said they are great for checking out the latest features or validating a bug that has now been fixed. If you choose to install these please give us your feedback and post any bugs you find on the forums.

    Have Fun!!

    Updated 21-Dec-2005
    - Added SUSE builds
    - Filter UI re-worked

    Note: No new Mac build this week.
    Latest Developer Builds
    Last edited by KevinH; 12-21-2005 at 05:33 PM.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I assume they will install over the current OSS builds and you want any problems reporting in the forums?

    Looks like it's going to be a fun week-end.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Yep I've updated my laptop (runs FC4) from M2. So that's the goal, as always any feedback is welcomed.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  4. #4
    Join Date
    Nov 2005
    Posts
    51
    Rep Power
    9

    Default

    I'm getting an error while trying to open the admin ui all that shows up is the .
    In /opt/zimbra/log/zimbra.log:
    Code:
    2005-12-08 16:31:34,983 WARN  [http-7071-Processor50] [ip=192.168.10.2;] misc - LC.get(trial_expiration_date) was null, returning empty string
    From Firefox:
    Code:
    message: el has no properties
    fileName: https://blazer.unilogiclabs.com:7071/zimbraAdmin/js/Ajax_all.js.jgz?v=051208105425
    lineNumber: 108
    stack: (undefined)@https://blazer.unilogiclabs.com:7071/zimbraAdmin/js/Ajax_all.js.jgz?v=051208105425:108
    ([object Object],null,null,null,true)@https://blazer.unilogiclabs.com:7071/zimbraAdmin/js/Ajax_all.js.jgz?v=051208105425:2351
    ("",[object Array],1,"uid",true,null,"displayName,zimbraId,zimbraMailHost,uid,zimbraAccountStatus,description,zimbraMailStatus",1)@https://blazer.unilogiclabs.com:7071/zimbraAdmin/js/ZimbraAdmin_all.js.jgz?v=051208105425:2135
    (undefined)@https://blazer.unilogiclabs.com:7071/zimbraAdmin/js/ZimbraAdmin_all.js.jgz?v=051208105425:2673
    call([object Object],undefined)@:0
    ((function () {this._appViewMgr = new ZaAppViewMgr(this._shell, this, true);try {var testSrch = ZaSearch.search("", [ZaSearch.ACCOUNTS], 1, ZaAccount.A_uid, true, this._app, null, 1);ZaSettings.init();var elements = new Object();elements[ZaAppViewMgr.C_SASH] = new DwtSash(this._shell, DwtSash.HORIZONTAL_STYLE, "console_inset_app_l", 20);elements[ZaAppViewMgr.C_BANNER] = this._createBanner();elements[ZaAppViewMgr.C_APP_CHOOSER] = this._createAppChooser();elements[ZaAppViewMgr.C_STATUS] = this._statusBox = new DwtText(this._shell, "statusBox", Dwt.ABSOLUTE_STYLE);this._statusBox.setScrollStyle(Dwt.CLIP);this._setLicenseStatusMessage();if (skin && skin.showSkin) {skin.showSkin(true);}this._appViewMgr.addComponents(elements, true);this._launchApp();elements = new Object();elements[ZaAppViewMgr.C_TREE] = this.getOverviewPanelController().getOverviewPanel();elements[ZaAppViewMgr.C_SEARCH] = this._app.getAccountListController().getSearchPanel();elements[ZaAppViewMgr.C_CURRENT_APP] = new ZaCurrentAppToolBar(this._shell);this._appViewMgr.addComponents(elements, true);} catch (ex) {this._handleException(ex, "ZaZimbraAdmin.prototype.startup", null, true);}this._schedule(this._killSplash);}),undefined,0)@https://blazer.unilogiclabs.com:7071/zimbraAdmin/js/ZimbraAdmin_all.js.jgz?v=051208105425:1035
    apply([object Object],[object Array])@:0
    (0)@https://blazer.unilogiclabs.com:7071/zimbraAdmin/js/Ajax_all.js.jgz?v=051208105425:379
    @https://blazer.unilogiclabs.com:7071/zimbraAdmin/js/Ajax_all.js.jgz?v=051208105425:376
    
    name: TypeError
    The webmail interface works fine and zmcontrol shows everything running. Any ideas whats wrong?
    Thanks,
    Ben

    Edit: Nevermind: It was a Firefox caching problem. It still had the prevoius session from before the update cached.
    Last edited by unilogic; 12-08-2005 at 01:46 PM.

  5. #5
    Join Date
    Nov 2005
    Posts
    12
    Rep Power
    9

    Exclamation Upgrade FC4 with developer build

    At the end of the upgrade on FC4 I got:

    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    chown: cannot access `/opt/zimbra/conf/smtpd.key': No such file or directory
    chown: cannot access `/opt/zimbra/conf/smtpd.crt': No such file or directory
    Operations logged to /tmp/zmsetup.log.27217
    Setting defaults...Setting defaults from existing config...Done
    Upgrading from 3.0.0_M2 to 3.0.0_M3
    Proceed with upgrade? [No] yes
    Fri Dec 9 06:50:47 2005: Stopping zimbra services
    Fri Dec 9 06:50:49 2005: Checking mysql status
    Fri Dec 9 06:50:49 2005: Starting mysql
    Fri Dec 9 06:50:50 2005: SELECT value FROM config WHERE name = 'db.version'
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=xxxmaskedxxx --database=zimbra --batch --skip-column-names'. at /opt/zimbra/libexec/scripts/Migrate.pm line 101, <> line 1.


    Strange thing is, mysql was running afterward and I could login manually with:

    /opt/zimbra/bin/mysql --user=zimbra --password=xxxmaskedxxx --database=zimbra

    Also when I restarted Zimbra I got:

    Starting spell...FAILED
    Syntax error on line 232 of /opt/zimbra/conf/httpd.conf:
    Cannot load /opt/zimbra/httpd-2.0.54/modules/libphp5.so into server: /opt/zimbra/httpd-2.0.54/modules/libphp5.so: cannot open shared object file: No such file or directory

    Finally, I can login no problem with a regular user on:

    http://www.myserver.com

    but cannot with admin on:

    https://www.myserver.com:7071

    The page shows up but I get: "Authentication failed"

    If I change manually the admin password with "zmprov" it's all the same.

    Thank you for this beautiful piece of work! Keep-up!

  6. #6
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Can you attach the entire /tmp/zmsetup.log.27217 log?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  7. #7
    Join Date
    Dec 2005
    Posts
    24
    Rep Power
    9

    Default What's a Zimlet?

    Ok, so you've snuck out a build on 12/30/05, but not notes, and lots of changes.

    Whats a zimlet?

    The install process is much better, but takes longer to start, I think.

    I know you guys are busy, but when you release a build, we need notes to see whats fixed, added, etc

    Great work though, you guys kick A$$.

    I'm an old MS Exchange Junkie and this product is the best I've seen in a long time. The install is almost perfect.

    Can't wait for the debian package, but I'll try compiling before that.

    Again, great job, keep up the good work!

    John

  8. #8
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by retireoncsco
    Ok, so you've snuck out a build on 12/30/05, but not notes, and lots of changes.

    Whats a zimlet?
    Stay tuned for more on this in an upcoming announcement.

    Quote Originally Posted by retireoncsco
    I know you guys are busy, but when you release a build, we need notes to see whats fixed, added, etc
    Well if your looking for a particular bug you can check bugzilla ( http://bugzilla.zimbra.com ). In general we won't spend time to write up notes for each dev/weekly build. I always try to mention a quick summary of the big changes for the week (ie these), but at this time we don't plan to include change/bug numbers. We do include more detail in our milestone releases which have a release notes.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  9. #9
    Join Date
    Dec 2005
    Posts
    24
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    Stay tuned for more on this in an upcoming announcement.
    I can't wait.

    Well if your looking for a particular bug you can check bugzilla ( http://bugzilla.zimbra.com ). In general we won't spend time to write up notes for each dev/weekly build. I always try to mention a quick summary of the big changes for the week (ie these), but at this time we don't plan to include change/bug numbers. We do include more detail in our milestone releases which have a release notes.
    I totally understand, thanks Kevin

Similar Threads

  1. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM
  2. Receiving Mails problem
    By praveen_14 in forum Administrators
    Replies: 10
    Last Post: 12-12-2005, 12:11 PM
  3. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 03:55 PM
  4. antispam not working?
    By moebis in forum Installation
    Replies: 16
    Last Post: 12-03-2005, 07:11 PM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 06:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •