Results 1 to 5 of 5

Thread: SOAP AuthRequest/Response Syntax

  1. #1
    Join Date
    May 2007
    Location
    Vancouver, Canada
    Posts
    75
    Rep Power
    8

    Default SOAP AuthRequest/Response Syntax

    I'm working on getting the Zimbra Funambol connector working, but am getting an authentication failure when it tries to connect to the back-end Zimbra server using SOAP. It does an AuthRequest and expects to get back an authToken and SessionID, but for some reason, the SOAP response is missing a SessionID. The Zimbra server is running 5.0Beta3. The request looks like this:

    <AuthRequest xmlns="urn:zimbraAccount">
    <account by="name">hillman</account><password>xxxxxxxx</password>
    <prefs><pref name="zimbraPrefTimeZoneId"/></prefs>
    </AuthRequest>

    And the response that comes back:

    <AuthResponse xmlns="urn:zimbraAccount">
    <authToken>0_07b4de1326b4.....</authToken>
    <lifetime>172800000</lifetime>
    <prefs>
    <pref name="zimbraPrefTimeZone Id">(GMT -08.00) Pacific Time (US &amp; Canada)</pref>
    </prefs>
    </AuthResponse>

    Am I correct in assuming that if I got an authToken back from the server, that the authrequest succeeded? If so, why no sessionID? All of the documentation I've read suggests that one should be present..

    Thanks!
    Last edited by hillman; 09-21-2007 at 12:59 AM.

  2. #2
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    My guess is that the ZCS server you're authing to doesn't believe that the account is homed there. Check your hostnames.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    May 2007
    Location
    Vancouver, Canada
    Posts
    75
    Rep Power
    8

    Default

    I tried changing the account string from 'user' to 'user@servername', but that made no difference. I only have one server, so all users are in the same place. Is there anything else that might instruct the SOAP server not to create a session? The Zimbra server is running in 'both' mode for http, but the soap request is coming in via http (I don't know whether it supports https). Will the Zimbra SOAP server refuse to issue a sessionID on an http connection if 'both' mode is on?
    Last edited by hillman; 09-21-2007 at 01:55 PM.

  4. #4
    Join Date
    May 2007
    Location
    Vancouver, Canada
    Posts
    75
    Rep Power
    8

    Default Solved.

    The problem turned out to be in the <Soap:Header> that was being passed along with the authRequest. A '<nonotify/> flag was being passed, which, according to the documentation, just means "don't notify about not messages/events in this session", but perhaps it changed somewhere along the line because in my case it was preventing a sessionID from being assigned. Once I removed the <nonotify/>, logins started working.

    Hopefully this helps someone else one day because I spent a lot of hours of trial and error figuring that one out..

  5. #5
    Join Date
    Apr 2010
    Posts
    6
    Rep Power
    5

    Default

    It doesn't work!!
    My request don't has a <nonotify/>, in the header is only "<context xmlns="urn:zimbraAccount"/><session/>". I try everything that google tellme and nothing!!

Similar Threads

  1. XSD/WSDL Files for the SOAP Server?
    By photoadrian in forum Developers
    Replies: 5
    Last Post: 12-23-2012, 02:32 AM
  2. Jar For Soap Client
    By wcameron in forum Developers
    Replies: 19
    Last Post: 06-03-2009, 03:04 PM
  3. Question on SOAP compatibility
    By Robin Diederen in forum Developers
    Replies: 3
    Last Post: 09-19-2006, 02:26 AM
  4. Bug with preauth mechanism and SOAP headers?
    By Coilcore in forum Developers
    Replies: 3
    Last Post: 07-20-2006, 11:41 AM
  5. Replies: 6
    Last Post: 03-17-2006, 10:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •