Results 1 to 4 of 4

Thread: [SOLVED] Building only Zimbra WEB UI

  1. #1
    Join Date
    Jul 2007
    Posts
    27
    Rep Power
    8

    Default [SOLVED] Building only Zimbra WEB UI

    Greetings All,

    I have Zimbra 4.5.6 opensource installed on one of my Linux box. I want to build only Zimbra WEB UI 4.5.6 and use it, instead of the one installed with the full deployment. I downloaded the Source tar ball and went to the directory [$SOURCE]\ZimbraWebClient and issued the command 'ant'. This created a distributable web archive(war). But when I compared this build with the one installed on a full deployment there was considerable size difference and also there was difference in the packaged content. There was even a difference in the list of JS(JavaScript) files used by Zimbra Web UI.

    Is my procedure to build Zimbra WEB UI correct? Do I need to do a complete Zimbra (all Zimbra products) build so as to just get the build of Zimbra WEB UI?

    I had a look at the link Building Zimbra on Fedora Core 5 and x86 64 - Zimbra :: Wiki but I could not find anything mentioning, building Zimbra WEB UI only. My Linux OS is RHEL 4 update 3.
    Regards,
    Zocs...

  2. #2
    Join Date
    Sep 2006
    Posts
    252
    Rep Power
    9

    Default

    Which ant task did you execute? Also, why do you want the zimbra ui only? It's really tied to rest of the suite so the ui alone is useless.

    Thanks,

  3. #3
    Join Date
    Jul 2007
    Posts
    27
    Rep Power
    8

    Default

    I used the build.xml file located in folder ${source}\ZimbraWebClient. I used the default target from this build.xml which is 'war'. As I already mentioned I have a deployed Zimbra product (4.5.6-GA) on one of the machine. So I am not going to use the Zimbra UI alone. But I was looking for steps to build individual components.
    Regards,
    Zocs...

  4. #4
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    10

    Default

    Quote Originally Posted by zocs View Post
    I used the build.xml file located in folder ${source}\ZimbraWebClient. I used the default target from this build.xml which is 'war'. As I already mentioned I have a deployed Zimbra product (4.5.6-GA) on one of the machine. So I am not going to use the Zimbra UI alone. But I was looking for steps to build individual components.
    War won't get it done. Use ant deploy and ant admin-deploy.

Similar Threads

  1. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  2. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 10:19 AM
  3. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 01:58 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •