Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Question about 5.0.1 NETWORK.

  1. #1
    Join Date
    Jul 2007
    Posts
    39
    Rep Power
    8

    Default Question about 5.0.1 NETWORK.

    I made the upgrade recently and I found it weird, for the reasons I list here :

    - The UI is now equal to the Community version. Is that normal ? or the package that was put online was named NETWORK by mistake ?

    - Even if I save the time location (Brussels for example), it keeps putting me over Berlin all the time.

    - IM is unreliable depending on the browser. Under Firefox over a PC it doesn't get messages, hangs, etc. as soon as you changed from the IM to mail for example. But under Caminor on a Mac, it works just ok.

    - Spell checkers not choosed correctly with language you chose.

    - UI is now getting out of browsers screen because of some long translations (french for example), and the arrows don't appear anymore.


    Thanks

    Just asking.


    Thanks

  2. #2
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Quote Originally Posted by arkanis View Post
    - The UI is now equal to the Community version. Is that normal ? or the package that was put online was named NETWORK by mistake ?
    Which UI ? User or Admin ?

    Quote Originally Posted by arkanis View Post
    - Even if I save the time location (Brussels for example), it keeps putting me over Berlin all the time.
    Did you try changing it for the whole CoS ?

    Quote Originally Posted by arkanis View Post
    - IM is unreliable depending on the browser. Under Firefox over a PC it doesn't get messages, hangs, etc. as soon as you changed from the IM to mail for example. But under Caminor on a Mac, it works just ok.
    Did not try IM, I can not help, sorry (but I've seen such reports in the forum already).

    Quote Originally Posted by arkanis View Post
    - Spell checkers not choosed correctly with language you chose.
    Known bug...
    Bug 22779 - [da, fr, sv] E-mail: Compose: Spell-check feature misfunctions

    Quote Originally Posted by arkanis View Post
    - UI is now getting out of browsers screen because of some long translations (french for example), and the arrows don't appear anymore.
    http://www.zimbra.com/forums/i18n-l1...ise-5-0-x.html
    http://www.zimbra.com/forums/i18n-l1...happy-all.html

  3. #3
    Join Date
    Jul 2007
    Posts
    39
    Rep Power
    8

    Default Ok...

    1) The User UI

    2) Yes, already changed that in the CoS to :
    Brussels / Madrid / Cop...

    3) I've seen this mostly on PC's, and on Firefox, since I force them all to use Firefox.

    4) Will what for a fix then... but installing it by hand give errors in the spell corrections, like the word splitted by the corrector and thus telling me it's a wrong word, etc.

    5) I've checked that, but it's a turnaround made by a user, it's nice and helps me but I prefer to have Zimbra team fix this from tail to toe.


    Thanks!

  4. #4
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Quote Originally Posted by arkanis View Post
    1) The User UI
    I'm sorry but what were the changes you saw before (4.5) in the user UI between OSE and NE ?

    Quote Originally Posted by arkanis View Post
    2) Yes, already changed that in the CoS to :
    Brussels / Madrid / Cop...
    So, if I understand correctly, you changed the CoS but if a user wants to override the CoS, it doesn't work ?
    Did you try to override CoS value from Admin UI ?

    Quote Originally Posted by arkanis View Post
    4) Will what for a fix then... but installing it by hand give errors in the spell corrections, like the word splitted by the corrector and thus telling me it's a wrong word, etc.
    Big changes are needed to get multi-language spell checkings.

    Currently, spell check is done with aspell, aspell being called through a php file. The problems are that the php file contains the hardcoded locale to use (en_EN) and that other languages dictionnaries are not installed.

    I fixed it on my servers by installing the dictionnary by hand and patch the php file by hand too. Problem is now that, like the french 4.5.x translation, Zimbra is only able to spell-check in french...

    Quote Originally Posted by arkanis View Post
    5) I've checked that, but it's a turnaround made by a user, it's nice and helps me but I prefer to have Zimbra team fix this from tail to toe.
    I made it 8)
    Just like I worked on the previous (4.x an 4.5.x) translations.

    And I'm afraid we won't unfortunately see any Zimbra solution before 5.0.3 (thus my "I'm not happy" post).

  5. #5
    Join Date
    Jul 2007
    Posts
    39
    Rep Power
    8

    Default Some other things...

    1) Will make shortly a screenshot so you can compare with the ones posted on the Zimbra website (that used to look the same here with the rounded tabs, etc).

    I realised this because I have installed the Community Edition in another place and after I installed 5.0.1 now the look exactly the same.

    2) I changed CoS in Admin UI, and it's not that the users can't change it, they can... but the changes are not taken into account, and the second problem and more scary one is that I choosed Brussels/Cop/Madrid/Paris but users get Berlin ? WTH ?

    3) I used your method for the ASPELL dictionary since 4.5 so thanks a lot, but with the 5.0 release I'm having problems with the way it cuts words to analyze them. Can you share your modifications on the 5.0.x install so I can be sure everything is good ?


    Thanks !!!

  6. #6
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Quote Originally Posted by arkanis View Post
    1) Will make shortly a screenshot so you can compare with the ones posted on the Zimbra website (that used to look the same here with the rounded tabs, etc).

    I realised this because I have installed the Community Edition in another place and after I installed 5.0.1 now the look exactly the same.
    OK, thanks.

    Quote Originally Posted by arkanis View Post
    2) I changed CoS in Admin UI, and it's not that the users can't change it, they can... but the changes are not taken into account, and the second problem and more scary one is that I choosed Brussels/Cop/Madrid/Paris but users get Berlin ? WTH ?
    I've just tested and same behaviour as yours :
    . my CoS (for my user) is set to Brussels/Cop/Madrid/Berlin (admin UI)
    . this CoS shows as Berlin in the User UI
    . if I change it as a user, save, log off, log back in, I'm back to Berlin.

    The UserUI TZ list is not the same that the AdminUI.
    It does not seem to be in the translation files.

    There's a bug opened : Bug 22968 - timezone change doesn't impact on Ajax verion.

    Quote Originally Posted by arkanis View Post
    3) I used your method for the ASPELL dictionary since 4.5 so thanks a lot, but with the 5.0 release I'm having problems with the way it cuts words to analyze them. Can you share your modifications on the 5.0.x install so I can be sure everything is good ?
    Did you fully-patch the aspell.php file (with the same diff than 4.5) or just changed the locale ?
    Last edited by Klug; 01-23-2008 at 06:00 AM. Reason: Found the bug in bugzilla

  7. #7
    Join Date
    Jul 2007
    Posts
    39
    Rep Power
    8

    Default Here we are...

    1) Ok, here are the screenshots :

    BEFORE



    AFTER




    2) I will try to open a bug for that behavior, never opened a bug, hope everthing will go ok...

    3) I fully patched, and I noticed also that there is a new line (that I commented because otherwise results where worst, the UT8 line).

    But still having the same problems. I liked your installers, they where easy and straightforward, any chance you get one running for 5.0.x ?


    thanks

  8. #8
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Screenshots difference is due to, I think, the same (new) template (Sand) available both in NE and OSS.

    The "before" screenshot is a beta screenshot, isn't it ?

    About the language-installers, 5.0 is supposed to be localised "out of the box" and supported with its own language files.

    Several bugs are opened (spell checker, issues with non-tested french translation, etc), we're waiting for follows-up on them.

  9. #9
    Join Date
    Jul 2007
    Posts
    39
    Rep Power
    8

    Default Well...

    Uhmmmm... it was like that in 5.0.0GA NETWORK... so was that beta too ?

    I took the screenshot from the Zimbra website since it was the same here. And since I can't go back to 5.0.0 to get you a screenie, I used that one.

    But it was the same here.

    As for the installer I was talking about the dictionary and spell correction, since your packages used to install everything in one shot.

  10. #10
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Quote Originally Posted by arkanis View Post
    Uhmmmm... it was like that in 5.0.0GA NETWORK... so was that beta too ?
    I took the screenshot from the Zimbra website since it was the same here. And since I can't go back to 5.0.0 to get you a screenie, I used that one.
    If the screeny is 5.0GA, it means the skin was upgraded between 5.0 and 5.0.1 8)

    Quote Originally Posted by arkanis View Post
    As for the installer I was talking about the dictionary and spell correction, since your packages used to install everything in one shot.
    It's the same : spell checker is part of the localisation process.

Similar Threads

  1. upgrading to network edition
    By zzzzsg in forum Installation
    Replies: 11
    Last Post: 03-06-2008, 09:58 PM
  2. [SOLVED] LogoURL under 5.0.1 NETWORK
    By Rich Graves in forum Administrators
    Replies: 6
    Last Post: 03-05-2008, 07:28 AM
  3. Replies: 1
    Last Post: 12-19-2006, 01:58 PM
  4. Zimbra stops working following network failure
    By jsachs in forum Administrators
    Replies: 1
    Last Post: 08-17-2006, 09:09 PM
  5. Questions about upgrade / network edition
    By goetzi in forum Administrators
    Replies: 7
    Last Post: 02-27-2006, 07:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •