Results 1 to 2 of 2

Thread: Building Zimbra for PLD Linux

  1. #1
    Join Date
    Feb 2008
    Rep Power

    Question Building Zimbra for PLD Linux


    I try build Zimbra 5.0.2 from sources.
    In few words I describe what I did.

    1. download and install jdk-1_5_0_14-linux-i586.bin in directory /opt/zimbra-src
    2. export JAVA_HOME=/opt/zimbra-src/jdk1.5.0_14
    3. export
    4. export BUILD_HOME="/opt/zimbra-src/main/"
    5. p4 -u public -P public1234 -c public-view sync -f //depot/zcs/main/...
    6. cd /opt/zimbra-src/main/ZimbraBuild/defs
    7. cp RHEL4.def PLD.def
    8. add to /opt/zimbra-src/main/ZimbraBuild/rpmconf/Build/
      if [ -f /etc/pld-release ]; then
              echo "PLD"
              exit 0
    9. cd /opt/zimbra-src/main/ZimbraBuild
    10. make allclean all

    *** Creating openldap
    (cd /opt/zimbra-src/main/ZimbraBuild/ldapbuild/opt/zimbra; tar xzf /opt/zimbra-src/main/ZimbraBuild/../ThirdPartyBuilds/PLD/openldap/openldap-;)
    tar: /opt/zimbra-src/main/ZimbraBuild/../ThirdPartyBuilds/PLD/openldap/openldap- Nie można open: Nie ma takiego pliku ani katalogu
    tar: Błąd nie do naprawienia: koniec
    tar: Child returned status 2
    tar: Zakończenie z błędem z powodu uprzednich błędów
    make: *** [/opt/zimbra-src/main/ZimbraBuild/ldapbuild/opt/zimbra/openldap-] Błąd 2
    Tar try extract file openldap- but this file not exist.

    Where I find openldap-

    PS. In attachment is a compiler log.

    Attached Files Attached Files

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Rep Power


    You need to build all the ThirdParty components first. As of my last sync, openldap- was only in main branch not FRANKLIN (might have been updated in the last couple of days).

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. [SOLVED] Spam Being Sent Thru Server - Help Needed!
    By msf004 in forum Administrators
    Replies: 22
    Last Post: 03-15-2008, 12:11 AM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  4. Creating accounts problem
    By d64 in forum Administrators
    Replies: 17
    Last Post: 02-13-2008, 07:24 AM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts