Results 1 to 4 of 4

Thread: Single Sign On with Zimbra

Hybrid View

  1. #1
    Join Date
    Jan 2008
    Rep Power

    Default Single Sign On with Zimbra


    When I try to conect to Zimbra Server via Soap allways say not authorized.

    I get the AuthToken like this:
    String tok = sp.getAuthToken();
    sp is the class SoapProvisioning in package com.zimbra.cs.account.soap.SoapProvisioning

    and I build the URL https://server/service/preauth?isredirect=1&authtoken={} and between the branches token value.
    And allways opens Zimbras login screen.
    Before doing all this I autenticate as admin and reponse was correct.

    Anyone tried a Signal Sign On with Zimbra?

    Thank you

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    I presume you mean Single Sign On? Does this answer your questions: Preauth - Zimbra :: Wiki


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jan 2008
    Rep Power


    Yep, I have already been following the steps in that URL you mention.
    But still I do not get it work. Even with code provided in there.

    One question, in the documentation it says that the order of the concatenation is important, must be: account/by/expires/timestamp.
    But in example provided the order is: (Preauth - Zimbra :: Wiki)

    params.put("account", name);
    params.put("by", "name"); // needs to be part of hmac
    params.put("timestamp", ts);
    params.put("expires", "0"); // means use the default

    ¿Could be that a problem?

    I get error message --> http 400: authentication failed for
    And I already have my preAuthKey generated by zimbra with command zmprov gdpak. And after generating the key server was restarted.
    ¿Any hint?
    Thank you
    Last edited by Ada; 02-14-2008 at 01:02 AM.

  4. #4
    Join Date
    Jan 2008
    Rep Power

    Thumbs up

    well, problem was solved.
    You wanna know what was is it?
    The Zimbra server time was wrong, was not syncronized correctly and that's why I allways got the error of auth failed, timestamp had expired....

Similar Threads

  1. Zimbra SPNEGO Single Sign-On for ZCS
    By rrittmann in forum Installation
    Replies: 0
    Last Post: 08-10-2012, 08:15 AM
  2. Single Sign On
    By Dirk in forum Administrators
    Replies: 19
    Last Post: 03-12-2010, 05:10 AM
  3. zimbra moodle single sign on
    By hari46 in forum Developers
    Replies: 5
    Last Post: 11-08-2009, 10:29 PM
  4. Single Sign on
    By cobradevil in forum Administrators
    Replies: 4
    Last Post: 03-18-2008, 11:16 AM
  5. Replies: 4
    Last Post: 09-05-2007, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts