Results 1 to 5 of 5

Thread: Zimbra Development with Eclipse

  1. #1
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Cool Zimbra Development with Eclipse

    Hello,

    After building Zimbra with command line as I do here http://www.zimbra.com/forums/develop...html#post92965
    I have got a Zimbra running on, now I am trying to develop other features for Zimbra using Eclipse, so I search a tutorial and I find this Zimbra Development with Eclipse
    I make as it said and I make attention that it is using Tomcat and Windows, and I am using jetty and ubuntu, but when I execute "reset-the-world" I have got the following error:
    Code:
    localhost-ssl-cert:
       [genkey] Generating Key for jetty
       [genkey] erreur keytool : java.io.IOException: Keystore was tampered with, or password was incorrect
    
    BUILD FAILED
    /home/vmmachine/workspace/Zimbra/ZimbraServer/build.xml:672: The following error occurred while executing this line:
    /home/vmmachine/workspace/Zimbra/ZimbraServer/build.xml:761: genkey returned: 1
    
    Total time: 47 seconds
    Any idea?
    Last edited by Abdelmonam Kouka; 05-28-2008 at 01:02 AM.

  2. #2
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    I think that is a problem of permessions, so I run (as root) this command
    Code:
    chown -hR vmmachine:vmmachine /opt/zimbra/
    And I re-run "reset-the-world" and I have got now:
    Code:
          [sql] Executing resource: /home/vmmachine/workspace/Zimbra/ZimbraServer/src/db/db.sql
          [sql] Failed to execute:  CREATE DATABASE zimbra
    
    BUILD FAILED
    /home/vmmachine/workspace/Zimbra/ZimbraServer/build.xml:672: The following error occurred while executing this line:
    /home/vmmachine/workspace/Zimbra/ZimbraServer/build.xml:850: java.sql.SQLException: Can't get stat of './zimbra' (Errcode: 13)
    
    Total time: 40 second
    Any help please?

  3. #3
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by Abdelmonam Kouka View Post
    I think that is a problem of permessions, so I run (as root) this command
    Code:
    chown -hR vmmachine:vmmachine /opt/zimbra/
    And I re-run "reset-the-world" and I have got now:
    Code:
          [sql] Executing resource: /home/vmmachine/workspace/Zimbra/ZimbraServer/src/db/db.sql
          [sql] Failed to execute:  CREATE DATABASE zimbra
    
    BUILD FAILED
    /home/vmmachine/workspace/Zimbra/ZimbraServer/build.xml:672: The following error occurred while executing this line:
    /home/vmmachine/workspace/Zimbra/ZimbraServer/build.xml:850: java.sql.SQLException: Can't get stat of './zimbra' (Errcode: 13)
    
    Total time: 40 second
    Any help please?
    I think it is a bad idea, in fact I have a troubleshooting in executing zmcontrol status so I return chown -hR zimbra:zimbra /opt/zimbra/

    The old problem :-(

  4. #4
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by Abdelmonam Kouka View Post
    I think that is a problem of permessions, so I run (as root) this command
    Code:
    chown -hR vmmachine:vmmachine /opt/zimbra/
    And I re-run "reset-the-world" and I have got now:
    Code:
          [sql] Executing resource: /home/vmmachine/workspace/Zimbra/ZimbraServer/src/db/db.sql
          [sql] Failed to execute:  CREATE DATABASE zimbra
    
    BUILD FAILED
    /home/vmmachine/workspace/Zimbra/ZimbraServer/build.xml:672: The following error occurred while executing this line:
    /home/vmmachine/workspace/Zimbra/ZimbraServer/build.xml:850: java.sql.SQLException: Can't get stat of './zimbra' (Errcode: 13)
    
    Total time: 40 second
    Any help please?
    I think it is a bad idea, in fact I have a troubleshooting in executing zmcontrol status so I return chown -hR zimbra:zimbra /opt/zimbra/

    The old problem :-(

  5. #5
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    No one to help me? What is missing in my work? The ones who develop Zimbra: how do you do?

Similar Threads

  1. admin consol blank after 5.0.3 upgarde
    By maumar in forum Administrators
    Replies: 6
    Last Post: 03-21-2008, 05:16 AM
  2. Replies: 12
    Last Post: 02-25-2008, 06:28 PM
  3. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 09:47 AM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 06:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •