Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] Send mail to 50000 users once, ERROR...

  1. #1
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Unhappy [SOLVED] Send mail to 50000 users once, ERROR...

    My zimbra editon is OSS 509. OS : RedHat AS5. 2 cpu ,1 G ram.

    I test to send a mail to a distribute list named all@domain, which has 50000 users . For speed reasons , i shut down the anti-spam and anti-virus process. But some errors stiil occoured. As follows is the log:

    Oct 17 21:58:20 mail postfix/qmgr[27088]: 6DD00160646: to=<test24127@domain>, orig_to=<all@domain>, relay=none, delay=13413, delays=9310/4103/0/0, dsn=4.3.0, status=deferred (mail transport unavailable)

    (conversation wi th mail.domain[192.168.1.135] timed out while sending end of data -- message may be sent more than once)

    Some suggestion ? Thanks!
    Ask Forever...

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    That is because you have shutdown AmavisD. Could you not just de-select AV/AS from the Admin GUI and then restart ZCS ?

  3. #3
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Default Maybe I described not clearly.

    Now I will show you what I did before.

    First time :

    I kept antiviurs and antispam running , and I sent a mail to the distribution list all@domain,which has 50000 users. At the beginning , maybe 3 o 5 mails was delivered to user's mailbox . And then , the system seems fall asleep , I searched the log , found that large numbers of mails were delivered to port 10024 to filter spam and to anti-virus. At last , i gave up .

    Second time :

    I shut down the antispam and antivirus by command :
    "zmprov ms `hostname` -zimbraServiceEnabled antivirus" and
    "zmprov ms `hostname` -tmailerServiceEnabled antispam" . This time seems a little good , but after delivering 7000 or 8000 mails correctly , the system fall a sleep again , I search the log , and find the following error info:

    Oct 17 21:58:20 mail postfix/qmgr[27088]: 6DD00160646: to=test24127@domain, orig_to=all@domain, relay=none, delay=13413, delays=9310/4103/0/0, dsn=4.3.0, status=deferred (mail transport unavailable)

    (conversation with hostname [192.168.1.135] timed out while sending end of data -- message may be sent more than once)

    Lots of these info in the log. Looks like the mta cannot process the huge data .

    Am I clear ? Any suggestion?
    Thanks!
    Ask Forever...

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Well for a start 1GB of RAM is pretty low for a ZCS installation (according to the install guide that is the minimum).

  5. #5
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Talking My mistake!!!

    My mistake , It's 4 ram , not 1 ram .

    sorry !
    Ask Forever...

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Is your server going external for DNS lookups ?

  7. #7
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Default No , I only send mail from local domain to local doman.

    No , I only send mail from local domain to local doman.
    Ask Forever...

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    If they are all going to the same domain you could look at increasing the max number of simultaneous messages that get delivered. The default is 20 according to Postfix Configuration Parameters.

  9. #9
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Default Maybe is not.

    Thanks for your replies first.

    Although I have already incerased the number of default_destination_concurrency_limit , but I think the problem is not in postfix,maybe is in mailbox . because i found lots of mails sent by mta to mailbox , this means mta is health. However , mailbox cannot deliver mails to users mailbox . so the log display those error info.

    Does some parameters like "default_destination_concurrency_limit" can increase the number of lmtp ? Or some else ?

    Thanks!
    Ask Forever...

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    su - zimbra
    zmprov gs `hostname` zimbraLmtpNumThreads
    default is 20 so you could increase it using
    Code:
    zmprov ms `hostname` zimbraLmtpNumThreads 40
    zmlocalconfig -e postfix_lmtp_destination_concurrency_limit=40
    though by doing this the server may be spending most of its time attempting to deliver messages and not servicing other requests. These are all documented in Performance Tuning Guidelines for Large Deployments - Zimbra :: Wiki.
    Last edited by uxbod; 10-23-2008 at 02:12 AM.

Similar Threads

  1. Replies: 48
    Last Post: 09-18-2012, 08:49 AM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. Replies: 2
    Last Post: 02-12-2008, 10:55 AM
  4. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-03-2006, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •