Results 1 to 9 of 9

Thread: Reinstall the operate system but keep /opt .

  1. #1
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Default Reinstall the operate system but keep /opt .

    hello, all
    my zimbra edition is zcs509 open source. Os : redhat as 5 32-bit.

    I have installed zcs 509 on redhat as5 yesterday. but today ,for some grub reasons , i reinstall the operate system, but i keep the /opt directory with no change. After finishing the reinstall . I checked the proces :
    antispam Running
    antivirus Running
    ldap Running
    logger Stopped
    logmysql.server is not running
    zmlogswatchctl is not running
    mailbox Running
    mta Running s
    nmp Stopped swatch

    but i can send/recieve mails as usual.

    when i restart logmysql.server , it told me , cannot find /var/log/zimbra.log files.
    so can somebody help me ?
    how can i make all the process run correctlly?
    thanks!
    Ask Forever...

  2. #2
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Default additional

    Additionally , in normal circumstances, when i restart the server , all the process of zimbra are running automaticlly, but now my server can not keep all the process on after restart the server . So once i shutdown or resart the server , i have to restart the process manually.

    any suggestion ?
    Ask Forever...

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    First of all backup /opt ! As you have re-installed the server you will have lost files in /etc/init.d that are put there as part of the ZCS installation. Once you have performed the backup, download the same version of ZCS again, and perform a dummy installation. Details are documented in the Backup and Restoring ZCS OSS Edition :: Wiki article.
    Last edited by uxbod; 10-29-2008 at 01:23 AM.

  4. #4
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Default The page cannot be opened!

    Thanks for your apply , but it seems that the page cannot open ?
    Ask Forever...

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Sorry Cut and paste went a bit wrong Try the link again in my post as I have updated it.

  6. #6
    Join Date
    Aug 2008
    Posts
    87
    Rep Power
    7

    Default ok, thanks a lot

    Ok , thanks a lot!
    Ask Forever...

  7. #7
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    rerun the zimbra installer. zimbra doesn't just live in /opt/zimbra, it also makes alterations to sudoers, crontab, syslog, init etc which all live outside of /opt.

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    The dummy install as in the wiki article should take care of that.

  9. #9
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    oh yes. sorry, can't read.

Similar Threads

  1. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 06:52 AM
  2. Replies: 8
    Last Post: 10-19-2008, 09:52 AM
  3. Replies: 4
    Last Post: 10-08-2008, 06:55 AM
  4. Replies: 4
    Last Post: 08-04-2008, 06:17 PM
  5. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •