Results 1 to 3 of 3

Thread: enable remote debug

  1. #1
    Join Date
    May 2008
    Posts
    24
    Rep Power
    7

    Default enable remote debug

    Hey guys!

    I would like to enable remote debug of the Zimbra server from Eclipse. I tried to use the information stated in jetty.txt to connect to the server but no success. I read also the posts here in the forum () but it seem that they are very old. Maybe someone could update them.

    What have I done: as far as I have understood from all the hints given in the posts, I would have to set only the following java arguments for jetty '-Xdebug -Xnoagent -Djava.compiler=NONE -Djava.library.path=/opt/zimbra/lib -Xrunjdwp:transport=dt_socket,address=4000,server=y ,suspend=y'.

    I tried first to set them manually in the config files of jetty. But then I realized that there exists the tool 'zmlocalconfig' with which I can set these arguments. I set the arguments for the zmmailboxd. The entry looks like this one:
    Code:
    mailboxd_java_options = -client -XX:NewRatio=2 -Djava.awt.headless=true -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1 -Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,address=4000,server=y,suspend=n
    But now, the mailbox demon doesn't start up any more. I tried to search a bit in the log files but could not get any clue.

    What did I wrong?

    All suggestions are appriciated.

  2. #2
    Join Date
    May 2008
    Posts
    24
    Rep Power
    7

    Default

    Got no one a clue?

  3. #3
    Join Date
    Apr 2009
    Posts
    1
    Rep Power
    6

    Default

    The default launcher program allows only a certain set of JVM options. The JDWP options require the use of the unrestricted version.

    You should perform the followings before restarting the mailbox service:

    Code:
    (as root) 
     # cd /opt/zimbra/libexec/
     # mv zmmailboxdmgr zmmailboxdmgr.org
     # ln -s zmmailboxdmgr.unrestricted zmmailboxdmgr

Similar Threads

  1. 'Couldn't access Yahoo! Zimbra Desktop server"
    By chirag1 in forum Error Reports
    Replies: 37
    Last Post: 06-12-2011, 06:14 PM
  2. [SOLVED] Sudden problem synching with gmail
    By bouchardpie in forum Error Reports
    Replies: 8
    Last Post: 09-09-2010, 10:50 AM
  3. Unable to access Yahoo account via Zimbra Desktop
    By drdrem in forum Error Reports
    Replies: 10
    Last Post: 10-13-2009, 02:30 PM
  4. Moving to different server
    By AaronW1000 in forum Installation
    Replies: 2
    Last Post: 07-03-2008, 08:39 AM
  5. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 03:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •