Results 1 to 2 of 2

Thread: [SOLVED] problem with soap service and port 993/995

Hybrid View

  1. #1
    Join Date
    Sep 2007
    Rep Power

    Default [SOLVED] problem with soap service and port 993/995

    I have a very strange problem with my zimbra server on solaris, version 5.0.15, the result of upgrade of 4.5.4 made by dijichi2. May be somebody can help me by pointing out where to look for the problem.

    The server 4.5.4 had name different from certificate name, so before doing upgrade I disabled all ssl and tls ports and services.
    After upgrade it is working pretty well, zimbraMailMode=mixed, listens on ports 80, 443, 7071, 110 and 143. It recognized the certificate and because I've renamed the server after upgrade, it uses it.
    But when I tried to enable Imap SSL or Pop3 SSL services, it results in service soap failure to start.
    The most intriguing thing - after changing Imap SSL port to bind to to something like 8993, it starts and works perfectly, with soap service and all others. But when I change port to anything below 1024, like 994 - it fails:
    2009-04-01 00:02:47,925 FATAL [main] [] soap - Unable to start servlet
    com.zimbra.common.service.ServiceException: system failure: Could not bind to port=993 bindaddr=null ssl=true useChannels=false
    at com.zimbra.common.service.ServiceException.FAILURE (
    at com.zimbra.common.util.NetUtil.getServerSocket(Net
    at com.zimbra.common.util.NetUtil.getSslTcpServerSock et(
    at com.zimbra.cs.server.ServerConfig.getServerSocket(
    at com.zimbra.cs.tcpserver.TcpServer.<init>(TcpServer .java:46)
    at com.zimbra.cs.imap.ImapServer.<init>(ImapServer.ja va:50)
    at com.zimbra.cs.imap.ImapServer.startServer(ImapServ
    at com.zimbra.cs.imap.ImapServer.startupImapSSLServer (
    at com.zimbra.cs.util.Zimbra.startup(
    at com.zimbra.cs.util.Zimbra.startup(
    at com.zimbra.soap.SoapServlet.init( 117)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:241)
    at org.mortbay.jetty.servlet.ServletHolder.initServle t(
    at org.mortbay.jetty.servlet.ServletHolder.doStart(Se
    at org.mortbay.component.AbstractLifeCycle.start(Abst
    at org.mortbay.jetty.servlet.ServletHandler.initializ e(
    at org.mortbay.jetty.servlet.Context.startContext(Con
    at org.mortbay.jetty.webapp.WebAppContext.startContex t(
    at org.mortbay.jetty.handler.ContextHandler.doStart(C
    at org.mortbay.jetty.webapp.WebAppContext.doStart(Web
    at org.mortbay.component.AbstractLifeCycle.start(Abst
    at org.mortbay.jetty.handler.HandlerCollection.doStar t(
    at org.mortbay.jetty.handler.ContextHandlerCollection .doStart(
    at org.mortbay.component.AbstractLifeCycle.start(Abst
    at org.mortbay.jetty.handler.HandlerCollection.doStar t(
    at org.mortbay.component.AbstractLifeCycle.start(Abst
    at org.mortbay.jetty.handler.HandlerWrapper.doStart(H
    at org.mortbay.component.AbstractLifeCycle.start(Abst
    at org.mortbay.jetty.handler.HandlerWrapper.doStart(H
    at org.mortbay.jetty.Server.doStart(
    at org.mortbay.setuid.SetUIDServer.doStart(SetUIDServ
    at org.mortbay.component.AbstractLifeCycle.start(Abst
    at org.mortbay.xml.XmlConfiguration.main(XmlConfigura
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
    at java.lang.reflect.Method.invoke(
    at org.mortbay.start.Main.invokeMain(
    at org.mortbay.start.Main.start(
    at org.mortbay.start.Main.main(
    Caused by: Permission denied
    at Method)
    at :359)
    at com.zimbra.common.util.NetUtil.newBoundServerSocke t(
    at com.zimbra.common.util.NetUtil.getServerSocket(Net
    ... 38 more
    2009-04-01 00:02:47,929 WARN [main] [] log - failed SoapServlet
    Will appreciate any help.

  2. #2
    Join Date
    Sep 2007
    Rep Power


    The problem was in /opt/zimbra/jetty/etc/, although updated each time by zmmtaconfigctl, but - wrongly, and it did not have zimbraImapSSLServerEnabled=true and zimbraPop3SSLServerEnabled=true, but "falses".

Similar Threads

  1. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  2. Installation Problem - Possibly LDAP
    By geroshea in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 05:47 AM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  4. Replies: 21
    Last Post: 08-29-2006, 09:47 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts