Results 1 to 7 of 7

Thread: Background Images

Hybrid View

  1. #1
    Join Date
    Jun 2009
    Posts
    1
    Rep Power
    6

    Default Background Images

    I am trying to place background images in a newsletter, but it seems that zimbra strips it out no matter which method I try. I have used inline styles
    Code:
    (style="background-image:url(http://www.whateverimage.com/image.jpg)">
    , the background property of tables, and just setting a background for the body. No matter what I do, it gets stripped out and looks like this once I send the email and it is received by someone with zimbra:
    Code:
    (style="background-image: none;"

  2. #2
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    6

    Default

    I've got the same problem - didn't find any information concerning that issue yet

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    How is the email being generated ? Could you expand please on exactly what you are doing ?

  4. #4
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    6

    Default

    I've got some div elements in my HTML mail with a background image definition in the style attr. - when receiving the mail, it looks like that: style="background-image:none; ..."

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Would you be able to post a example so that I can run through my ZCS installation ? Have you checked /var/log/zimbra.log to see whether Amavis is stripping it out ?

  6. #6
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    6

    Default

    I can mail you an example if you give me your email address

    I'd rather suspect the client, as I did try to view the mail in other clients and it did show the background images - so there wasn't any stripping from amavis happening there

  7. #7
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    6

    Default

    You could also just write yourself an HTML email with some tag containing a background-image style definition

Similar Threads

  1. expected behavior of forwarding messages with images
    By bdial in forum Administrators
    Replies: 0
    Last Post: 02-01-2009, 05:57 AM
  2. Can't display images
    By loupy in forum Users
    Replies: 10
    Last Post: 09-21-2006, 10:21 AM
  3. Embedded images in html mail
    By Dirk in forum Users
    Replies: 2
    Last Post: 08-02-2006, 11:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •