First off, hello!

Our company has a random mysql table with contact information that I am trying to get accessable over to Zimbra's Address book so we can ultimately sync that information with iPhone.

Here's the issue!
I'm using this header to put data into a user's contact system(via: sudo /opt/zimbra/bin/zmmailbox -z -m pru /Contacts awesome.csv ).

the header:
"Business City","Business Country","Business Fax","Business Phone","Business Phone 2","Business Postal Code","Business State","Business Street","Business Street 2","Business Street 3","Callback","Car Phone","Company","Company Main Phone","Department","E-mail Address","E-mail Display Name","E-mail Type","E-mail 2 Address","E-mail 2 Display Name","E-mail 2 Type","E-mail 3 Address","E-mail 3 Display Name","E-mail 3 Type","First Name","Home City","Home Country","Home Fax","Home Phone","Home Phone 2","Home Postal Code","Home State","Home Street","Home Street 2","Home Street 3","Initials","Job Title","Last Name","Middle Name","Mobile Phone","Notes","Other City","Other Country","Other Fax","Other Phone","Other Postal Code","Other State","Other Street","Other Street 2","Other Street 3","Pager","Suffix","Web Page"

Now, that's great. I need to be able to put notes into the system, which I can do(because I'm doing fancy syncing to manage personal contacts and business contacts).

The downside comes here, when I try to get a user's address book in CSV.
I run:
sudo /opt/zimbra/bin/zmmailbox -z -m getRestURL "Contacts?fmt=csv" > my_contacts.csv

And the header I get for the information out of there is:
"company","email","email2","firstName","homePhone" ,"homeState","homeStreet","jobTitle","lastName","m obilePhone","otherCity","workCity","workPhone","wo rkPhone2","workPostalCode","workState","workStreet "

I've even gotten some though where the second field is "dlist"(what is dlist anyway?).

The note that I put into in the original field(which works fine.) comes out under "otherCity" when I run the export. This is obviously less than optimal if my data is just being tossed around randomly into generated CSV files.

Is this a known bug? Is there a workaround?

Please Help! I just want some consistency here in imports/exports!