Results 1 to 2 of 2

Thread: Message ID IMAP mapping to Message ID in Store

  1. #1
    Join Date
    Jul 2008
    Posts
    9
    Rep Power
    7

    Default Message ID IMAP mapping to Message ID in Store

    Hello,

    I'm writing an application that will directly download attachments through the /service/content/get?id=<id>&part=<part> url. I would like to bring down the message via IMAP but not the actual attachments. I want to provide a link to the attachments via http.

    I would like to know how can you determine what the id is other than looking at the link in the Web UI? Is there a way to specify the actual IMAP Message ID to retrieve an attachment? What's the best way to do this?

    I hope I'm being clear enough. Thanks!

  2. #2
    Join Date
    Feb 2008
    Location
    Urbana-Champaign, IL
    Posts
    68
    Rep Power
    7

    Default Retrieving Zimbra message id from Message-ID: header

    Quote Originally Posted by crunch View Post
    Hello,

    I'm writing an application that will directly download attachments through the /service/content/get?id=<id>&part=<part> url. I would like to bring down the message via IMAP but not the actual attachments. I want to provide a link to the attachments via http.

    I would like to know how can you determine what the id is other than looking at the link in the Web UI? Is there a way to specify the actual IMAP Message ID to retrieve an attachment? What's the best way to do this?
    Use zmmboxsearch. i.e.

    /opt/zimbra/bin/zmmboxsearch -m user@example.com -q 'msgid:029301ca2bd7$8c4a19f0$a4de4dd0$@example.com '

    It will return an XML; you're interested in the 'id' attribute.

    Chris
    Last edited by lindsey; 09-02-2009 at 11:19 AM.

Similar Threads

  1. 'Couldn't access Yahoo! Zimbra Desktop server"
    By chirag1 in forum Error Reports
    Replies: 37
    Last Post: 06-12-2011, 06:14 PM
  2. [SOLVED] Sudden problem synching with gmail
    By bouchardpie in forum Error Reports
    Replies: 8
    Last Post: 09-09-2010, 10:50 AM
  3. [SOLVED] Zimbra desktop slowed down the system
    By hvle in forum General Questions
    Replies: 5
    Last Post: 03-23-2009, 06:32 PM
  4. Emails bouncing with "Error Text: 401,'null'"
    By sholden in forum Zimbra Connector for Outlook
    Replies: 27
    Last Post: 08-20-2008, 05:59 PM
  5. E61i IMAP sync - old bug back again?
    By matt_b in forum Zimbra Mobile
    Replies: 7
    Last Post: 08-10-2008, 03:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •