Results 1 to 7 of 7

Thread: Get GunsNRoses source with P4

  1. #1
    Join Date
    Jun 2009
    Posts
    12
    Rep Power
    6

    Default Get GunsNRoses source with P4

    Hi,

    I want to make Zimbra Server Open Source working on Ubuntu Server 9.04 system.

    I have an issue, how can I get GunsNRoses sources ???

    I have seen Final Release is out, I have try this :

    p4 -u public -P public1234 -c public-view //depot/zcs branches
    => no branch appears,

    so it's hard to find the right one

    I have try this :
    p4 -u public -P public1234 -c public-view sync -f //depot/zcs/GUNSNROSES/...

    and this
    p4 -u public -P public1234 -c public-view sync -f //depot/zcs/GunsNRoses/...

    but nothing appear !

    So any idea on how can I get this version ?

    The download page redirect to an Out of Date wiki,
    I have made a full working tuto from "main" version,

    I want to do the same for "GunsNRoses" one.

    Thanks for support

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    To get ZCS 6.0 GA it's GNRD5

    Current choices are:
    GNRD#
    Where # is 1, 2, 4, or 5 (there is no 3) to represent each of the drops (betas).

    (Eventually they'll be a plain 'GNR' once main moves on to Helix content.)
    Last edited by mmorse; 09-04-2009 at 06:04 AM. Reason: no 3

  3. #3
    Join Date
    Jun 2009
    Posts
    12
    Rep Power
    6

    Default

    so final source is not release yet ? v6 is not available on source ? but available in package ???

    I have test it, and it work

    p4 -u public -P public1234 -c public-view sync -f //depot/zcs/GNR-D5/...

    I have a bug in compilation, about java

    in ZimbraBuild/defs/plat_common.def, v 1.6 java jdk is required, but
    ./ZimbraBuild/buildZCS.sh don't accept more than v1.5 !!!

    so I have test both
    and none of them work !!!

    any idea ?

  4. #4
    Join Date
    Jun 2009
    Posts
    12
    Rep Power
    6

    Default

    well,

    I have get GNR-D5, and get GA_1805 (GA_1802 is available in package for download), is they a way to get this version ?

    Well, in this version they is a mistake

    JAVA 1.6.0_19 is require in platform conf, but the build system still validate 1.5 only !

    I have change it to 1.5.0_19 (the version that work well with zimbra), and it's working !

    they is another issue, in nginx, Werror make it not work ! I have remove it, and now it's ok !!!

    I don't understand how they build their package, this error is really obvious when you try to compile !

  5. #5
    Join Date
    Jan 2009
    Posts
    369
    Rep Power
    6

    Default

    have any new version of source code released?
    6.02?
    how do I know which version of source code released?
    I think we should have a document to guide the developers how to get the newest source code
    Last edited by dalmate; 11-06-2009 at 09:49 PM.

  6. #6
    Join Date
    Jun 2009
    Posts
    12
    Rep Power
    6

    Default

    I'm using Karmic now, I have to do something for building this on this version.
    It seems be be hard because of gcc version (too early).

    so, as soon as I have time, I will try it.

  7. #7
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    GNR-602 for 602, GNR-603 for 6.0.3, etc...
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Similar Threads

  1. Zimbra + Funambol Sync4j Code
    By KevinH in forum Mobility
    Replies: 563
    Last Post: 01-16-2010, 01:20 AM
  2. ISP mail connection errors out
    By egottwald in forum Error Reports
    Replies: 1
    Last Post: 10-13-2008, 10:59 PM
  3. [Installation] Zimbra Desktop - Ubuntu 8.04 Hardy
    By kaltera in forum Installation Help
    Replies: 1
    Last Post: 06-18-2008, 04:43 AM
  4. Sits at loading screen?
    By moshen in forum General Questions
    Replies: 8
    Last Post: 02-19-2008, 01:15 PM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •