Results 1 to 3 of 3

Thread: How to create message with attachments.

  1. #1
    Join Date
    Aug 2009
    Posts
    6
    Rep Power
    6

    Default How to create message with attachments.

    Hi everyone.

    I need an advice.
    Is the any way in ZCS to create new e-mail message in browser window with attached files?

    I've seen great link Mailto Links and Zimbra [How to] - Zomgee

    Author suggests to use link like .../zimbra?app=mail&view=compose&to=abbeyvet@outfront. net&bcc=apple@apple.com&subject=Hello%20Katherine& body=test

    It works but w/o attachments.

    As I see I have to use SOAP calls for my purpose.

    Dear all. Honestly speaking I'm new in SOAP and etc.

    Could someone point me the right way how to make massage with predefined attachment.
    I'm going to call special script on client's computer and transfer attachment as parameter.

    It should be something like
    user$ send_by_zimbra.sh ./file.txt user2@foo.com "Mail Subject"

    Thank you in advance.

  2. #2
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    10

    Default

    Why not just use the standard SMTP service? Unix has great support for it.

    Your best bet on actions like this is to install firebug on your browser. Turn on network tracing, and then send a email with a attachment. That will reveal the soap call that zimbra uses to deliver mail to the server.

    The other option - if you are delivering to a local user - is to use the LMTP port?

  3. #3
    Join Date
    Aug 2009
    Posts
    6
    Rep Power
    6

    Default

    Thank you for response.
    I will try to trace it via Firebug.

    The only one question is disturbing me.
    Am I right that I can call procedure of the mail creation on the client's browser side w/o any client's actions by magic SOAP request from my 3rd party software ?

Similar Threads

  1. 'Couldn't access Yahoo! Zimbra Desktop server"
    By chirag1 in forum Error Reports
    Replies: 37
    Last Post: 06-12-2011, 06:14 PM
  2. [SOLVED] Zimbra desktop slowed down the system
    By hvle in forum General Questions
    Replies: 5
    Last Post: 03-23-2009, 06:32 PM
  3. Emails bouncing with "Error Text: 401,'null'"
    By sholden in forum Zimbra Connector for Outlook
    Replies: 27
    Last Post: 08-20-2008, 05:59 PM
  4. Replies: 5
    Last Post: 08-05-2008, 11:25 AM
  5. Replies: 2
    Last Post: 05-20-2006, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •