Results 1 to 5 of 5

Thread: [SOLVED] Building Zimbra using Perforce - FAIL!

  1. #1
    Join Date
    Nov 2009
    Posts
    6
    Rep Power
    6

    Default [SOLVED] Building Zimbra using Perforce - FAIL!

    Ok, I've never used Perforce before, but I'm failing with my building of Zimbra at step 3. On the Basic Walkthrough, I've completed the 'export' command and the 'mkdir' command, but the 'p4' command fails with a message ...

    //depot/zcs/BRANCH/... - no such file(s)

    I've cut'n'pasted the command (./p4 -u public -P public1234 -c public-view sync -f //depot/zcs/BRANCH/...) into my terminal window, so there should be no errors. Have the 'options' for this step been superceeded?

    Thanks for any tips

  2. #2
    Join Date
    Nov 2009
    Posts
    6
    Rep Power
    6

    Default Using p4v on the Zimbra Server

    Following on from the problems in my previous post, I decided to download the p4v client so that I could visually navigate the repository and try and resolve the issue myself. The client requires me to log in with an account - which I don't have. And I'm not allowed to create an account either.

    Would it be out of place to ask for a 'public view of the repository' account for people such as myself, so that we can try and resolve problems ourselves?

  3. #3
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Welcome to the forums,

    Your gonna laugh, but the the answer is actually in your previous post: user is 'public' password is 'public1234' and client workspace is 'public-view' assuming you have a /home/public/p4/ that's writable.

    (Or /opt/zimbra-src or /site/src/zimbra/p4 or C:\p4 or /Users/public/p4 - every so often I clean up the extras and create some fresh linux, mac, and pc specific workspaces.)

    We are in the process of setting up p4web so you can navigate using just a browser, additionally there are occasional tars up on ZimbraCommunity - SourceForge.net

  4. #4
    Join Date
    Nov 2009
    Posts
    6
    Rep Power
    6

    Default

    :-)

    Thanks for that. I suppose the -u and -P options are obvious now that you've pointed them out, but I wouldn't have got the 'c' option. I suppose I was partially posting this so that you could see my thought processes, and how I was trying to resolve the issues I've encountered. I haven't currently got the time to look into learning about Perforce, so was hoping for some quick answers to my problems.

    I don't know if it's worth adding some of that info you've just posting into the 'Building Zimbra' wiki page - it's fully of meaty details ;-)

  5. #5
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

Similar Threads

  1. postfix relay=none status=bounced for local mails
    By vdd in forum Administrators
    Replies: 1
    Last Post: 08-06-2009, 09:05 AM
  2. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 04:23 PM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •