I have submitted a bug on this, but wanted to ask the question in the forums in case someone has some insight on it.

I had recently posted a question on the forums here:
http://www.zimbra.com/forums/showthread.php?t=3680

I followed the example and entered this command (I had already created the account):
zmprov ma catchall@domain.tld zimbraMailCatchAllAddress @domain.tld

I tested two emails addressed to:
RCPT TO:<something@domain.tld>
RCPT TO:"Some One"<something@domain.tld>

Both emails get delivered to the account catchall@domain.tld as expected, but the To: header has been changed to [To: undisclosed-recipients:;] instead of showing the correct header field [To: <something@domain.tld>] or [To: Some One <something@domain.tld>].

I can't tell if it's postfix or amavisd-new that is rewriting the header, most likely postfix. Is there a zimbraMailCatchAllCanonicalAddress option that needs to be added when creating a catchall account?
Any guidance would be greatly appreciated.