Results 1 to 8 of 8

Thread: Regressed enhancement - choosing a view via URL

  1. #1
    Join Date
    Nov 2005
    Posts
    55
    Rep Power
    9

    Default Regressed enhancement - choosing a view via URL

    It appears the 3.2 has regressed a previously working enhancement to be able to select a specific view via url. For example, going to /zimbra/mail?app=mail&view=compose&to=somebody@domain.com would take you directly to the compose page with the to address prefilled. This appears to no longer work in the 3.2 beta 2 release.

    I believe this was #6891 in bugzilla, which oddly was never marked closed or resolved but worked none-the-less in 3.1.1 onward. Did the parameters change? I hope its that simple because this is a very important feature for us and would repressent a major setback were it no longer functioning.

    Update
    We *also* were using ZmComposeController.doAction() at another point to change the view and this also seems to no longer work. So it may not be the parameter, but something else thats no longer working.
    Last edited by Coilcore; 08-15-2006 at 03:14 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Looks like your right, doesn't seem to work on my local build. Please file a bug or comment on the bug and we'll see if we can add it into the final release. If you've got the number handy just post the link here for others.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Bug 9688 has been filed to get this fixed for 4.0 GA
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  4. #4
    Join Date
    Nov 2005
    Posts
    55
    Rep Power
    9

    Default

    Thanks. But bug #9688 looks like something else about maintenance mode.

  5. #5
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Sorry bug 9968 (it's now fixed)
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  6. #6
    Join Date
    Nov 2005
    Posts
    55
    Rep Power
    9

    Default Not fixed in 4.0GA

    With 4.0GA released this is the first thing I've checked and its NOT fixed. This is a pretty core feature for us and seems like something that many people ask about. The most unfortunate thing is that we've been doing development against 4.0 and will be unable to release anything to our users until this bug is fixed.

    I'd go and comment on the bug but I get a giant " You are not authorized to access bug #9968."

  7. #7
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default Fixed the bug access

    You should now have full access to bug 9968. Sorry for the visibility issue!
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #8
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    This is working in the GA - correct qs is ?view=compose
    Bugzilla - Wiki - Downloads - Before posting... Search!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •