Results 1 to 4 of 4

Thread: New Skins

  1. #1
    Join Date
    Nov 2005
    Posts
    55
    Rep Power
    9

    Default New Skins

    I started trying to create a new skin by using existing skins as examples. Overall to do some simple stuff it looks fairly straight forward. I've copied the 'sand' theme files into a new directory called 'test', I changed the file names to match the new directory (test_subs.txt and test.xml), made some small changes to the a _subs file including changing the theme name to match the new directory, and finally changed the test.xml to reference test_subs.txt. It seems consistent with other themes.

    The one thing I cannot figure out is how to get my skin to show up as in 'installed UI themes' (obviously it can never be put into 'available' if I can't even get it to show as installed). I've restarted tomcat and I've restarted all of zimbra, I've flushed my browsers cache, but when I look at the 'installed UI themes' in the my new skin doesn't show up.

    I grepped through the source code to find references to the existing themes to see if there was some config file, but doing a grep -r 'lavender' trunk/* only finds the lavender xml file and _subs.

    Whats the magic I'm missing?
    Last edited by Coilcore; 08-17-2006 at 12:23 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    You need to use zmprov to add it to the list of skins

    zmprov gacf| grep -i skin

    This will give you the list of installed skins. Adding yours with zmprov and a restart will let it show up in the list.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Oct 2005
    Location
    Emeryville, CA US
    Posts
    22
    Rep Power
    10

    Default

    I'm also trying to deploy a custom skin (on ZCS 4.5). I've followed the instructions on these pages:

    http://wiki.zimbra.com/index.php?tit...etwork_Edition

    http://wiki.zimbra.com/index.php?tit...s_Long_Version

    Now my custom skin shows up in the admin UI in the list of available skins under "Limit Themes available to users in this COS to:", and users can select the skin. Yay!

    However, I don't see my skin in the menu next to "Current UI theme:" in the admin UI. I would like to make my custom skin the current theme, but I can't figure out a way to do that because I can't figure out how to get my custom skin into that menu. Is there another zmprov command or something that needs to be run to alter that menu?

  4. #4
    Join Date
    Oct 2005
    Location
    Emeryville, CA US
    Posts
    22
    Rep Power
    10

    Default

    Whoops! Nevermind. I see from this thread that I have to use IE in order to see my custom skin in the menu:

    http://www.zimbra.com/forums/showthr...=current+theme

    In FF2, after I've selected my custom skin as the current theme in IE, I see my custom skin selected, but it's still not actually in the menu. Funky...
    Last edited by sdouglass; 02-02-2007 at 03:59 PM.

Similar Threads

  1. installing new skins
    By santo in forum Users
    Replies: 2
    Last Post: 03-08-2007, 07:02 AM
  2. 3.2 Beta 2 M2 - New Skins Not Available
    By klarsen in forum Developers
    Replies: 1
    Last Post: 07-26-2006, 12:14 PM
  3. Skins and ALE
    By kowell in forum Administrators
    Replies: 4
    Last Post: 06-06-2006, 07:25 PM
  4. Skins / Theme Development
    By kbaker in forum Developers
    Replies: 4
    Last Post: 01-31-2006, 01:31 PM
  5. Doc about creating new Skins
    By nirg in forum Developers
    Replies: 3
    Last Post: 12-08-2005, 03:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •