Results 1 to 4 of 4

Thread: Another about install error for Postfix

  1. #1
    Join Date
    Aug 2006
    Posts
    64
    Rep Power
    9

    Question Another about install error for Postfix

    Hi, guys, I will be crazy.

    When I make postfix, it will report
    "bin/postconf: error while loading shared libraries:libldap-2.3.so.0: cannot open shared object file: No such file or directory"

    But in fact, this is is in the /opt/zimbra/openldap/lib,

    How should I do? Could some guys help me?

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    have you got /opt/zimbra/openldap/lib in /etc/ld.so.conf and run ldconfig?

  3. #3
    Join Date
    Aug 2006
    Posts
    64
    Rep Power
    9

    Talking

    Quote Originally Posted by dijichi2
    have you got /opt/zimbra/openldap/lib in /etc/ld.so.conf and run ldconfig?
    Just it is. Thank you very much. Although there are some comment
    "no version information avaliable.."
    I think it is ok.

    But there is not any requirement about add this lib to ld.so.conf, so I only add mysql/lib.

    BTW, is there other lib should be added in the ld.so.conf?

  4. #4
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    unfortunately each unix platform deals with shared libs differently. for some reason -R runtime linkpath hints don't seem to get used in linux, unlike solaris for instance so either setting LD_LIBRARY_PATH (not advised) or /etc/ld.so.conf is necessary. if you get any lib missing errors chances are you will have to add them, because all the zimbra stuff builds in nonstandard place outside the FHS. i would expect you to have to add any core lib paths like berkeleydb, ldap, sql, kerberos, ssl (cant remember if they come with zimbra, dont think so).

Similar Threads

  1. Replies: 11
    Last Post: 02-23-2014, 01:08 PM
  2. fresh install (both OS and Zimbra) but zimbra-spell fails
    By xtremetoonz in forum Installation
    Replies: 14
    Last Post: 09-09-2007, 01:34 AM
  3. INSTALLATION PROBLEM ON Centos 4.3 x_86-64Bit.
    By jawad@cogilent.com in forum Installation
    Replies: 11
    Last Post: 07-09-2007, 09:09 AM
  4. Replies: 16
    Last Post: 11-29-2006, 10:36 AM
  5. Fail to install on Debian
    By hsrai in forum Installation
    Replies: 2
    Last Post: 03-25-2006, 04:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •