Results 1 to 4 of 4

Thread: [SOLVED] After request I get (500) Internal Server Error

  1. #1
    Join Date
    Jul 2010
    Posts
    4
    Rep Power
    5

    Default [SOLVED] After request I get (500) Internal Server Error

    I can't seem to get off first base using c# with soap. My XML message is:

    <?xml version='1.0'?>
    <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
    <soap:Header>
    <context xmlns="urn:zimbra"/>
    </soap:Header>
    <soap:Body>
    <AuthRequest xmlns="urn:zimbraAdmin"><name>user@domain</name><password>password</password></AuthRequest>
    </soap:Body>
    </soap:Envelope>

    and my code is

    AuthToken = getAuthRequest("user@domain", "password");

    HttpWebRequest webrequest = (HttpWebRequest)WebRequest.Create("https://domain:7071/service/admin/soap");
    webrequest.Headers.Add("SOAPAction", "\"\"");
    webrequest.Method = "POST";
    webrequest.ContentType = "text/xml;charset=\"utf-8\"";

    XmlDocument requestDoc = new XmlDocument();
    requestDoc.LoadXml(AuthToken);

    System.IO.Stream str = webrequest.GetRequestStream();

    requestDoc.Save(str);
    str.Close();

    HttpWebResponse webresponse = (HttpWebResponse)webrequest.GetResponse();

    ==================================================
    I've compared this to other examples I've found on the web and can't see where I have gone wrong.

  2. #2
    Join Date
    Jul 2010
    Posts
    4
    Rep Power
    5

    Default

    I managed to get it to work by using the admin user but using any other user (even with domain/service/soap) gave the error.
    I can't understand this how does the zimbra standalone program log in?

  3. #3
    Join Date
    May 2010
    Posts
    37
    Rep Power
    5

    Default

    be sure to watch log, if any request goes to zimbra , an entry will be there in the the following log file,

    run, this command
    tail -f /opt/zimbra/log/mailbox.log

  4. #4
    Join Date
    Jul 2010
    Posts
    4
    Rep Power
    5

    Default

    I found that there are two versions of the AuthRequest request. I've just done a few more changes and it is annoying getting the 500 server errors rather than something meaningful.

Similar Threads

  1. Replies: 9
    Last Post: 02-25-2009, 04:39 AM
  2. Error after installation
    By robsontuxlinux in forum Installation
    Replies: 13
    Last Post: 09-11-2008, 10:48 PM
  3. Replies: 4
    Last Post: 08-04-2008, 07:17 PM
  4. [SOLVED] upgrade zimbra 5.0.2 32 bit to 64 bit
    By jwilson in forum Installation
    Replies: 1
    Last Post: 03-11-2008, 01:15 PM
  5. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 11:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •