Results 1 to 1 of 1

Thread: [SOLVED] Zimbra 6.0.8 CreateAppointmentRequest creates appointment with length of app

  1. #1
    Join Date
    Mar 2011
    Location
    Lansing, MI
    Posts
    17
    Rep Power
    4

    Default [SOLVED] Zimbra 6.0.8 CreateAppointmentRequest creates appointment with length of app

    Solved: this was bad XML. <s> element and <e> element are siblings; I put <e> element as child to <s>.

    Making SOAP request (shown below) to create appointment, results in appointment 1 second long. Also, this call allows entering duplicate busy events at same time (that may be correct).

    I tried this using <e d="20110405T131500Z"/>, and tried using <dur m="30"/>, both resulting with same results.

    Please give advise on how to properly create appointment of any given length (15 min, 1/2 hour, 1 hour, etc).


    Thank you,
    Ray


    Zimra full version info: Release 6.0.8_GA_2661.RHEL5_64_20100824100342 CentOS5_64 NETWORK edition.

    Here is example request being made (left out SOAP envelope -- let me know if you need the entire request):
    Code:
    <zmail:CreateAppointmentRequest>
    	<m l="10">
    		<su>SOAP Appointment</su>
    		<inv>
    			<comp
    					name="Test 04-05 15min"
    					status="COMP"
    					fb="B"
    					fba="B"
    					url="https://www.egr.msu.edu/test/adcalendar/">
    				<s d="20110405T130000Z">
    					<e d="20110405T131500Z"/>
    				</s>
    			</comp>
    		</inv>
    	</m>
    </zmail:CreateAppointmentRequest>
    Last edited by raymond.naseef; 04-05-2011 at 08:32 AM.

Similar Threads

  1. Old Backup stay in TO_DELETE status and no clearing..
    By bartounet in forum Administrators
    Replies: 0
    Last Post: 10-05-2010, 08:40 AM
  2. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  3. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  4. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 09:56 PM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •