Results 1 to 3 of 3

Thread: [SOLVED] Caracters encoding

  1. #1
    Join Date
    May 2011
    Posts
    6
    Rep Power
    4

    Default [SOLVED] Caracters encoding

    Hello,

    I'm a french user and i developped a script which made a backup of Zimbra mails.

    I'm using zmmailbox in order to realize a tar.gz of my Zimbra accounts.

    But, when i open a EML file, special caracters are replaced by others :

    Code:
    je t=C3=A8ste l=C3=A9s =C3=A0ccents, qui se trouve l@ o=C3=B9 l=C3=A0.
    But, the original mail is :

    Code:
    je tèste lés àccents, qui se trouve l@ où là.
    When i restore, no problems, but i want to display the mail...

    What's the problem ? How do i re-encode my special caracters ?

    Thanx.

  2. #2
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    There isn't any problem.
    It is normal that the characters in the eml format file are encoded.
    From what I see, the mail body is encoded in quoted-printable.

    To see the encoding, check the Content-Transfer-Encoding header in the eml file.

  3. #3
    Join Date
    May 2011
    Posts
    6
    Rep Power
    4

    Default

    I know there isn't any problem...

    But, i found qprint, a command which re-encode my eml. Perfect !

Similar Threads

  1. Zimbra soap and encoding
    By mimmo1 in forum Developers
    Replies: 0
    Last Post: 04-14-2011, 01:39 AM
  2. Replies: 0
    Last Post: 02-07-2011, 06:16 AM
  3. Subject encoding problem
    By deepblue in forum Administrators
    Replies: 5
    Last Post: 04-01-2008, 10:30 AM
  4. Default Encoding change in 4.0.3???
    By inigoml in forum Administrators
    Replies: 0
    Last Post: 10-30-2006, 07:07 AM
  5. message body Encoding.
    By mmt in forum Developers
    Replies: 0
    Last Post: 10-26-2005, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •