Results 1 to 3 of 3

Thread: Add Custom Attribute in LDAP

  1. #1
    Join Date
    Mar 2011
    Posts
    131
    Rep Power
    4

    Default Add Custom Attribute in LDAP

    Hello,

    I would like to be able to add some more attributes to Zimbra's user database. For example:
    I want to display message when a user first time login (it would be a flag) and also want to store a PIN assigned to him.

    Please let me know if is there any way to do it.

    Thank You!

  2. #2
    Join Date
    Mar 2011
    Posts
    131
    Rep Power
    4

    Default

    anybody. Please.

  3. #3
    Join Date
    Mar 2011
    Posts
    131
    Rep Power
    4

    Default

    I did following steps to add new attribute. Please tell me what is wrong in it. Coz zimbra gives me an error while creating new user. That the type does not exits.

    1. I went to /opt/zimbra/data/ldap/config/cn=config/cn=schema
    2. And I've created a new file named "cn={11}custom.ldif" and added following content to it.
    Code:
    dn: cn={11}custom
    objectClass: olcSchemaConfig
    cn: {11}custom
    
    olcObjectIdentifier: zimbraAccountGId ZimbraAttrType:5001
    
    olcAttributeTypes: ( zimbraAccountGId
      NAME ( 'zimbraAccountGId' )
      DESC 'G ID type'
      SYNTAX 1.3.6.1.4.1.1466.115.121.1.15{32}
      EQUALITY caseIgnoreMatch
      SUBSTR caseIgnoreSubstringsMatch
      SINGLE-VALUE)
    
    olcObjectClasses: ( zimbraCustomClass 
      NAME 'zimbraCustomClass'
      DESC 'Custom class'
      SUP  zimbraMailRecipient AUXILIARY
      MAY (
        zimbraAccountGId $
      )
      )
    3. And restarted ldap.

    But I am getting an error that the zimbraAccountGId does not exists while adding new user.

    Please help me if you can.

    Thanks.

Similar Threads

  1. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 02:08 AM
  2. [SOLVED] Can't receive messages from Gmail
    By agfeller in forum Administrators
    Replies: 4
    Last Post: 02-04-2008, 10:16 AM
  3. Postfix problem
    By jimbo in forum Administrators
    Replies: 46
    Last Post: 07-23-2007, 05:24 AM
  4. Zimbra + Samba LDAP, cannot add winxp
    By fajarpri in forum Installation
    Replies: 4
    Last Post: 07-08-2007, 11:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •