Results 1 to 3 of 3

Thread: Developing on the SVN HEAD

  1. #1
    Join Date
    Nov 2006
    Rep Power

    Default Developing on the SVN HEAD


    I would like to look into fixing some bugs with the Zimbra Web Client, as I am a AJAX guy and not a backend developer.

    I have currently installed the Ubuntu binary version of Zimbra, but I would like to hack on the SVN version. Is there an easy way to install the SVN version? Or is it possible to only use the SVN version of the ZimbraWebClient and run it together with the other binary packages? (I guess not, but it would be convenient

    The information about installing from SVN (from ZimbraServer/docs/) seemed a bit outdated. Is there any newer information available?

  2. #2
    Join Date
    Aug 2005
    San Mateo, CA
    Rep Power


    Moved to dev forum. The easiest way to develop would be to setup a local developer build. So looking at INSTALL.txt in the docs dir as a guide. Basically you'll install ant, open ldap, java jdk, mysql, tomcat, etc all locally. Then use the ant commands to build and deploy a local system. This is easier to do on a seperate machine and not on the same machine that is already running Zimbra.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Nov 2006
    Rep Power


    Thank you.

    I have now installed Zimbra from SVN trunk, on Windows by following your INSTALL.txt. It worked as described, the only problem I had was that ant refused to run properly from within Eclipse. When I stared it from the command line it build and deployed the project properly. I also had some problems trying to build it from a path which contained spaces.

    I now have it installed and I am able to open the login screen from http://localhost:7070/zimbra/ and the admin interface from https://localhost:7071/zimbraAdmin

    But I am still not able to log in. When trying to log in with Firefox I get an error saying:

    "Error: this._setIdentityVisibility is not a function
    Line: 1284".
    I have searched through all the source code and can not find anywhere where this function is defined.

    Is this a known error? I am doing something wrong or is this a bug?
    Last edited by Sverre Johansen; 11-23-2006 at 07:39 AM.

Similar Threads

  1. Replies: 12
    Last Post: 09-11-2007, 04:35 PM
  2. Replies: 1
    Last Post: 06-23-2007, 04:23 PM
  3. Need guidance for developing zimlets
    By jiggy in forum Developers
    Replies: 12
    Last Post: 02-23-2007, 03:32 AM
  4. language files in svn?
    By goetzi in forum I18N/L10N - Translations
    Replies: 3
    Last Post: 09-29-2006, 02:47 PM
  5. SVN Trunk and Branches
    By kenny810 in forum Developers
    Replies: 3
    Last Post: 09-18-2006, 03:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts