Results 1 to 4 of 4

Thread: Faulty JSON response for SendMsgResponse

  1. #1
    Join Date
    Feb 2013
    Location
    India
    Posts
    28
    Rep Power
    2

    Default Faulty JSON response for SendMsgResponse

    Hi,

    according to soap structure for SendMsgResponse the response should be,

    <SendMsgResponse> ## SendMsgResponse
    <m [id="..."] /> ## Id
    </SendMsgResponse>

    but what i am getting in JSON response is,something like this.

    {"SendMsgResponse":{"m":[{"id":"2425"}],"_jsns":"urn:zimbraMail"}},"_jsns":"urn:zimbraSoa p"}

    note that [ and ]. there should be no squre braces in m tag. this is same issue like http://www.zimbra.com/forums/develop...threquest.html. i request moderators as well as active developer to check this issue and raise a bug if it is a bug.

    Thank You.

    Parin Dholakia,
    India.

  2. #2
    Join Date
    Aug 2010
    Location
    England
    Posts
    39
    Rep Power
    5

    Default

    Hi Parin,
    This issue has the same root cause as for AuthRequest - I've updated Bug 85110 ? JAXB/Documentation for SOAP AuthResponse is incorrect - authToken is an array, not a singleton to mention it.
    Thanks,
    Gren
    Gren Elliot
    Lead Engineer - Server
    Zimbra | Community & Collaboration

  3. #3
    Join Date
    Feb 2013
    Location
    India
    Posts
    28
    Rep Power
    2

    Default

    Thank you @gren.
    Parin S.Dholakia,
    India

  4. #4
    Join Date
    Feb 2013
    Location
    India
    Posts
    28
    Rep Power
    2

    Default

    @Gren

    Hi,

    i discoverd same issue in SaveDraftResponse as well. so i think the API documentation should be reassessed !. please report it.

    Thank You.
    Parin S.Dholakia,
    India

Similar Threads

  1. strange JSON response for AuthRequest.
    By parin in forum Developers
    Replies: 2
    Last Post: 11-26-2013, 08:55 PM
  2. Replies: 0
    Last Post: 05-02-2012, 04:38 AM
  3. BAD JSON RESPONSE on SearchDirectoryRequest
    By Srikanth G in forum Administrators
    Replies: 3
    Last Post: 01-11-2010, 05:44 AM
  4. BAD JSON RESPONSE on SearchDirectoryRequest
    By anthony.rasat in forum Administrators
    Replies: 15
    Last Post: 09-08-2009, 12:39 AM
  5. SOAP <-> JSON format
    By fernandoflorez in forum Developers
    Replies: 0
    Last Post: 02-22-2009, 11:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •