Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: Extending authentication

  1. #11
    Join Date
    Aug 2005
    Posts
    228
    Rep Power
    10

    Default

    strange. I just cut-and-pasted from the sample code again and it is working fine for me.

  2. #12
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default what am I missing?

    Nothing special on my end. I did copy and paste, modified DOMAIN_KEY, modified user1.

    I'm using https on port 8080.

    Does the error page give you any clue?

    Thanks.

  3. #13
    Join Date
    Aug 2005
    Posts
    228
    Rep Power
    10

    Default

    I'd look for a typo around the domain key line, or for any line wraps. You might also want to take the example verbatim and see if it works (i.e., compiles).

    I just changed the sample to be an attachment instead of inline code as well
    Last edited by schemers; 01-24-2006 at 01:16 PM. Reason: update

  4. #14
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default

    I loaded tomcat example, cal, it works. Please see this link:
    http://jian.cirrata.net/zimbra/cal/login.html

    I just copied and pasted your new jsp again, removed comments on the top, replaced domain_key and user, reviewed it with vi to make sure no line wrapper, BUT it gave me the same error:
    http://jian.cirrata.net/zimbra/preauth.jsp

  5. #15
    Join Date
    Aug 2005
    Posts
    228
    Rep Power
    10

    Default

    ok, it looks like it might be a tomcat versioning issue. As far as I can tell from the tomcat release notes:

    http://tomcat.apache.org/tomcat-5.5-doc/changelog.html

    they started support JDK 1.5 in JSPs around 5.5.10, I think we are shipping 5.5.9, and I'm running 5.5.12 on my Mac. I reproduced your error on another system, and I'll see if I can the example working on an earlier version, as well as ask that we upgrade our tomcat version.

  6. #16
    Join Date
    Aug 2005
    Posts
    228
    Rep Power
    10

    Default

    OK. I updated the example one more time, this time removing JDK 1.5-isms. This time it should hopefully work.

  7. #17
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default Thanks!

    It's working now. Please update your jsp when you have a new version of tomcat.

  8. #18
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default Progressing Page

    I gave a button to the users so they can jump into Zimbra WebMail directly. But they are frustrated by the progressing page before they get in. How to diable or hide this progressing page?

    Thanks.

  9. #19
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    That splash page is there while the application loads and caches the needed data, gets the first page of messages/conversations, etc. So if we were to remove it (which we don't plan to do) the user would just have a blank page during that time. In general after the first login the time spent on that page should be much shorter since user's will have the application, CSS, and images cached in their browser.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  10. #20
    Join Date
    Feb 2006
    Location
    Hungary, Budapest
    Posts
    14
    Rep Power
    9

    Exclamation about security

    Hi!

    I tried this pre-auth stuff and this is excellent

    i have only one question.

    If anybody gets the site-key, I messed up

    Is any security option apart from hide-ing security key.?
    for example accept pre-auth from only 1 ip address, and deny access from anywhere else?

    thanks
    Szabi

Similar Threads

  1. Does Zimbra support IMAP Secure Authentication?
    By zzzzsg in forum Administrators
    Replies: 6
    Last Post: 11-06-2009, 07:19 PM
  2. External Authentication with Active Directory via LDAPS
    By merrill in forum Administrators
    Replies: 1
    Last Post: 10-21-2007, 02:13 PM
  3. External LDAP Authentication Issue
    By xtreme-one in forum Installation
    Replies: 10
    Last Post: 02-16-2007, 07:52 PM
  4. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 03:17 PM
  5. ldap external authentication
    By tdi in forum Administrators
    Replies: 2
    Last Post: 10-21-2006, 05:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •