Results 1 to 5 of 5

Thread: [SOLVED] sync failure

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Location
    Netherlands
    Posts
    90
    Rep Power
    9

    Default [SOLVED] sync failure

    Hi,

    Almost finished syncing a large Zimbra account (completed 3.4 GB of 3.6 GB), a sync error occurs.
    I don't get an error report so I turned on DEBUG mode.
    mailbox.log now says:

    Code:
    2008-09-20 11:26:53,253 DEBUG [btpool0-0] [name=bart@abc.com;aname=local@host.local;mid=3;ip=127.0.0.1;ua=ZimbraWebClient - PRISM (Linux)/0.0;] request - GET https://webmail.abc.com/home/~/?fmt=tgz&list=34722,34721,34720,34719,34718,34717,34715,34714,34713,34712,34711,34710,34709,34708,34707,34706,34705,34704,34702,34700,34699,34697,34696,34694,34693,34692,34691,34690,34689,34688,34687,34686,34684,34683,34681,34680,34678,34677,34675,34673,34672,34671,34670,34669,34668,34667,34666,34665,34664,34663,34662,34661,34660,34659,34658,34657,34656,34655,34654,34653,34652,34651,34650,34649,34647,34646,34645,34644,34643,34641,34640,34639,34638,34637,34636,34635,34633,34631,34630,34628,34627,34626,34625,34624,34622,34621,34620,34619,34618,34617,34616,34615,34614,34613,34612,34611,34610,34609,34607,34606
    2008-09-20 11:26:53,422 ERROR [btpool0-0] [name=bart@abc.com;aname=local@host.local;mid=3;ip=127.0.0.1;ua=ZimbraWebClient - PRISM (Linux)/0.0;] offline - sync failure: bart@abc.com
    com.zimbra.common.service.ServiceException: system failure: InitialSync.syncMessagesAsTgz
    ExceptionId:btpool0-0:1221906413421:4c705020b968722b
    Code:service.FAILURE
            at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:253)
            at com.zimbra.cs.mailbox.SyncExceptionHandler.checkRecoverableException(SyncExceptionHandler.java:38)
            at com.zimbra.cs.mailbox.InitialSync.syncMessagesAsTgz(InitialSync.java:882)
            at com.zimbra.cs.mailbox.InitialSync.syncMessages(InitialSync.java:840)
            at com.zimbra.cs.mailbox.InitialSync.syncMessagelikeItems(InitialSync.java:423)
            at com.zimbra.cs.mailbox.InitialSync.initialFolderSync(InitialSync.java:313)
            at com.zimbra.cs.mailbox.InitialSync.prioritySync(InitialSync.java:387)
            at com.zimbra.cs.mailbox.InitialSync.initialFolderSync(InitialSync.java:372)
            at com.zimbra.cs.mailbox.InitialSync.initialFolderSync(InitialSync.java:377)
            at com.zimbra.cs.mailbox.InitialSync.resume(InitialSync.java:188)
            at com.zimbra.cs.mailbox.InitialSync.resume(InitialSync.java:174)
            at com.zimbra.cs.mailbox.MailboxSync.sync(MailboxSync.java:192)
            at com.zimbra.cs.mailbox.OfflineMailbox.sync(OfflineMailbox.java:115)
            at com.zimbra.cs.service.offline.OfflineSync.handle(OfflineSync.java:44)
            at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:411)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:268)
            at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:160)
            at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:266)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
            at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:188)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
            at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
            at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:362)
            at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
            at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
            at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:716)
            at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:406)
            at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:211)
            at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
            at org.mortbay.jetty.handler.RewriteHandler.handle(RewriteHandler.java:176)
            at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
            at org.mortbay.jetty.Server.handle(Server.java:313)
            at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506)
            at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:844)
            at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:644)
            at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
            at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381)
            at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396)
            at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)
    Caused by: com.zimbra.common.service.ServiceException: system failure: Unable to read/write message id=34722
    ExceptionId:btpool0-0:1221906413421:4c705020b968722b
    Code:service.FAILURE
            at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:253)
            at com.zimbra.cs.mailbox.InitialSync.saveMessage(InitialSync.java:1014)
            at com.zimbra.cs.mailbox.InitialSync.syncMessagesAsTgz(InitialSync.java:879)
            ... 37 more
    Caused by: java.io.IOException: unexpected EOF with 1 bytes unread
            at com.zimbra.common.util.tar.TarInputStream.read(TarInputStream.java:353)
            at com.zimbra.common.util.tar.TarInputStream.read(TarInputStream.java:298)
            at com.zimbra.common.util.ByteUtil.readInput(ByteUtil.java:614)
            at com.zimbra.cs.mailbox.InitialSync.saveMessage(InitialSync.java:1003)
            ... 38 more
    I had exactly the same promblem with this account on another zdesktop machine.
    I only have it with this account.
    I'm running zdesktop_0_90_build_1278_linux_i686.sh

    -Bart
    Last edited by eombah; 09-21-2008 at 03:30 AM.

  2. #2
    Join Date
    Nov 2006
    Location
    Netherlands
    Posts
    90
    Rep Power
    9

    Default

    I investigated some more.

    In firefox I navigate to https://webmail.abc.com/home/~/?fmt=tgz&list=34722

    this returns a tgz file. Opening it in File Roller fails.
    Command line output is:

    Code:
    tar: Unexpected EOF in archive
    tar: Error is not recoverable: exiting now
    Fetching the next message, 34723, opens fine in File Roller.
    So it looks as if there's something wrong with message 34722.

    I viewed message 34722 using more, there were strange characters in it and an attachment named winmail.dat.

    I couldn't delete the message using the Zimbra Advanced Client so I deleted it with Thunderbird, this worked.

    I killed the server part of zdesktop and restarted, after that it started to sync again, up until the message 35885. I couldn't delete this one from the Zmmbra Advanced Client nor using Thunderbird so I deleted it "hard" from the mail server's file system. Then restarted zdesktop and it's syncing again. Guess I'll have to reindex my mailbox.

    So in my case, syncing stopped working due to corrupted messages. I don't know how they got corrupted, I guess in one of the two migrations from Cyrus IMAP to zimbra that I have performed over the last two years.

    So for me this is SOLVED, I'll mark it as such.

    -Bart

  3. #3
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    You probably ran into this issue:

    Access Denied

  4. #4
    Join Date
    Nov 2006
    Location
    Netherlands
    Posts
    90
    Rep Power
    9

    Default

    I get:

    You are not authorized to access bug #31519.

  5. #5
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    my bad. i referenced a zimbra internal bug. sorry.

Similar Threads

  1. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 07:52 AM
  2. Replies: 13
    Last Post: 11-20-2008, 12:42 PM
  3. Replies: 4
    Last Post: 08-04-2008, 07:17 PM
  4. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 02:01 PM
  5. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 03:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •