Results 1 to 9 of 9

Thread: ZD 0.92 Offline function doesn't work on Mac

  1. #1
    Join Date
    Oct 2008
    Posts
    4
    Rep Power
    7

    Default ZD 0.92 Offline function doesn't work on Mac

    Hello,
    we use Zimbra 5.0.9, Leopard 10.5.5 and isync-5.0.9_GA_2533 connector.
    The ZD 0.92 works fine as long as the connection to the zimba server is online.
    When I disconnect from the server, I'm able to read all my mails. But when I restart the ZD without a connection I have no access to my mails and calendars.

    I have no idea why this is possible. It should be possible (offline mode) otherwise the use of the ZD makes no sense.

    Does someone have a similar problem?
    Any ideas? Suggestions?

    Hp

  2. #2
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    can you post a screenshot on what you mean by no access to mail and calendar?

  3. #3
    Join Date
    Oct 2008
    Posts
    4
    Rep Power
    7

    Default Clarify whats happen

    In the attached file you can see what I meant.
    This situation happens only when I close the ZD and start it again. Access to mails during a disconnection session works fin.

    I send you also the logfile from the console.

    With kind regards
    Hp
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by khp; 12-10-2008 at 12:38 AM.

  4. #4
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

  5. #5
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Number 10 on that page reads, "10. When using Zimbra sharing, folder tree will not display if remote server is not reachable or there's a mountpoint no longer valid."

    So if I am accessing any shared folders (from other people's accounts), then offline doesn't work for me.

    That's pretty clear...but it took several passes to assimilate.

    The workaround, I guess, is, to just delete any shared folders I'm accessing...but is there an easy way to quickly relocate and mount them when I'm online again?

  6. #6
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Not at the moment. We are working on a new update release to correct this issue. Sorry about the inconvenience.

  7. #7
    Join Date
    Oct 2008
    Posts
    4
    Rep Power
    7

    Default We need a solution

    Thanks for the quick response.
    I hope the new update release will be finish soon and ZD leaves the beta status. Today we haven't a working solution on Mac and Linux without some limits. If we use iCal we are not able to make an invention with some members.(http://www.zimbra.com/forums/isync-c...-new-post.html) It is fundamental to have a working solution without Outlook, otherwise we can just as well move to MS-Exchange.

    Kind regards
    Hp
    Last edited by khp; 12-16-2008 at 11:09 AM.

  8. #8
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Yes, this actually is a bigger issue than I thought at first since once you disconnect and "lose" the left hand panel, there's no way to delete the shared folders--at least through the GUI.

    In short, while it would be nice to have a facility that lets you relocate and mount shared folders that aren't currently in your folder list, that wouldn't be a complete workaround. What's really important is ensuring reliable access to stored mail while offline.

  9. #9
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Looks like this has been fixed in ZD 0.92 (build 1433). See the announcment which indicates that this build fixes
    Zimbra mailbox mountpoint can cause folder tree loading failure when offline. Bug 33168 - offline: missing folder tree and permissions on shared message folders
    Furthermore I just tested on my Mac and it seems to work.

Similar Threads

  1. Cannot empty trash
    By dellock in forum Error Reports
    Replies: 5
    Last Post: 09-19-2008, 01:56 PM
  2. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 02:01 PM
  3. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 03:49 AM
  4. ZD Beta 2 for Windows crashes
    By ms2k in forum Installation Help
    Replies: 5
    Last Post: 04-12-2008, 08:51 AM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-15-2005, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •