Results 1 to 9 of 9

Thread: Error message:Cannot connect to "zimbra.imap.mail.yahoo.com:993"

  1. #1
    Join Date
    Dec 2008
    Posts
    4
    Rep Power
    7

    Default Error message:Cannot connect to "zimbra.imap.mail.yahoo.com:993"

    I installed Zimbra for the first time on a system running Windows XP SP2. I get the following error when I attempt to setup either of my Yahoo accounts: Cannot connect to "zimbra.imap.mail.yahoo.com:993" Please check host/port and network connectivity.

    I get the same error while at work, or home. The derby.log file reads as follows:
    ----------------------------------------------------------------
    2008-12-11 00:48:11.968 GMT:
    Booting Derby version The Apache Software Foundation - Apache Derby - 10.3.3.0 - (652961): instance c013800d-011e-2383-dda3-000003acf5e8
    on database directory C:\Program Files\zdesktop\derby

    Database Class Loader started - derby.database.classpath=''


    The zdesktop.log reads as follows:
    2008-12-10 19:48:40,984 DEBUG [main] [] offline - Loading 6 folder mappings for service 'yahoo.com'
    2008-12-10 19:48:40,984 DEBUG [main] [] offline - Loading 2 attrs for service 'yahoo.com'
    2008-12-10 19:48:40,984 DEBUG [main] [] offline - Loading 19 folder mappings for service 'gmail.com'
    2008-12-10 19:48:41,000 DEBUG [main] [] offline - Loading 2 attrs for service 'gmail.com'
    2008-12-10 19:48:41,000 DEBUG [main] [] offline - Loading 5 folder mappings for service 'aol.com'
    2008-12-10 19:48:41,000 DEBUG [main] [] offline - Loading 8 folder mappings for service '.m***change'
    2008-12-10 19:48:41,000 DEBUG [main] [] offline - Loading 9 folder mappings for service 'hotmail.com'
    2008-12-10 19:49:10,453 INFO [main] [] log - No Transaction manager found - if your webapp requires one, please configure one.
    2008-12-10 19:49:45,765 INFO [main] [] log - Opened C:\Program Files\zdesktop\jetty\logs\access_log.2008-12-10
    2008-12-10 19:49:45,890 INFO [main] [] log - Started SelectChannelConnector@localhost:7633
    2008-12-10 19:53:58,578 INFO [btpool0-0] [] datasource - Testing: DataSource: { id=7762ecdc-1f8d-40a7-9eb2-dad0af3457c1, type=imap, isEnabled=true, name=mgalactico, host=zimbra.imap.mail.yahoo.com, port=993, connectionType=ssl, username=mgalactico, folderId=1 }
    2008-12-10 19:53:58,625 DEBUG [btpool0-0] [] datasource - Loading 2 yauth token(s) for user 'local@host.local'
    2008-12-10 20:00:14,171 WARN [btpool0-0] [] datasource - Test failed: DataSource: { id=7762ecdc-1f8d-40a7-9eb2-dad0af3457c1, type=imap, isEnabled=true, name=mgalactico, host=zimbra.imap.mail.yahoo.com, port=993, connectionType=ssl, username=mgalactico, folderId=1 }
    com.zimbra.common.service.ServiceException: system failure: Unable to connect to IMAP server: DataSource: { id=7762ecdc-1f8d-40a7-9eb2-dad0af3457c1, type=imap, isEnabled=true, name=mgalactico, host=zimbra.imap.mail.yahoo.com, port=993, connectionType=ssl, username=mgalactico, folderId=1 }
    ExceptionId:btpool0-0:1228957214171:c23c89cfc6408b67
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:253)
    at com.zimbra.cs.datasource.ImapSync.connect(ImapSync .java:142)
    at com.zimbra.cs.datasource.ImapSync.test(ImapSync.ja va:98)
    at com.zimbra.cs.offline.YMailImport.test(YMailImport .java:50)
    at com.zimbra.cs.datasource.DataSourceManager.test(Da taSourceManager.java:64)
    at com.zimbra.cs.account.offline.OfflineProvisioning. testDataSource(OfflineProvisioning.java:549)
    at com.zimbra.cs.account.offline.OfflineProvisioning. createDataSourceAccount(OfflineProvisioning.java:6 41)
    at com.zimbra.cs.account.offline.OfflineProvisioning. createAccount(OfflineProvisioning.java:446)
    at com.zimbra.cs.service.admin.CreateAccount.handle(C reateAccount.java:58)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:429)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:286)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:160)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:269)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:190)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:487)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:362)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:716)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:406)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:211)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.handler.RewriteHandler.handle(Re writeHandler.java:176)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.Server.handle(Server.java:313)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:506)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:844)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:211)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:381)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:396)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:442)
    Caused by: java.net.SocketException: Connection reset
    at java.net.SocketInputStream.read(Unknown Source)
    at com.sun.net.ssl.internal.ssl.InputRecord.readFully (Unknown Source)
    at com.sun.net.ssl.internal.ssl.InputRecord.read(Unkn own Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRec ord(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readDat aRecord(Unknown Source)
    at com.sun.net.ssl.internal.ssl.AppInputStream.read(U nknown Source)
    at java.io.BufferedInputStream.fill(Unknown Source)
    at java.io.BufferedInputStream.read(Unknown Source)
    at com.zimbra.cs.mailclient.util.TraceInputStream.rea d(TraceInputStream.java:73)
    at com.zimbra.cs.mailclient.MailInputStream.peek(Mail InputStream.java:99)
    at com.zimbra.cs.mailclient.MailInputStream.peekChar( MailInputStream.java:127)
    at com.zimbra.cs.mailclient.imap.ImapInputStream.read Text(ImapInputStream.java:225)
    at com.zimbra.cs.mailclient.imap.ImapResponse.readRes ponse(ImapResponse.java:48)
    at com.zimbra.cs.mailclient.imap.ImapResponse.read(Im apResponse.java:41)
    at com.zimbra.cs.mailclient.imap.ImapConnection.readR esponse(ImapConnection.java:596)
    at com.zimbra.cs.mailclient.imap.ImapConnection.proce ssGreeting(ImapConnection.java:89)
    at com.zimbra.cs.mailclient.MailConnection.connect(Ma ilConnection.java:88)
    at com.zimbra.cs.mailclient.imap.ImapConnection.conne ct(ImapConnection.java:76)
    at com.zimbra.cs.datasource.ImapSync.connect(ImapSync .java:129)
    ... 33 more


    Any help would be appreciated.

    Thank you

  2. #2
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    it looks like you are having trouble reaching that hostort. does your work/home have some kind of firewall that restricts access?

  3. #3
    Join Date
    Dec 2008
    Posts
    4
    Rep Power
    7

    Default Additional Info

    I forgot to add that I am running version 0.92 build 1418.

  4. #4
    Join Date
    Dec 2008
    Posts
    4
    Rep Power
    7

    Default

    At work we do but not at home. I am running etrust anti virus and Cisco Security Agent, but no firewall on this machine.

  5. #5
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    from command line if you type the following line what do you see:

    telnet zimbra.imap.mail.yahoo.com 993

  6. #6
    Join Date
    Dec 2008
    Posts
    4
    Rep Power
    7

    Default

    A couple of things have happened since your question. First, the telnet command does not get any response either from work or home however, the original error message is not longer an issue as I can not longer reproduce it. Now the desktop works from home, but not from work. AT work I get an error message that reads like this:
    2008-12-11 09:04:07,534 INFO [mid=2] [] datasource - Importing data for data source 'mgalactico'
    2008-12-11 09:04:07,534 INFO [mid=3] [] datasource - Importing data for data source 'Mario'
    2008-12-11 09:04:09,706 DEBUG [mid=2] [] datasource - Loading 1 yauth token(s) for user 'mgalactico@yahoo.com'
    2008-12-11 09:04:09,706 DEBUG [mid=3] [] datasource - Loading 1 yauth token(s) for user 'mario_jarrin@yahoo.com'
    2008-12-11 09:04:30,612 INFO [main] [] log - No Transaction manager found - if your webapp requires one, please configure one.
    2008-12-11 09:04:33,221 INFO [mid=3] [] datasource - Import completed for data source 'Mario'
    2008-12-11 09:04:33,221 INFO [mid=2] [] datasource - Import completed for data source 'mgalactico'
    2008-12-11 09:04:33,300 INFO [mid=2] [] offline - sync connection down: mgalactico
    2008-12-11 09:04:33,300 INFO [mid=3] [] offline - sync connection down: Mario
    2008-12-11 09:04:33,300 INFO [mid=2] [] offline - >>>>>>>> name=mgalactico@yahoo.com;version=0.92;build=1418; release=BETA;os=Windows XP x86 5.1;type=imap
    2008-12-11 09:04:33,300 INFO [mid=3] [] offline - >>>>>>>> name=mario_jarrin@yahoo.com;version=0.92;build=141 8;release=BETA;os=Windows XP x86 5.1;type=imap
    2008-12-11 09:04:33,300 INFO [mid=2] [] datasource - Importing data for data source 'mgalactico'
    2008-12-11 09:04:33,300 INFO [mid=3] [] datasource - Importing data for data source 'Mario'
    2008-12-11 09:04:41,831 INFO [main] [] log - Opened C:\Program Files\zdesktop\jetty\logs\access_log.2008-12-11
    2008-12-11 09:04:41,940 INFO [main] [] log - Started SelectChannelConnector@localhost:7633
    2008-12-11 09:04:54,940 INFO [mid=2] [] datasource - Import completed for data source 'mgalactico'
    2008-12-11 09:04:54,940 INFO [mid=3] [] datasource - Import completed for data source 'Mario'
    2008-12-11 09:04:54,940 INFO [mid=2] [] offline - sync connection down: mgalactico
    2008-12-11 09:04:54,940 INFO [mid=3] [] offline - sync connection down: Mario
    2008-12-11 09:05:59,940 INFO [mid=3] [] offline - >>>>>>>> name=mario_jarrin@yahoo.com;version=0.92;build=141 8;release=BETA;os=Windows XP x86 5.1;type=imap
    2008-12-11 09:05:59,940 INFO [mid=2] [] offline - >>>>>>>> name=mgalactico@yahoo.com;version=0.92;build=1418; release=BETA;os=Windows XP x86 5.1;type=imap

    or like this:
    2008-12-11 16:51:25,065 INFO [mid=3] [] offline - >>>>>>>> name=mario_jarrin@yahoo.com;version=0.92;build=141 8;release=BETA;os=Windows XP x86 5.1;type=imap
    2008-12-11 16:51:25,065 INFO [mid=3] [] datasource - Importing data for data source 'Mario'
    2008-12-11 16:51:46,612 INFO [mid=3] [] datasource - Import completed for data source 'Mario'
    2008-12-11 16:51:46,612 INFO [mid=3] [] offline - sync connection down: Mario
    2008-12-11 16:58:01,268 INFO [mid=2] [] offline - >>>>>>>> name=mgalactico@yahoo.com;version=0.92;build=1418; release=BETA;os=Windows XP x86 5.1;type=imap
    2008-12-11 16:58:01,268 INFO [mid=2] [] datasource - Importing data for data source 'mgalactico'
    2008-12-11 16:58:22,721 INFO [mid=2] [] datasource - Import completed for data source 'mgalactico'
    2008-12-11 16:58:22,721 INFO [mid=2] [] offline - sync connection down: mgalactico

    Thanks

  7. #7
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Basically from work you are not allowed by your firewall to connect to zimbra.imap.mail.yahoo.com port 993. You'll need to speak with your IT department to resolve this.

  8. #8
    Join Date
    Dec 2008
    Posts
    1
    Rep Power
    6

    Default it keeps saying invalid token

    i put yahoo mail addy in it and my pw but it says invalid token report this problem

  9. #9
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Please file a bug and attach <install>/log/zdesktop.log. Thanks!

Similar Threads

  1. [SOLVED] Email Down -- mail.send_failure
    By frankb in forum Administrators
    Replies: 1
    Last Post: 12-10-2008, 09:16 PM
  2. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 10:10 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. Can't send or receive mails from Zimbra
    By ppurama in forum Administrators
    Replies: 4
    Last Post: 11-14-2005, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •