Results 1 to 10 of 10

Thread: Trouble connecting to POP3 server

  1. #1
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default Trouble connecting to POP3 server

    I installed ZD on my Vista machine. Gmail account works fine, but adding my regular POP3 account fails every time. The error I get is :

    Cannot connect to "mail.delius.be:110". Please check host/port and network connectivity.

    Error log extract:

    2009-01-05 22:02:33,757 INFO [btpool0-18] [] datasource - Testing: DataSource: { id=205b1a5c-7c5f-4b54-8d18-154239b3ac43, type=pop3, isEnabled=true, name=PP, host=mail.delius.be, port=110, connectionType=cleartext, username=paul.delbar@delius.be, folderId=2 }
    2009-01-05 22:02:33,850 WARN [btpool0-18] [] datasource - Test failed: DataSource: { id=205b1a5c-7c5f-4b54-8d18-154239b3ac43, type=pop3, isEnabled=true, name=PP, host=mail.delius.be, port=110, connectionType=cleartext, username=paul.delbar@delius.be, folderId=2 }
    com.zimbra.common.service.ServiceException: system failure: Unable to connect to IMAP server: DataSource: { id=205b1a5c-7c5f-4b54-8d18-154239b3ac43, type=pop3, isEnabled=true, name=PP, host=mail.delius.be, port=110, connectionType=cleartext, username=paul.delbar@delius.be, folderId=2 }
    ExceptionId:btpool0-18:1231189353850:041b0ce4b35be77c
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:253)
    at com.zimbra.cs.datasource.Pop3Sync.connect(Pop3Sync .java:139)
    at com.zimbra.cs.datasource.Pop3Sync.test(Pop3Sync.ja va:95)
    at com.zimbra.cs.datasource.DataSourceManager.test(Da taSourceManager.java:64)
    at com.zimbra.cs.account.offline.OfflineProvisioning. testDataSource(OfflineProvisioning.java:549)
    at com.zimbra.cs.account.offline.OfflineProvisioning. createDataSourceAccount(OfflineProvisioning.java:6 41)
    at com.zimbra.cs.account.offline.OfflineProvisioning. createAccount(OfflineProvisioning.java:446)
    at com.zimbra.cs.service.admin.CreateAccount.handle(C reateAccount.java:58)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:429)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:286)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:160)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:269)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:190)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:487)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:362)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:716)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:406)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:211)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.handler.RewriteHandler.handle(Re writeHandler.java:176)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.Server.handle(Server.java:313)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:506)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:844)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:211)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:381)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:396)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:442)
    Caused by: java.net.SocketException: Connection reset
    at java.net.SocketInputStream.read(Unknown Source)
    at com.sun.net.ssl.internal.ssl.InputRecord.readFully (Unknown Source)
    at com.sun.net.ssl.internal.ssl.InputRecord.read(Unkn own Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRec ord(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.perform InitialHandshake(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHa ndshake(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHa ndshake(Unknown Source)
    at com.zimbra.common.util.CustomSSLSocket.startHandsh ake(CustomSSLSocket.java:197)
    at com.zimbra.cs.mailclient.MailConnection.startTls(M ailConnection.java:294)
    at com.zimbra.cs.mailclient.MailConnection.connect(Ma ilConnection.java:90)
    at com.zimbra.cs.datasource.Pop3Sync.connect(Pop3Sync .java:131)
    ... 32 more

    I am able to connect to this account from Thinderbird on the same machine without problems.

    Any suggestions of what I am doing wrong or could try ?

    Thanks !

  2. #2
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Your POP server advertises support of STARTTLS but it looks like it doesn't really like it. The difference between Thunderbird and Zimbra Desktop is that Zimbra Desktop will force the use of STARTTLS if the server advertises that capability.

  3. #3
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Question

    Thanks for your swift response.

    I have verified TLS operation and it is indeed configured (mail server is postfix). If I request Thunderbird to use TLS, it does do that and the connection works. So my guess is that TLS works as intended.

    However, I am no expert , and the fine distinction between TLS and SSL is beyond my understanding. Is there an easy way I can verify whether TLS is actually working as ZD requires it ?

    I am considering migrating to Zimbra server as well, but for the time being, I would like to be able to check POP3 mail as well, so this is a bit of a showstopper. Any help would be appreciated !

  4. #4
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    how did you make Thunderbird use TLS? are you using the 'TLS if available' option or the 'TLS' option?

  5. #5
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default Feedback

    Both options (TLS if available and TLS) work correctly. The SSL option does not work however.

  6. #6
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    OK, please file a bug with this information. Thanks!

  7. #7
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default

    Did that : Bug 34318 – ZDC cannot connect to POP3 client supporting TLS. If anyone needs more info (like user/pwd to test on our server) I can provide a test account on the server for you guys.

    Thanks for the support. Now let's hope the bug gets resolved quickly.

  8. #8
    Join Date
    Jan 2009
    Posts
    1
    Rep Power
    6

    Default

    I am getting what seems to be the exact same problem. It works fine in Thunderbird and Outlook express but not Zimbra.

    I would love to get it to work as I really like how Zimbra will sync my google calendar as I use Google calendar on my domain to show the companies I work for when I am available. I also like how I can get my yahoo account to work in it without paying extra while I cant (at least not to my knowledge) get it to work in Thunderbird.

    My host provides this info for helping setup my domain. I tried both ways:

    Manual Settings
    Mail Server Username: klemperle+mydomain.com
    Incoming Mail Server: mail.mydomain.com
    Incoming Mail Server: (SSL) alpha.dnshostname.net
    Outgoing Mail Server: mail.mydomain.com(server requires authentication) port 25
    Outgoing Mail Server: (SSL) alpha.dnshostname.net(server requires authentication) port 465
    Supported Incoming Mail Protocols: POP3, POP3S (SSL/TLS), IMAP, IMAPS (SSL/TLS)
    Supported Outgoing Mail Protocols: SMTP, SMTPS (SSL/TLS)

  9. #9
    Join Date
    Jan 2009
    Posts
    6
    Rep Power
    6

    Default

    All I can say is that I recognize the pattern. Other than submit the bug, I don't think there is much we can do. The forum contains a lot of POP3/TLS-related posts, perhaps there is a common issue underlying this.

    Anyone out there with a similar experience ?

  10. #10
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Yeah we do see a number of similar issues. We haven't been able to reproduce this in our lab as the TLS servers we setup, any of IMAP/POP/SMTP, work just fine.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  3. POP3 Server
    By rajeshkodali in forum Installation
    Replies: 1
    Last Post: 09-01-2007, 07:09 AM
  4. Admin console not connecting to remote server
    By f2uk in forum Administrators
    Replies: 8
    Last Post: 05-22-2007, 01:00 AM
  5. Installation Problem
    By AnilKumarYalla in forum Developers
    Replies: 4
    Last Post: 09-22-2006, 06:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •