Results 1 to 1 of 1

Thread: Calendar Sync after AutoSync

  1. #1
    Join Date
    May 2009
    Rep Power

    Default Calendar Sync after AutoSync

    Having a vexing calendar problem. I will recount my steps to the best of my ability:

    1. In preparation for usage of the Zimbra Desktop for Yahoo!, I upgraded my Yahoo! Calendar to the new beta.
    2. Seemed to work great! No problems when syncing calendar and email. But my calendar was empty…
    3. DOH! Silly me – I didn’t do an AutoSync on my local Outlook which only works with the OLD Calendar.
    4. So I reverted to the old Calendar, AutoSynced, and re-upgraded to new Calendar.
    5. From then on, I couldn’t do calendar sync! The status indicator on that tab turned red with an error: com.zimbra.cs.mailbox.OfflineServiceException: must upgrade to all-new yahoo calendar service
    6. Reset or reindex did not work. Removing and re-adding account did not work (keeps saying I have to upgrade). Hit link to upgrade to new Yahoo! Calendar in account setup and tried to “reconvert” – ineffective.
    7. Oddly enough, I did get it to work ONCE recently. I can’t put my finger on how, though. I have the Desktop running on an Ubuntu client at home (manual syncs, not 24/7). I cannot be certain of my Ubuntu client successfully syncing calendar lately.
    8. Would rather not reinstall but I will if I have to. Is it possible that the client didn't completely finish the job of deleting the account out of the client?
    9. Reinstalled my JRE - no effect (although it looks like the Desktop uses its own anyway).

    This may be helpful: These are lines added to my zdesktop.log file typical of the process when I edit my account to add calendar sync function (returns with the msg that I need to upgrade the calendar):

    2009-05-28 09:23:41,791 INFO [btpool0-8] [ds=landgazer;] datasource - Testing: DataSource: { id=c63c319e-f230-4e43-99f2-fe4fbc5f72c0, type=imap, isEnabled=true, name=landgazer,, port=993, connectionType=ssl, username=landgazer, folderId=1 }
    2009-05-28 09:23:41,791 INFO [btpool0-8] [ds=landgazer;] datasource - IMAP read timeout is 60 seconds
    2009-05-28 09:23:41,791 DEBUG [btpool0-8] [ds=landgazer;] datasource - Getting token for user 'landgazer'
    2009-05-28 09:23:41,791 DEBUG [btpool0-8] [ds=landgazer;] datasource - Generating new yauth token for user 'landgazer'
    2009-05-28 09:23:42,463 DEBUG [btpool0-8] [ds=landgazer;] datasource - Saving 1 yauth token(s) for mailbox '5'
    2009-05-28 09:23:43,072 DEBUG [btpool0-8] [ds=landgazer;] datasource - Getting token for user 'landgazer'
    2009-05-28 09:23:44,696 DEBUG [btpool0-8] [ds=landgazer;] imap - S: * OK IMAP4rev1 server ready (3.5.54)
    2009-05-28 09:23:44,696 DEBUG [btpool0-8] [ds=landgazer;] imap - C: C01 CAPABILITY
    2009-05-28 09:23:44,868 DEBUG [btpool0-8] [ds=landgazer;] imap - S: C01 OK CAPABILITY completed
    2009-05-28 09:23:44,868 DEBUG [btpool0-8] [ds=landgazer;] imap - C: C02 AUTHENTICATE XYMECOOKIE
    2009-05-28 09:23:45,071 DEBUG [btpool0-8] [ds=landgazer;] imap - S: +
    2009-05-28 09:23:45,071 DEBUG [btpool0-8] [ds=landgazer;] imap - C: <authentication data>
    2009-05-28 09:23:45,462 DEBUG [btpool0-8] [ds=landgazer;] imap - S: C02 OK AUTHENTICATE completed
    2009-05-28 09:23:45,462 DEBUG [btpool0-8] [ds=landgazer;] imap - C: C03 LIST "" ""
    2009-05-28 09:23:45,696 DEBUG [btpool0-8] [ds=landgazer;] imap - S: * LIST (\Noselect) NIL ""
    2009-05-28 09:23:45,696 DEBUG [btpool0-8] [ds=landgazer;] imap - S: C03 OK LIST completed
    2009-05-28 09:23:45,696 INFO [btpool0-8] [ds=landgazer;] datasource - Test succeeded: DataSource: { id=c63c319e-f230-4e43-99f2-fe4fbc5f72c0, type=imap, isEnabled=true, name=landgazer,, port=993, connectionType=ssl, username=landgazer, folderId=1 }
    2009-05-28 09:23:45,696 DEBUG [btpool0-8] [ds=landgazer;] datasource - Getting token for user 'landgazer'
    2009-05-28 09:23:46,899 DEBUG [btpool0-8] [ds=landgazer;] offline - testing offline caldav access: username=landgazer
    2009-05-28 09:23:46,899 DEBUG [btpool0-8] [ds=landgazer;] offline - offline caldav login test: url= path=/principals/users/@USERNAME@
    2009-05-28 09:23:46,899 DEBUG [btpool0-8] [ds=landgazer;] dav - WebDAV request (depth=zero): /principals/users/landgazer

    If any other information would be helpful, please let me know and I will be sure to post it.

    Many thanks in advance for any assistance anyone could give!

    -gabe (landgazer)

    UPDATE 29-May 11:30 Pacific

    ZD advised me to upgrade to v1.0. So I did. All is well and the Calendar even seemed to finish sync all my events, but when it was done I got an exception + stack trace. Subsequent attempts to refresh the calendar thereafter give me the error, and validation also fails telling me I need to upgrade when I already have. Any ideas?

    Your Yahoo! account doesn't support calendar. Please either upgrade to add the support or turn off calendar sync option.

    Debug message: must upgrade to all-new yahoo calendar service


    com.zimbra.cs.mailbox.OfflineServiceException: must upgrade to all-new yahoo calendar service
    at com.zimbra.cs.mailbox.OfflineServiceException.YCAL DAV_NEED_UPGRADE(
    at com.zimbra.cs.offline.OfflineCalDavDataImport.doCa lDavFailures(
    at com.zimbra.cs.offline.OfflineCalDavDataImport.impo rtData(
    at com.zimbra.cs.offline.OfflineImport.importData(Off
    at com.zimbra.cs.offline.YMailImport.importData(YMail
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(
    at com.zimbra.cs.mailbox.LocalMailbox.importData(Loca
    at com.zimbra.cs.mailbox.LocalMailbox.syncAllLocalDat aSources(
    at com.zimbra.cs.mailbox.LocalMailbox.sync(LocalMailb
    at com.zimbra.cs.service.offline.OfflineSync.handle(O
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:286)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:160)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:275)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.RewriteHandler.handle(Re
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(

    If issue persists please post description and debug information here.
    Last edited by landgazer; 05-29-2009 at 12:28 PM. Reason: New information

Similar Threads

  1. Replies: 8
    Last Post: 02-23-2009, 10:49 PM
  2. Replies: 13
    Last Post: 11-20-2008, 12:42 PM
  3. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 02:01 PM
  4. 4 MACs one calendar and contact Sync issue
    By 3tpro in forum CalDAV / CardDAV / iSync
    Replies: 0
    Last Post: 05-24-2008, 10:06 AM
  5. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 03:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts