Results 1 to 1 of 1

Thread: [SOLVED] Sync with MS Echange issue

  1. #1
    Join Date
    Jan 2007
    Longmont CO
    Rep Power

    Default [SOLVED] Sync with MS Echange issue

    Error occurs when setting up an IMAP with MS Exchange. I tried to reset and start over, but the same error occurred. Two folders received 219 mb and 293 mb before the error.

    Failure communicating with remote server. Please try again later.

    Debug message: Request already pending


    com.zimbra.common.service.ServiceException: system failure: Synchronization of folder '/Cocona2009' failed
    at com.zimbra.common.service.ServiceException.FAILURE (
    at com.zimbra.cs.datasource.ImapSync.syncFailed(ImapS
    at com.zimbra.cs.datasource.ImapSync.syncMessages(Ima
    at com.zimbra.cs.datasource.ImapSync.syncFolders(Imap
    at com.zimbra.cs.datasource.ImapSync.importData(ImapS
    at com.zimbra.cs.offline.OfflineImport.importData(Off
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(
    at com.zimbra.cs.mailbox.LocalMailbox.importData(Loca
    at com.zimbra.cs.mailbox.LocalMailbox.syncAllLocalDat aSources(
    at com.zimbra.cs.mailbox.LocalMailbox.sync(LocalMailb
    at com.zimbra.cs.mailbox.LocalMailbox.syncOnTimer(Loc
    at com.zimbra.cs.mailbox.DesktopMailbox$
    at java.util.TimerThread.mainLoop(Unknown Source)
    at Source)
    Caused by: java.lang.IllegalStateException: Request already pending
    at com.zimbra.cs.mailclient.imap.ImapConnection.sendR equest(
    at com.zimbra.cs.mailclient.imap.ImapRequest.send(Ima
    at com.zimbra.cs.mailclient.imap.ImapRequest.sendChec kStatus(
    at com.zimbra.cs.mailclient.imap.ImapConnection.doSel ectOrExamine(
    at com.zimbra.cs.mailclient.imap.ImapConnection.selec t(
    at com.zimbra.cs.datasource.ImapFolderSync.checkUidVa lidity(
    at com.zimbra.cs.datasource.ImapFolderSync.syncMessag es(
    at com.zimbra.cs.datasource.ImapSync.syncMessages(Ima
    ... 11 more

    Problem solved. Issue was a message with a bad format.
    I isolated the problem by determining which folder was causing the problem. I made a new folder and move messages from the Bad folder to the New folder. I moved 25 messages (using OWA) at a time and sync Zimbra after each move. Once the folder gave an error on the sync I looked at that set of 25 messages. I used Evolution with an IMAP connection to see which email had an IMAP4 issue. One message stated there was a problem with IMAP4. An alternative work around is to search the folder using Evolution for "IMAP4" in the body of the message text.
    Last edited by Regger; 07-24-2009 at 10:59 AM. Reason: UPDATE

Similar Threads

  1. New calendar sync issue for *some* users
    By centrex in forum Zimbra Connector for BlackBerry
    Replies: 8
    Last Post: 03-12-2009, 09:11 AM
  2. Replies: 13
    Last Post: 11-20-2008, 12:42 PM
  3. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 02:01 PM
  4. 4 MACs one calendar and contact Sync issue
    By 3tpro in forum CalDAV / CardDAV / iSync
    Replies: 0
    Last Post: 05-24-2008, 10:06 AM
  5. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 03:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts