Results 1 to 2 of 2

Thread: Trying to sync w/

  1. #1
    Join Date
    Feb 2008
    Rep Power

    Default Trying to sync w/

    We're playing around w/ Zimbra again trying to figure out if we want to switch over to this. One problem I'm having is getting a third party IMAP/web based mailer (Net@ddress Mail) to work properly w/ the client. As far as I can tell the settings are correct and it validates, however when I try to sync I get the following error. I'm relatively certain it is not the end site itself because my usual mail client (Alpine) has no problems connecting. I'm not a java programmer by any stretch of the imagination so if anyone can decrypt the following and let me know what might be wrong I'd appreciate it. I'm not sure what is means by "request already pending" as I've tried this several times over the past few days from a few different machines so any single session should have timed out by now.


    Failure communicating with remote server. Please try again later.

    Debug message: Request already pending


    com.zimbra.common.service.ServiceException: system failure: Synchronization of folder '[mailbox]' failed
    at com.zimbra.common.service.ServiceException.FAILURE (
    at com.zimbra.cs.datasource.ImapSync.syncFailed(ImapS
    at com.zimbra.cs.datasource.ImapSync.syncRemoteFolder s(
    at com.zimbra.cs.datasource.ImapSync.syncFolders(Imap
    at com.zimbra.cs.datasource.ImapSync.importData(ImapS
    at com.zimbra.cs.offline.OfflineImport.importData(Off
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(
    at com.zimbra.cs.mailbox.LocalMailbox.importData(Loca
    at com.zimbra.cs.mailbox.LocalMailbox.syncAllLocalDat aSources(
    at com.zimbra.cs.mailbox.LocalMailbox.sync(LocalMailb
    at com.zimbra.cs.service.offline.OfflineSync.handle(O
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:286)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:160)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:275)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.RewriteHandler.handle(Re
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(
    Caused by: java.lang.IllegalStateException: Request already pending
    at com.zimbra.cs.mailclient.imap.ImapConnection.sendR equest(
    at com.zimbra.cs.mailclient.imap.ImapRequest.send(Ima
    at com.zimbra.cs.mailclient.imap.ImapRequest.sendChec kStatus(
    at com.zimbra.cs.mailclient.imap.ImapConnection.doSel ectOrExamine(
    at com.zimbra.cs.mailclient.imap.ImapConnection.selec t(
    at com.zimbra.cs.datasource.ImapFolderSync.createLoca lFolder(
    at com.zimbra.cs.datasource.ImapFolderSync.syncFolder (
    at com.zimbra.cs.datasource.ImapSync.syncRemoteFolder s(
    ... 34 more

    If issue persists please post description and debug information here.

    EDIT: BTW just so I understand, this connection should just be from the machine the client/desktop is running on to the Netaddress server over the IMAP port right? Does the client/desktop need to talk to the local Zimbra server in this process? The reverse connection should come back over the same path right, so a stateful f/w should have the appropriate connection state to allow this, correct?
    Last edited by fhouston; 04-12-2010 at 02:25 PM.

  2. #2
    Join Date
    Feb 2008
    Rep Power


    I've also found out it doesn't work from the web client either. During setting up the account I get successful test logins but when it tries to sync I'm getting the following error:

    system failure: Synchronization of folder 'Inbox' failed, SELECT failed: Error in response, Invalid number format: 42153101529505023

    Anyone know what this means?

Similar Threads

  1. Zimbra GAL and GALSync Questions Since Upgrading to 6.0
    By Chewie71 in forum Administrators
    Replies: 2
    Last Post: 01-13-2010, 12:31 PM
  2. Replies: 13
    Last Post: 11-20-2008, 12:42 PM
  3. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 02:01 PM
  4. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 03:49 AM
  5. Z-Mobile & Motorola Q - sync issues
    By dwill in forum Zimbra Mobile
    Replies: 0
    Last Post: 11-17-2006, 09:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts