Results 1 to 7 of 7

Thread: Keep getting errors with attachments

  1. #1
    Join Date
    Jan 2010
    Cochrane, Alberta
    Rep Power

    Default Keep getting errors with attachments

    Almost all email with attachments results in an error:

    method: GetMsgRequest
    msg: system failure: MessagingException while creating MimeMessage for item 38444
    code: service.FAILURE
    detail: soap:Receiver......

    Caused by: renaming destination file C:\Documents and Settings\xxxxxxxxx\Local Settings\Application Data\Zimbra\Zimbra Desktop\data\tmp\uncompressed\y7sXVafI3GsMg5BmGzdD 6IuBp4M= already exists at

    When I delete the file y7sXVafI3GsMg5BmGzdD6IuBp4M at the location above. I can then open the email and retrieve the file though the error may likely reoccur.

    I'm using ZD2 Beta 2. I often received the same error ZD2 Beta 1.

    Also, creating a new email or replying or forwarding an email seems slow opening a new windows compared to ZD2 Beta 1.


  2. #2
    Join Date
    Apr 2010
    Rep Power

    Default Same here

    ..when selecting an e-mail with attachment. Here's the error report:

    method:	SearchConvRequest
    msg:	system failure: MessagingException while creating MimeMessage for item 35958
    code:	service.FAILURE
    detail:	soap:Receiver
    trace:	com.zimbra.common.service.ServiceException: system failure: MessagingException while creating MimeMessage for item 35958 ExceptionId:btpool0-387:1272027688282:e7b7bc289615c34a Code:service.FAILURE at 
    com.zimbra.common.service.ServiceException.FAILURE( at 
    com.zimbra.cs.mailbox.MessageCache.getMimeMessage( at com.zimbra.cs.mailbox.Message.getMimeMessage( at 
    com.zimbra.cs.mailbox.Message.getMimeMessage( at 
    com.zimbra.cs.service.mail.ToXML.encodeMessageAsMP( at 
    com.zimbra.cs.service.mail.Search.addMessageHit( at 
    com.zimbra.cs.service.mail.SearchConv.putHits( at 
    com.zimbra.cs.service.mail.SearchConv.handle( at 
    com.zimbra.soap.SoapEngine.dispatchRequest( at 
    com.zimbra.soap.SoapEngine.dispatch( at 
    com.zimbra.soap.SoapEngine.dispatch( at 
    com.zimbra.soap.SoapServlet.doWork( at 
    com.zimbra.soap.SoapServlet.doPost( at 
    javax.servlet.http.HttpServlet.service( at 
    com.zimbra.cs.servlet.ZimbraServlet.service( at 
    javax.servlet.http.HttpServlet.service( at 
    org.mortbay.jetty.servlet.ServletHolder.handle( at 
    org.mortbay.jetty.servlet.ServletHandler.handle( at 
    at org.mortbay.jetty.servlet.SessionHandler.handle( 
    at org.mortbay.jetty.handler.ContextHandler.handle( 
    at org.mortbay.jetty.webapp.WebAppContext.handle( 
    at org.mortbay.jetty.handler.ContextHandlerCollection.handle( at 
    org.mortbay.jetty.handler.HandlerCollection.handle( at 
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle( 
    at org.mortbay.jetty.handler.HandlerWrapper.handle( at 
    org.mortbay.jetty.Server.handle( at 
    org.mortbay.jetty.HttpConnection.handleRequest( at 
    org.mortbay.jetty.HttpConnection$RequestHandler.content( at org.mortbay.jetty.HttpParser.parseNext( at 
    org.mortbay.jetty.HttpParser.parseAvailable( at 
    org.mortbay.jetty.HttpConnection.handle( at at 
    Caused by: javax.mail.MessagingException: Error in input stream; nested exception is: renaming destination file 
    C:\Users\andre\AppData\Local\Zimbra\Zimbra Desktop\data\tmp\uncompressed\khY15Ds+YxkRYTX3OOjx3SAOl2s= already exists 
    at javax.mail.internet.InternetHeaders.load( at 
    javax.mail.internet.InternetHeaders.( at 
    at javax.mail.internet.MimeMessage.parse( at 
    javax.mail.internet.MimeMessage.( at 
    com.zimbra.cs.mime.Mime$FixedMimeMessage.( at 
    ... 33 more 
    Caused by: renaming destination file C:\Users\andre\AppData\Local\Zimbra\Zimbra Desktop\data\tmp\uncompressed\khY15Ds+YxkRYTX3OOjx3SAOl2s= already exists 
    at com.zimbra.common.util.FileUtil.rename( at at at at at 
    com.sun.mail.util.LineInputStream.readLine( at 
    ... 39 more
    Body: {
      SearchConvRequest: {
        _jsns: "urn:zimbraMail",
        cid: "972a3370-0e1f-4d25-877d-1e8b386d1858:-35958",
        fetch: "972a3370-0e1f-4d25-877d-1e8b386d1858:35958",
        html: 1,
        limit: 50,
        locale: {
          _content: "en_US"
        max: 100000,
        offset: 0,
        query: "in:"inbox"",
        read: 1,
        sortBy: "dateDesc",
        tz: {
          id: "Europe/Berlin"
    Header: {
      context: {
        _jsns: "urn:zimbra",
        account: {
          _content: "***",
          by: "name"
        authToken: "(removed)",
        notify: {
          seq: 69
        session: {
          _content: 13206,
          id: 13206
        userAgent: {
          name: "ZimbraWebClient - PRISM (Win)",
          version: "0.0"

  3. #3
    Join Date
    Mar 2010
    Rep Power


    Getting the same thing. ZD2 beta2

  4. #4
    Join Date
    Jan 2009
    Rep Power

    Unhappy Same Problem with Attachments

    Like others I'm having the same problem with attachments over a certain size (not quite sure how large). Deleting files in the \data\tmp\uncompressed folder solves the problem one time (requires a machine re-boot to do so) but then next "large" attachment fails. Most frustrating!

    I'm running windows 7.

    Any ideas would be most appreciated.

  5. #5
    Join Date
    Apr 2006
    Rep Power


    Also open that same problem attachment in the web version of zimbra and save to your local system. Then compose a new message in the web version, add that attachment, and then save your new message as draft. Sync Zimbra Desktop and try and open that draft message with the attachment - it will also fail with the same error at least isolating the problem to how Zimbra Desktop stores attachments/retrieves attachments from the Zimbra Server (nothing to do with how Zimbra Server processes the message).

    I've been waiting for RC1/Beta3 before opening a bug report on this to see if it's still present. I have been submitting the "send error report" occasionally like others but I don't know what happens to these reports - is anyone viewing them?

  6. #6
    Join Date
    May 2010
    Rep Power


    On ZD203 on OSX 10.6.5 I get this:
    Attached Images Attached Images

  7. #7
    Join Date
    Apr 2006
    Rep Power


    For me, ZD2 beta 3 has resolved all problems with attachments.

Similar Threads

  1. [SOLVED] Attachments with 0 bits in webmail (ok in Outlook)
    By georgelazar in forum Administrators
    Replies: 6
    Last Post: 02-18-2010, 06:56 AM
  2. Outlook and Zimbra Connector not sending attachments
    By kilrathi in forum Zimbra Connector for Outlook
    Replies: 32
    Last Post: 01-15-2010, 01:45 PM
  3. Mailbox log errors?
    By carnold in forum Administrators
    Replies: 3
    Last Post: 08-11-2008, 08:31 AM
  4. Replies: 5
    Last Post: 08-05-2008, 11:25 AM
  5. Drag email to calendar and attachments
    By Richard in forum Users
    Replies: 2
    Last Post: 09-14-2006, 01:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts