Results 1 to 3 of 3

Thread: How can you get a "network error" accessing the local folders?

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Rep Power

    Default How can you get a "network error" accessing the local folders?

    I have a user (using v2.0 of the desktop on a Win7 machine) who has been migrating a bunch of old email to the local folders. Sometime last week, he is not sure when, he lost access to the mail that had already been moved over. He can move more mail to the local folders, he just can't access what is there. Whenever he tries he gets a "network service error". The two attachments show what he is seeing. The below is the info I pulled from the local Zimbra log that I believe corresponds to the error.

    Anyone have any idea what is going on? How does one get a "network error" accessing local folders Although I suspect it is more of a generic error code. If I had to take a guess I believe the index has potentially been corrupted somehow. I was able to dig into the file structure (User/AppData/Local/Zimbra....) and verify the .msg files themselves still seem to be there so I don't think any data was lost, just the index/metadata. Any way to force a rebuild?

    Any hints/clues/suggestions are appreciated....

    2011-04-22 13:21:59,392 WARN [btpool0-1] [mid=1;] misc - system failure: fetching search metadata
    com.zimbra.common.service.ServiceException: system failure: fetching search metadata
    at com.zimbra.common.service.ServiceException.FAILURE (
    at com.zimbra.cs.db.DbSearch.searchInternal(DbSearch. java:759)
    at )
    at com.zimbra.cs.index.DBQueryOperation.noLuceneGetNe xtChunk(
    at com.zimbra.cs.index.DBQueryOperation.getNextChunk(
    at com.zimbra.cs.index.DBQueryOperation.peekNext(DBQu
    at com.zimbra.cs.index.QueryOperation.hasNext(QueryOp
    at com.zimbra.cs.index.ItemPreloadingGrouper.bufferHi ts(
    at com.zimbra.cs.index.BufferingResultsGrouper.hasNex t(
    at com.zimbra.cs.index.ConvQueryResults.internalGetNe xtHit(
    at com.zimbra.cs.index.ConvQueryResults.bufferNextHit (
    at com.zimbra.cs.index.ConvQueryResults.peekNext(Conv
    at com.zimbra.cs.index.ZimbraQueryResultsImpl.hasNext (
    at com.zimbra.cs.index.ItemPreloadingGrouper.bufferHi ts(
    at com.zimbra.cs.index.BufferingResultsGrouper.hasNex t(
    at com.zimbra.cs.index.HitIdGrouper.bufferHits(HitIdG
    at com.zimbra.cs.index.BufferingResultsGrouper.peekNe xt(
    at com.zimbra.cs.index.FilteredQueryResults.peekNext(
    at com.zimbra.cs.index.FilteredQueryResults.hasNext(F
    at com.zimbra.cs.index.ResultsPager.hasNext(ResultsPa
    at com.zimbra.cs.service.mail.Search.putHits(Search.j ava:200)
    at com.zimbra.cs.service.mail.Search.handle(Search.ja va:127)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:274)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:158)
    at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:291)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:212)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:755)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(
    Caused by: java.sql.SQLException: [SQLITE_ERROR] SQL error or missing database (too many SQL variables)
    at org.sqlite.DB.newSQLException(
    at org.sqlite.DB.newSQLException(
    at org.sqlite.DB.throwex(
    at org.sqlite.NativeDB.prepare(Native Method)
    at org.sqlite.DB.prepare(
    at org.sqlite.PrepStmt.<init>(
    at org.sqlite.Conn.prepareStatement(
    at org.sqlite.Conn.prepareStatement(
    at org.sqlite.Conn.prepareStatement(
    at com.zimbra.cs.db.RetryConnection$1.execute(RetryCo
    at com.zimbra.cs.db.AbstractRetry.doRetry(AbstractRet
    at com.zimbra.cs.db.RetryConnection.prepareStatement(
    at org.apache.commons.dbcp.DelegatingConnection.prepa reStatement(
    at org.apache.commons.dbcp.PoolingDataSource$PoolGuar dConnectionWrapper.prepareStatement(PoolingDataSou
    at com.zimbra.cs.db.DbPool$Connection.prepareStatemen t(
    at com.zimbra.cs.db.DbSearch.searchInternal(DbSearch. java:710)
    ... 47 more
    Attached Images Attached Images

  2. #2
    Join Date
    Feb 2008
    Rep Power


    Just a quick update... the user tried the "reindex" function on the main setup screen of Zimbra desktop and that did not help/resolve the issue. Anyone have any hints/clues/suggestions? This really is a show stopper for this user...

    I know one trick we used to do for Eudora (I think that's what it was) was to delete the index files (.toc files IIRC) and that would force a reindex the next time the mail box was accessed. Is there a similar file in the Zimbra structure?

    RESOLUTION: I'm still not sure what caused the issue, but upgrading to Desktop v7 resolved it... If someone can still answer the question above (about whether or not index files can be individually deleted and where they can be found) that would be appreciated for future reference.


    DERESOLUTION Although he can access the email now, ALL the messages in ALL the folders under the Local Folders have lost their directory structure, for lack of a better phrase. What I mean is no matter which of the folders under local folders you click on you get the exact same message list. It seems to be a complete list so again I don't think any data was lost, but which message belongs in which folder is completely gone. Any way to recover this?
    Last edited by fhouston; 04-29-2011 at 10:22 AM.

  3. #3
    Join Date
    Jul 2010
    Rep Power


    The original problem sounds like a variation on Bug 54935 - Zimbra is stuck loading forever when trying to connect to an Exchange server with tons of public folders. Most likely this caused messages not to be placed in their correct folder when moved.

    I don't think there is any way to recover the missing/incorrect folder structure.

    As for your question about reindexing; the reindex function on the account setup page does all that is required/possible. There is no need to manually manipulate index files.

Similar Threads

  1. Move Server Side Folders to Local Folders
    By WhyMe in forum General Questions
    Replies: 3
    Last Post: 03-16-2011, 10:54 AM
  2. sharing of local folders.
    By srinivas.v in forum General Questions
    Replies: 0
    Last Post: 10-15-2010, 10:10 PM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  4. [SOLVED] Thunderbird Local Folders to Zimbra
    By hurstel in forum Migration
    Replies: 2
    Last Post: 03-17-2008, 02:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts