Results 1 to 3 of 3

Thread: Zimbra file upload timeout

  1. #1
    Join Date
    Jun 2011
    Rep Power

    Question Zimbra file upload timeout

    I have Zimbra Version 7.1.0_GA_3140 instaled on Ubuntu 10.04.2
    Virtual machine is running on Vmware ESXI 4.1 and has 3 Gb of Ram and 2 Cpu-s .
    Everything works perfect except file upload.
    When i try to upload file that is 10 kb , it works , no problem . But if i try to upload a 500 kb file it waits for a long time and nothing happens.
    Same thing is when i create new text document in zimbra and paste lot of text inside. When i try to save it it waits forever . If i just type few words file is saved , no problem.

    I found error in mailbox.log and here it is :

    2011-06-01 09:57:38,928 INFO [btpool0-14://] [name=john.doe@mydomain;mid=7;ip=192.168.xx.xx;ua=M ozilla/5.0 (Windows NT 6.1;; WOW64;; rv:2.0.1) Gecko/20100101 Firefox/4.0.1;] FileUploadServlet - File upload failed
    org.apache.commons.fileupload.FileUploadBase$IOFil eUploadException: Processing of multipart/form-data request failed. null
    at org.apache.commons.fileupload.FileUploadBase.parse Request(
    at org.apache.commons.fileupload.servlet.ServletFileU pload.parseRequest(
    at com.zimbra.cs.service.FileUploadServlet.handleMult ipartUpload(
    at com.zimbra.cs.service.FileUploadServlet.doPost(Fil
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:725)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:814)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(Set
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.DebugHandler.handle(Debu
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:756)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(
    Caused by: org.mortbay.jetty.EofException
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:319)
    at org.mortbay.jetty.HttpParser$Input.blockForContent (
    at org.mortbay.jetty.HttpParser$ .java:1122)
    at org.apache.commons.fileupload.MultipartStream$Item InputStream.makeAvailable( )
    at org.apache.commons.fileupload.MultipartStream$Item
    at org.apache.commons.fileupload.util.Streams.copy(St
    at org.apache.commons.fileupload.util.Streams.copy(St
    at org.apache.commons.fileupload.FileUploadBase.parse Request(
    ... 33 more
    Caused by: org.mortbay.jetty.EofException
    at unwrap(
    at fill(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:290)

    I cant figure out this myself so any help would be apprechiated

  2. #2
    Join Date
    Jun 2011
    Rep Power


    I had a similar problem, same exception as you have... The difference was that the error was somewhat more random than yours.

    However, after some investigation I noticed that it's was my reverse-proxy that was the origin of the problem (I'm running Apache mod_proxy as a front-end SSL proxy).

    The problem was resolved by setting SetEnv proxy-sendcl 1.

  3. #3
    Join Date
    Jun 2011
    Rep Power

    Smile problem solved

    Belive or not it was not zimbra making problem. It was my network port. It was working but not normally, but it was hard to figure out. When i changed port , Zimbra started working.
    Thanx for reply

Similar Threads

  1. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  2. Replies: 22
    Last Post: 12-02-2007, 04:05 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  4. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts