Results 1 to 5 of 5

Thread: evolution connector won't compile on Fedora 14

Hybrid View

  1. #1
    Join Date
    Dec 2010
    Posts
    3
    Rep Power
    5

    Default evolution connector won't compile on Fedora 14

    Hi

    i get the following error when i run "make":
    Code:
    In file included from e-zimbra-connection.c:36:0:
    /usr/include/evolution-data-server-2.32/camel/camel-url.h:27:2: error: #error "Only <camel/camel.h> can be included directly."
    e-zimbra-connection.c: In function 'e_zimbra_connection_new':
    e-zimbra-connection.c:1045:9: error: 'GNOME_Evolution_Calendar_OtherError' undeclared (first use in this function)
    e-zimbra-connection.c:1045:9: note: each undeclared identifier is reported only once for each function it appears in
    e-zimbra-connection.c: In function 'e_zimbra_connection_sync_folder':
    e-zimbra-connection.c:1999:38: warning: assignment makes pointer from integer without a cast
    e-zimbra-connection.c:2042:38: warning: assignment makes pointer from integer without a cast
    e-zimbra-connection.c: In function 'e_zimbra_connection_sync_delete':
    e-zimbra-connection.c:2307:46: warning: assignment makes pointer from integer without a cast
    e-zimbra-connection.c:2318:46: warning: assignment makes pointer from integer without a cast
    e-zimbra-connection.c: In function 'e_zimbra_connection_update_source_id':
    e-zimbra-connection.c:3004:22: warning: assignment makes pointer from integer without a cast
    make[2]: *** [e-zimbra-connection.lo] Error 1
    make[2]: Leaving directory `/home/smg/Downloads/evolution-zimbra-0.1.1/libezimbra'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/smg/Downloads/evolution-zimbra-0.1.1'
    make: *** [all] Error 2
    [root@z60m evolution-zimbra-0.1.1]#
    Unfortunately I'm not much of a coder, but this could be a deal-stopper for our migration to zimbra, so any help is greatly appreciated.

    --
    Rgds
    Sven

  2. #2
    Join Date
    Dec 2010
    Posts
    3
    Rep Power
    5

    Default

    It doesn't work on Fedora 13 either (seems to be a different error though)

    Code:
    zimbra-account-setup.c:35: error: expected ')' before '*' token
    zimbra-account-setup.c:49: error: expected ')' before '*' token
    make[3]: *** [zimbra-account-setup.lo] Error 1
    make[3]: Leaving directory `/root/evolution-zimbra-0.1.1/eplugin'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/root/evolution-zimbra-0.1.1/eplugin'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/evolution-zimbra-0.1.1'
    make: *** [all] Error 2
    [root@localhost evolution-zimbra-0.1.1]#
    Is therer REALLY no one able to help here?

  3. #3
    Join Date
    Jan 2011
    Posts
    1
    Rep Power
    4

    Default

    i was able to compile and use the evolution-zimbra-0.1.1 plugin with Fedora 13 using the following:

    the first errors i received from make were:
    Code:
    zimbra-account-setup.c:35: error: expected ')' before '*' token
    zimbra-account-setup.c:49: error: expected ')' before '*' token
    after some searching, i found other plugins calling e_plugin_lib_enable with different parameter types than was used in the evolution-zimbra source code.

    in eplugin/zimbra-account-setup.c, change lines 35 and 49 from:
    Code:
    e_plugin_lib_enable (EPluginLib *ep,
    to
    Code:
    e_plugin_lib_enable (EPlugin *ep,
    after installing the following packages:
    evolution-data-server-devel-2.30.3-1.fc13.i686
    evolution-devel-2.30.3-1.fc13.i686
    evolution-conduits-2.30.3-1.fc13.i686
    evolution-2.30.3-1.fc13.i686
    evolution-data-server-2.30.3-1.fc13.i686
    evolution-help-2.30.3-1.fc13.noarch
    i was still receiving a compile error about a missing e-util/e-error.h
    Code:
    camel-zimbra-listener.c:29:28: error: e-util/e-error.h: No such file or directory
    i downloaded this from http://svn.gnome.org/svn/evolution/t...util/e-error.h and placed it in /usr/include/evolution-2.30/e-util/

    with this i was able to make/make install. however it installed to /usr/local/usr/lib/... rather than /usr/lib/...

    Code:
    sudo mv /usr/local/usr/lib/evolution/2.30/plugins/* /usr/lib/evolution/2.30/plugins/
    sudo mv /usr/local/usr/lib/evolution-data-server-1.2/camel-providers/libcamelzimbra.* /usr/lib/evolution-data-server-1.2/camel-providers/
    sudo mv /usr/local/usr/lib/evolution-data-server-1.2/extensions/libe* /usr/lib/evolution-data-server-1.2/extensions/
    after this, i was able to add a new zimbra account in evolution

  4. #4
    Join Date
    Dec 2010
    Posts
    3
    Rep Power
    5

    Default

    I'll try that, thanks for the hint.

    SMG

  5. #5
    Join Date
    Feb 2011
    Posts
    2
    Rep Power
    4

    Default

    Hi for me it doesn't work...

    I'm using Ubuntu maverick 64bit with this releases of evolution
    ii evolution 2.30.3-1ubuntu7.3 groupware suite with mail client and organizer
    ii evolution-common 2.30.3-1ubuntu7.3 architecture independent files for Evolution
    ii evolution-data-server 2.30.3-2ubuntu2.1 evolution database backend server
    ii evolution-data-server-common 2.30.3-2ubuntu2.1 architecture independent files for Evolution Data Server
    ii evolution-data-server-dbg 2.30.3-2ubuntu2.1 evolution database backend server with debugging symbols
    ii evolution-data-server-dev 2.32.1-0ubuntu1~ppa1 Development files for evolution-data-server (metapackage)
    ii evolution-dbg 2.30.3-1ubuntu7.3 debugging symbols for Evolution
    ii evolution-dev 2.30.3-1ubuntu7.3 development library files for Evolution
    ii evolution-exchange 2.30.3-0ubuntu2 Exchange plugin for the Evolution groupware suite
    ii evolution-exchange-dbg 2.30.3-0ubuntu2 Exchange plugin for Evolution with debugging symbols
    ii evolution-indicator 0.2.10-0ubuntu1 GNOME panel indicator applet for Evolution
    ii evolution-mapi 0.30.3-1ubuntu1 Exchange support for the Evolution groupware suite
    ii evolution-mapi-dbg 0.30.3-1ubuntu1 debugging symbols for the Evolution MAPI provider
    ii evolution-plugins 2.30.3-1ubuntu7.3 standard plugins for Evolution
    ii evolution-plugins-experimental 2.30.3-1ubuntu7.3 experimental plugins for Evolution
    ii evolution-webcal



    here is my configure output:

    ==========================================
    Ready to build ZCS Evolution Connector
    ==========================================
    Logging : no (version: 0.6)

    ==========================================

    CFLAGS: -g -O2
    ADD_CFLAGS:

    ====== Evolution Settings ================
    API Version :
    Evolution version : 2.30.3
    E-D-S backend dir : /usr/lib/evolution-data-server-1.2/extensions

    ====== Evolution Plugin Settings ==========
    Plugin Path : /usr/lib/evolution/2.30/plugins
    Error Path : /usr/share/evolution/2.30/errors

    ====== Camel-Provider Settings ===========
    privlibdir :
    Install Path :

    I got this error at compile time:

    e-zimbra-connection.c: In function 'xml_parse_path':
    e-zimbra-connection.c:173: warning: format not a string literal and no format arguments
    e-zimbra-connection.c: In function 'e_zimbra_connection_new':
    e-zimbra-connection.c:1045: error: 'GNOME_Evolution_Calendar_OtherError' undeclared (first use in this function)
    e-zimbra-connection.c:1045: error: (Each undeclared identifier is reported only once
    e-zimbra-connection.c:1045: error: for each function it appears in.)
    e-zimbra-connection.c: In function 'e_zimbra_connection_sync_folder':
    e-zimbra-connection.c:1999: warning: assignment makes pointer from integer without a cast
    e-zimbra-connection.c:2042: warning: assignment makes pointer from integer without a cast
    e-zimbra-connection.c: In function 'e_zimbra_connection_sync_delete':
    e-zimbra-connection.c:2307: warning: assignment makes pointer from integer without a cast
    e-zimbra-connection.c:2318: warning: assignment makes pointer from integer without a cast
    e-zimbra-connection.c: In function 'e_zimbra_connection_update_source_id':
    e-zimbra-connection.c:3004: warning: assignment makes pointer from integer without a cast
    make[2]: *** [e-zimbra-connection.lo] Error 1
    make[2]: Leaving directory `/root/evolution-zimbra-0.1.1/libezimbra'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/evolution-zimbra-0.1.1'
    make: *** [all] Error 2


    I made the substititions you spotted out as follows:

    me@myhost > grep -rin \(EPlugin zimbra-account-setup.c
    35:e_plugin_lib_enable (EPlugin *ep,
    49:e_plugin_lib_enable (EPluginx *ep,


    the problem happens also in evolution 2.32 (natty package backported to maverick).

    Could you give me some more hint?

Similar Threads

  1. ZCS Evolution Connector 0.1 released
    By mbarnes in forum Evolution Connector
    Replies: 4
    Last Post: 04-01-2008, 12:05 PM
  2. How to use Zimbra from within Evolution
    By snuffelt in forum Evolution Connector
    Replies: 8
    Last Post: 08-27-2007, 03:35 PM
  3. Evolution Connector compile error
    By carnold in forum Evolution Connector
    Replies: 1
    Last Post: 08-15-2007, 09:01 AM
  4. Introducing Zimbra Connector for Evolution
    By sam in forum Announcements
    Replies: 0
    Last Post: 03-19-2007, 04:09 PM
  5. Fedora Core 5 on x86_64 compile?
    By JoshuaPrismon in forum Developers
    Replies: 6
    Last Post: 05-22-2006, 06:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •