Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 53

Thread: Howto Configure the Connector for Ubuntu

  1. #41
    Join Date
    Dec 2008
    Posts
    8
    Rep Power
    7

    Default

    I checked out the latest version, however, I am unable to find the ./bootstrap file in it. Any ideas where it went?

  2. #42
    Join Date
    Aug 2007
    Location
    outside Philadelphia
    Posts
    214
    Rep Power
    8

    Default

    is there a ./autogen in there? If so, try that... it might generate the bootstrap...

  3. #43
    Join Date
    Dec 2008
    Posts
    8
    Rep Power
    7

    Default

    Quote Originally Posted by gnyce View Post
    is there a ./autogen in there? If so, try that... it might generate the bootstrap...
    Yeah, that did the trick. Thanks! It compiled and installed OK. Unfortunately, just like the sourceforge 0.1.1 version it still does not work properly with the calander and contacts....

  4. #44
    Join Date
    Aug 2008
    Posts
    7
    Rep Power
    7

    Default

    This issue is now holding up the Zimbra deployment in my company. Can the developers please help ?

  5. #45
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    It may be better to post directly to SourceForge as there is a outstanding issue with the latest version of Evolution :- SourceForge.net: ZCS Evolution Connector: Detail: 2378321 - zimbra connector doesn't work with evolution 2.24

  6. #46
    Join Date
    Aug 2008
    Posts
    7
    Rep Power
    7

    Default

    Thanks, I will do that

  7. #47
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    6

    Thumbs up Thank you UbuntuGuy!

    I just wanted to say thank you to UbuntuGuy for the very good step by step that some of us less technical users require to get things going. They worked as expected.

    Like others I don't have calendar and contacts and I look forward to future development of Evolution and the Zimbra Connector.

    As a long time Windows user who replaced Vista with Ubuntu on my laptop, I look forward to the day when I can replace Windows, Exchange and Outlook with Linux, Zimbra and Evolution and have everything work out of the box. What a push that would be for Linux in a business environment.

    Thanks again UbuntuGuy!

    Thanks to the many others who worked on this!

  8. #48
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    6

    Default SMTP or Sendmail for outgoing?

    One more thing....

    Does outgoing mail not use the Zimbra Connector? I had to choose between SMTP or Sendmail, but Outlook on my XP machine just uses the Zimbra server for messages in and out.

    Is something configured wrong?

    Thanks,

    Brian

  9. #49
    Join Date
    Nov 2009
    Posts
    1
    Rep Power
    6

    Default

    Quote Originally Posted by UbuntuGuy View Post
    After culling information from a variety of sources, I pulled together this quick and concise guide on how to install the Zimbra Evolution connector plugin. This guide works specifically for Ubuntu 8.04.1 and version 0.1.1 of the connector. I tested it using a fresh Ubuntu Hardy installation.

    Get everything ready:

    • Download the Zimbra connector's source 0.1.1 tarball from here:
      https://sourceforge.net/project/show...kage_id=245547
    • Extract the tarball to a folder on your computer I'll extract it to the desktop for this example.
    • Open a terminal window and change directory to the folder
      (cd ~/Desktop/evolution-zimbra-0.1.1)


    Install the needed packages with the following commands:

    • sudo apt-get install automake evolution-dev libglib2.0-dev intltool libtool evolution-data-server-dev libcurl3 libcurl3-dev
    • sudo apt-get install libedataserverui1.2-dev libedata-book1.2-dev libedata-cal1.2-dev

    Note: If the second command errors out and tells you that it can't find the files, then you may have to enable some repositories in Synaptic,

    Compile the source

    • ./configure
    • make
    • sudo make install

    Note: You should not receive any errors when running these commands. If you do, then something needs to be fixed before proceeding.


    Put everything in the right place
    The plugin files are installed in the wrong directory, so run these commands to fix everything:


    • sudo mv /usr/local/usr/lib/evolution-data-server-1.2/camel-providers/* /usr/lib/evolution-data-server-1.2/camel-providers
    • sudo mv /usr/local/usr/lib/evolution-data-server-1.2/extensions/* /usr/lib/evolution-data-server-1.2/extensions
    • sudo mv /usr/local/usr/lib/evolution/2.22/plugins/* /usr/lib/evolution/2.22/plugins/


    Access the connector in Evolution

    • Start Evolution
    • You should now be able to see the plugin in the list on the Edit – Plugins menu. It should be enabled by default.
    • When you setup a new email account, instead of choosing POP or IMAP on the “Receiving Email” dialog, select Zimbra Collaboration Suite.


    That should do it.

    (Good luck. I have had mixed success getting some of the connector's functions to work.)
    Many thx, it's working on Ubuntu 9.10 Karmic Koala.

    Just change:
    Code:
    sudo mv /usr/local/usr/lib/evolution/2.22/plugins/* /usr/lib/evolution/2.22/plugins/
    by
    Code:
    sudo mv /usr/local/usr/lib/evolution/2.28/plugins/* /usr/lib/evolution/2.28/plugins/
    Thx

  10. #50
    Join Date
    Feb 2011
    Posts
    3
    Rep Power
    4

    Default What is the status of this project?

    Is the evolution connector still active? It will not compile in Ubuntu 10.10

    Does anyone know what dev package contains this header file?

    Code:
    In file included from e-zimbra-connection.c:34:
    e-zimbra-utils.h:43: fatal error: libedataserver/e-file-cache.h: No such file or directory
    compilation terminated.

Similar Threads

  1. [SOLVED] Howto: Update ClamAV
    By unilogic in forum Administrators
    Replies: 9
    Last Post: 12-12-2007, 05:28 AM
  2. Configure snmp after installation?
    By bjdraw in forum Administrators
    Replies: 12
    Last Post: 05-22-2007, 10:31 AM
  3. SUSE Linux Enterprise Server 9 NAT Install HOWTO
    By LMStone in forum Installation
    Replies: 0
    Last Post: 11-03-2006, 02:31 PM
  4. Replies: 4
    Last Post: 01-18-2006, 11:58 AM
  5. Fix for SA Configure Files Version Mismatch
    By unilogic in forum Developers
    Replies: 1
    Last Post: 12-03-2005, 07:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •