Results 1 to 6 of 6

Thread: evolution development libraries not found

  1. #1
    Join Date
    Mar 2006
    Location
    Belgium
    Posts
    20
    Rep Power
    9

    Default evolution development libraries not found

    I'm trying to compile this evolution connector on Ubuntu 7.04 (Feisty) and have installed all the libraries as explained in this thread:
    http://www.zimbra.com/forums/showthread.php?t=7800

    But when I run
    Code:
    sudo ./bootstrap.sh
    I exits by telling me the Evolution Development libraries aren't installed:

    Code:
    [...]
    checking whether to build shared libraries... yes
    checking whether to build static libraries... yes
    configure: creating libtool
    appending configuration tag "CXX" to libtool
    appending configuration tag "F77" to libtool
    checking Evolution version... configure: error: Evolution development libraries not installed
    However the development packages are installed:

    Code:
    $ sudo aptitude -PVv install automake evolution-dev libglib2.0-dev intltool libtool evolution-data-server-dev libcurl3 libcurl3-dev
    Password:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Building tag database... Done      
    automake is already installed at the requested version (1:1.10+nogfdl-1)
    evolution-dev is already installed at the requested version (2.10.0-0ubuntu2)
    libglib2.0-dev is already installed at the requested version (2.12.11-0ubuntu1)
    intltool is already installed at the requested version (0.35.5-0ubuntu2)
    libtool is already installed at the requested version (1.5.22-4)
    evolution-data-server-dev is already installed at the requested version (1.10.0-0ubuntu1)
    libcurl3 is already installed at the requested version (7.15.5-1ubuntu2)
    libcurl3-dev is already installed at the requested version (7.15.5-1ubuntu2)
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Can this be related to the fact that Feisty comes with Evolution 2.10 ?
    What's the solution for this ?

  2. #2
    Join Date
    Aug 2005
    Posts
    821
    Rep Power
    11

    Default

    I think there's a versioning issue. You need version 2.8 of the libraries.
    Sam Khavari

    :: :: [ Zimbra ] :: :: [ Bugzilla ] :: :: [ Product Portal ] :: :: [ Wiki ] :: :: [ Downloads ] :: :: [ . ] ::

  3. #3
    Join Date
    Mar 2006
    Location
    Belgium
    Posts
    20
    Rep Power
    9

    Default

    I guess it's rather difficult (and even not applicable) to use the 2.8 libraries if I'm using evolution 2.10, isn't it ?

    In the meantime I found out that the announcement (http://www.zimbra.com/forums/showthread.php?t=7710) states that evolution 2.10 will be tested "shortly".
    We are "already" 2 weeks further in the meantime

    Any timeframe on this ?

  4. #4
    Join Date
    Feb 2007
    Location
    Massachusetts
    Posts
    136
    Rep Power
    8

    Default

    Anybody have any idea where I might find the source for the libraries? all I can find is RPMs, and I'm working ith OSx (yes I know it's odd, but some of us mac guys hate imail and ical.)

  5. #5
    Join Date
    Sep 2007
    Posts
    18
    Rep Power
    8

    Default

    Has development of this been abandoned? Looks like it has been over a year since there has been any updates on this.

  6. #6
    Join Date
    Apr 2007
    Location
    San Jose, CA
    Posts
    17
    Rep Power
    8

    Default

    Development of the Evolution Connector has moved to SourceForge and can be found under the ZimbraEvo project

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. Replies: 5
    Last Post: 08-02-2007, 05:55 PM
  3. Replies: 5
    Last Post: 03-01-2007, 03:20 AM
  4. Replies: 16
    Last Post: 11-29-2006, 10:36 AM
  5. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •