Results 1 to 4 of 4

Thread: Toaster exception error

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Location
    WV
    Posts
    49
    Rep Power
    8

    Default Toaster exception error

    I am working on installing Toaster on a user's XP (SP2) workstation. The install completes fine, but when I attempt to click the "Register Mailto Handler" button, I'm getting:

    Code:
    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Zimbra.Toast.Config.RegisterMailto_Click(Object sender, EventArgs e)
       at System.Windows.Forms.Control.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnClick(EventArgs e)
       at System.Windows.Forms.Button.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    ZToast
        Assembly Version: 4.5.193.0
        Win32 Version: 4.5.193.0
        CodeBase: file:///C:/Program%20Files/Zimbra/Zimbra%20Toaster/Zimbra%20Toaster.exe
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    Zimbra.Client
        Assembly Version: 4.5.193.0
        Win32 Version: 4.5.193.0
        CodeBase: file:///C:/Program%20Files/Zimbra/Zimbra%20Toaster/Zimbra.Client.DLL
    ----------------------------------------
    System.Xml
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    System.Deployment
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Deployment/2.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll
    ----------------------------------------
    System.Configuration
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    Additionally, after configuration, if I do attempt to click a mailto link, about 90 IE windows pop up even though FF is her default web client.

    I dug through the forums/wiki and googled around and the only references I could find were related to the beta release just before Thanksgiving last year, but no resolution.

    Any clues?

  2. #2
    Join Date
    Jan 2007
    Location
    France
    Posts
    71
    Rep Power
    8

    Default toaster problems

    Did you find out the solution?
    I am having the same problem.

    Cheers

  3. #3
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Quote Originally Posted by sturgis View Post
    Did you find out the solution?
    I am having the same problem.

    Cheers
    Try enabling the JIT debugging.

    If you think this is a bug, please file one, and attach repo steps.

  4. #4
    Join Date
    Mar 2008
    Posts
    1
    Rep Power
    7

    Default Solved

    I was having the exact same problem registering my mailto handler with toaster. It turned out that my default mail client was not set properly in the windows registry. Once I corrected the registry problems I was able to use toaster to register the mailto links properly.

    Here's how I fixed my registry:

    Instructions for Windows XP:

    * Click Start, Run and type control inetcpl.cpl
    * Select the Programs tab
    * From the E-mail dropdown list, choose another mail client and click Apply
    * Redo the procedure and set your preferred email client again

    The above information courtesy of Multiple browser windows open when you click on a mailto: link

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. Toaster exception error
    By briansrapier in forum Administrators
    Replies: 0
    Last Post: 09-07-2007, 01:53 PM
  3. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  4. Replies: 14
    Last Post: 12-22-2005, 04:59 PM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-15-2005, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •