Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: IMAP Error - No Mail is received

  1. #1
    Join Date
    Mar 2008
    Posts
    2
    Rep Power
    7

    Default IMAP Error - No Mail is received

    Hello,

    I installed Zimbra desktop client on Windows XP and configured it for my IMAP mail account. The program opens just fine but never gets my mail. I get this in the error logs:

    2008-03-19 22:44:03,782 INFO [sync-timer-jp@joshuapickering.com] [] datasource - Importing data.
    2008-03-19 22:44:04,532 ERROR [sync-timer-jp@joshuapickering.com] [] offline - sync failure: Joshua Pickering
    com.zimbra.common.service.ServiceException: system failure: A4 NO Mailbox does not exist, or must be subscribed to.
    ExceptionId:musicbox:sync-timer-jp@joshuapickering.com:1205991844532:2c5aa099ff7c5 1ea
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:217)
    at com.zimbra.cs.datasource.ImapImport.importData(Ima pImport.java:362)
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(DataSourceManager.java:148)
    at com.zimbra.cs.mailbox.LocalMailbox.syncAllLocalDat aSources(LocalMailbox.java:256)
    at com.zimbra.cs.mailbox.LocalMailbox.sync(LocalMailb ox.java:294)
    at com.zimbra.cs.mailbox.LocalMailbox.syncOnTimer(Loc alMailbox.java:236)
    at com.zimbra.cs.mailbox.DesktopMailbox$1.run(Desktop Mailbox.java:85)
    at java.util.TimerThread.mainLoop(Unknown Source)
    at java.util.TimerThread.run(Unknown Source)
    Caused by: javax.mail.MessagingException: A4 NO Mailbox does not exist, or must be subscribed to.;
    nested exception is:
    com.sun.mail.iap.CommandFailedException: A4 NO Mailbox does not exist, or must be subscribed to.
    at com.sun.mail.imap.IMAPFolder.getUIDValidity(IMAPFo lder.java:1730)
    at com.zimbra.cs.datasource.ImapImport.importData(Ima pImport.java:180)
    ... 7 more
    Caused by: com.sun.mail.iap.CommandFailedException: A4 NO Mailbox does not exist, or must be subscribed to.
    at com.sun.mail.iap.Protocol.handleResult(Protocol.ja va:328)
    at com.sun.mail.imap.protocol.IMAPProtocol.status(IMA PProtocol.java:727)
    at com.sun.mail.imap.IMAPFolder.getUIDValidity(IMAPFo lder.java:1722)
    ... 8 more


    Sending email from Zimbra desktop works, so it's communicating with my server OK.

    How to fix?

    Thanks,
    JP

  2. #2
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Hi, what IMAP server is this? We'll need the IMAP trace between client and server to see why it failed. Thanks!

  3. #3
    Join Date
    Mar 2008
    Posts
    2
    Rep Power
    7

    Default

    This IMAP server belongs to my hosting company (midphase.com). They are running the Courier IMAP server. I can send you log files from the Zimbra desktop client. But, as this is a shared hosting server, I'm not sure I can get detailed IMAP logging. I will check.

    For what it's worth, I am able to connect to the account with Thunderbird, Outlook, etc.

  4. #4
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    You don't need server permission to get the IMAP trace. Sorry I didn't mention this. You can turn IMAP trace on by following these steps in zdesktop:

    1) edit the file <install>/conf/localconfig.xml

    2) add a key javamail_imap_debug with value of true. you'll see what the format is once you open that file.

    3) restart the background service. if you don't know how refer to the zdesktop wiki.

    4) now try to connect again. IMAP trace will go into <install>/log/zdesktop.out

    Thanks!

  5. #5
    Join Date
    Mar 2008
    Location
    Raleigh, NC
    Posts
    4
    Rep Power
    7

    Default

    I have a very similar problem. I am trying to run Zimbra Desktop on Windoze XP and access my own IMAP server running Dovecot on Fedora8.

    I can access the server just fine with Outlook, Thunderbird, Evolution, but I get an error when I try Zimbra Desktop.

    I have set the IMAP logging as described and attach the IMAP Log and the Mail Log

    Let me know if there are further tests you would like run.

    Nigel
    Attached Files Attached Files
    Last edited by nterry; 03-22-2008 at 04:45 PM.

  6. #6
    Join Date
    Mar 2008
    Location
    Raleigh, NC
    Posts
    4
    Rep Power
    7

    Default

    Is Anyone Looking At This??

  7. #7
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Sorry missed this thread. It looks like a bug. Could you please file it in bugzilla and attach the logs? We'll investigate and fix it. Thanks!

  8. #8
    Join Date
    Mar 2008
    Location
    Raleigh, NC
    Posts
    4
    Rep Power
    7

    Default

    You have the logs. Tell me how to file the bug and I will try and do that

  9. #9
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Please take a look at this wiki about how to use bugzilla: Bugzilla - Zimbra :: Wiki

    We try to involve our users with the process as much as we can. It's a community effort Please let me know if you have trouble doing it. Thanks!

  10. #10
    Join Date
    Mar 2008
    Location
    Raleigh, NC
    Posts
    4
    Rep Power
    7

    Default

    Done - I think

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. Issues...
    By timothyalangorman in forum Administrators
    Replies: 3
    Last Post: 11-19-2007, 10:43 AM
  4. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •