Results 1 to 3 of 3

Thread: getDirectContext error

Hybrid View

  1. #1
    Join Date
    Apr 2008
    Rep Power

    Default getDirectContext error

    I was using the client to add an external email account (gmail). I was able to set up the account and would come back successful on the test but once I clicked on 'save' it would successfully confirm my gmail account but then return a pink box saying 'system failure: getDirectContext'.
    I opened up the [?mjsf=true&gzip=false&debug=1] window to see what was going on ...

    this is the batch request

    <soap:Envelope xmlns:soap="">


    <context xmlns="urn:zimbra">

    <userAgent xmlns="" name="ZimbraWebClient - IE7 (Win)" version="5.0.4_GA_2101.openSUSE_10.2"/>
    <sessionId xmlns="" id="113"/>
    <account xmlns="" by="name">
    <format xmlns="" type="js"/>
    <authToken xmlns="">
    0_b60b549d46d949c34173ed9e3e86a3a943db3d4d_69643d3 3363a31336632383532612d356235652d343734612d6138356 32d6539373430666430663061623b6578703d31333a3132303 83730373939323539353b747970653d363a7a696d6272613b6 d61696c686f73743d31353a3139322e3136382e312e31393a3 8303b

    <BatchRequest xmlns="urn:zimbra" onerror="stop">

    <CreateDataSourceRequest xmlns="urn:zimbraMail" requestId="0">

    <pop3 xmlns="" name="" isEnabled="true" emailAddress="" host="" port="995" username="" password="********" l="298" connectionType="ssl" pollingInterval="0" leaveOnServer="true" fromDisplay="Keith J. Pittner" fromAddress=""/>
    <NoOpRequest xmlns="urn:zimbraMail" requestId="1"/>

    and this is the response


    Body: {
    BatchResponse: {
    Fault: [
    0: {
    Code: {
    Value: "soap:Receiver"
    Detail: {
    Error: {
    Code: "service.FAILURE",
    Trace: "btpool0-8:1208535907429:ee2d59dd91fa0413",
    _jsns: "urn:zimbra"
    Reason: {
    Text: "system failure: getDirectContext"
    _jsns: "urn:zimbraSoap",
    requestId: "0"
    _jsns: "urn:zimbra"
    Header: {
    context: {
    _jsns: "urn:zimbra",
    change: {
    token: 13351
    sessionId: [
    0: {
    _content: "113",
    id: "113"
    _jsns: "urn:zimbraSoap"


    so I was wondering if anyone can spot the error or what might be going wrong.
    Thanks in advance

  2. #2
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    Is this using Zimbra Desktop or Zimbra server?

  3. #3
    Join Date
    Apr 2008
    Rep Power


    it is the CLIENt (sorry about that). I have to pause for a bit as I am setting up a new RAID server for the Zimbra server. I am having problems getting openSUSE to install on the mirror drives.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. [SOLVED] upgrade zimbra 5.0.2 32 bit to 64 bit
    By jwilson in forum Installation
    Replies: 1
    Last Post: 03-11-2008, 12:15 PM
  3. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 03:58 AM
  4. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts