Results 1 to 4 of 4

Thread: Shortcut for Sending Email

  1. #1
    Join Date
    Jul 2008
    Posts
    23
    Rep Power
    7

    Default Shortcut for Sending Email

    In Yahoo & Outlook, the shortcut for sending an email is Alt + S. In Zimbra, it's CTRL + S. Why can't it be the same as Yahoo?

  2. #2
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    I found out from the shortcut expert how to customize shortcuts. There's no user-friendly way, but if you are comfortable with tweaking system config files feel free to give it a try. Here's his answers:

    Yep. It's done by changing one of the two keys files:

    keys/AjxKeys.properties (low-level shortcuts for widgets)
    keys/ZmKeys.properties (function-related shortcuts)

    The shortcut for sending a msg is in ZmKeys:

    compose.Send.display = Ctrl+Enter; Ctrl+S
    compose.Send.keycode = Ctrl+13; Ctrl+83

    The "display" property controls the text that shows up on the
    Shortcuts page in Preferences. The "keycode" property controls the
    actual shortcut assignment. You could change those to:

    compose.Send.display = Ctrl+Enter; Alt+S
    compose.Send.keycode = Ctrl+13; Alt+83

    I'm not positive, but I think when I originally started assigning shortcuts,
    there were fewer conflicts with browser and Windows shortcuts using Ctrl rather
    than Alt.


    ---

    So in desktop, the path to the files is <install>/jetty/webapps/zimbra/WEB-INF/classes/keys/

    You need to restart gui client after editing these files.

  3. #3
    Join Date
    Jul 2008
    Posts
    23
    Rep Power
    7

    Default

    Thanks! It would be nice if there were a way to change this in the preferences page. Once this program goes mainstream, do you really want users changing these files?

  4. #4
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    no, there's a bug filed already for this, but so far it's on slow track since it hasn't got much demand from users.

Similar Threads

  1. Not receiving from given domain
    By jrefl5 in forum Administrators
    Replies: 19
    Last Post: 02-29-2008, 11:45 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  3. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •