Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: default mail client howto

  1. #11
    Join Date
    Feb 2009
    Posts
    14
    Rep Power
    6

    Default

    I am unable to set Zimbra desktop as the default email client. I have checked the box under general in preferences, but now the box shows a tick but you can not access it.

    I have gone into the internet options and tried to set Zimbra as the default but Zimbra does not show as a selection. On Firefox I have added it as another application but I still default to Thunderbird.

    I have followed the instruction, posted here, set outlook as the default and restarted Zimbra Desktop. I could then select the default box, but it only reverted back to the previous behavior - grayed out default.

    Am I missing something or should I post a bug report?

    Windows XP professional
    Zimbra 1482 and now 1513

  2. #12
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Quote Originally Posted by peter8rossi View Post
    I have followed the instruction, posted here, set outlook as the default and restarted Zimbra Desktop. I could then select the default box, but it only reverted back to the previous behavior - grayed out default.
    after doing the above, it should work now. click on a mailto link in firefox, you should see it bring up zd's compose window.

    the grayed out checkbox is by design - since application can not make itself "not the default mail app". in other words, once you select zd as default mail app, you have to use other mail app to change it.

  3. #13
    Join Date
    Feb 2009
    Posts
    14
    Rep Power
    6

    Default

    When I click on a mailto in Firefox it does bring up Zimbra, but not the compose window and does not therefore insert the email address.

    In all other programs and Internet Explorer Thunderbird starts (old default) and I have not been able to set Zimbra Desktop as the default, even though the box is grayed out.

  4. #14
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    can you try the steps in comment #8 of this thread again. if you don't have outlook express, you can use thunderbird too. you only need to restart YZD afterward (no need to restart computer).

    if it still won't work, see my comment #10 and post the value of that key here. i would also like to see the content of profile/prefs.js.

  5. #15
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    this was indeed a bug in build 1482. the latest rc2 (1513) has the fix.

    Quote Originally Posted by hauntvictim View Post
    Sorry yes on Windows Vista SP1
    Tried your directions and no luck. Still says the same thing "Unauthorized Access". Maybe I should try uninstalling and then reinstalling the program?

  6. #16
    Join Date
    Feb 2009
    Posts
    14
    Rep Power
    6

    Default

    Ok I have followed post #10 again but still no change. Here is the information requested:

    registry
    "C:\Documents and Settings\Peter\Local Settings\Application Data\Zimbra\zdesktop\win32\prism\zdclient.exe" -url "%1"

    Profile
    # Mozilla User Preferences

    /* Do not edit this file.
    *
    * If you make changes to this file while the application is running,
    * the changes will be overwritten when the application exits.
    *
    * To make a manual change to preferences, you can visit the URL about:config
    * For more information, see Customizing Mozilla
    */

    user_pref("app.update.lastUpdateTime.addon-background-update-timer", 1236268159);
    user_pref("app.update.lastUpdateTime.background-update-timer", 1236268760);
    user_pref("app.update.lastUpdateTime.blocklist-background-update-timer", 1236268159);
    user_pref("browser.places.importBookmarksHTML", true);
    user_pref("browser.places.importDefaults", false);
    user_pref("browser.places.leftPaneFolderId", -1);
    user_pref("browser.places.smartBookmarksVersion", 0);
    user_pref("browser.search.selectedEngine", "Inquisitor");
    user_pref("browser.startup.homepage", "http://localhost:7633/desktop/login.jsp?at=b83ae402-c064-47b0-a142-e441a0974183");
    user_pref("extensions.enabledItems", "prism-runtime@developer.mozilla.org:0.9.1,Inquisitor@yah oo:1.0.2,zimbradnd@zimbra.com:1.1.0");
    user_pref("extensions.lastAppVersion", "0.9.1");
    user_pref("inquisitor.data.prevsearchengine", "Inquisitor");
    user_pref("inquisitor.preferences.firstinstall", false);
    user_pref("intl.accept_languages", "en-US");
    user_pref("network.cookie.prefsMigrated", true);
    user_pref("prism.protocol.mailto", "http://localhost:7633/desktop/login.jsp?at=b83ae402-c064-47b0-a142-e441a0974183&mailto=%s");
    user_pref("spellchecker.dictionary", "en-US");

    Summary
    Firefox mailto - opens Zimbra but not in composer and no email address
    Internet Explorer and other Windows apps - opens Thunderbird and resets reg key to

    "C:\Program Files\Mozilla Thunderbird\thunderbird.exe" -osint -compose "%1"

    Can not set Zimbra as default mail application in Windows

  7. #17
    Join Date
    Feb 2009
    Posts
    14
    Rep Power
    6

    Default

    Where did my post disappear too? I have sent the information request twice now and both times the posts have disappeared.

  8. #18
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Everything looks correct. I can't think of anything else may cause the problem.

    Can you try one more thing:

    1) Set ZD as default mail app (may have to go through comment #8 again)
    2) Start ZD, Shift-F6 to bring up status bar
    3) Go to the "Commands" menu on status bar (gear icon), then
    Tools->Error Console.
    4) Now click on a mailto link from Firefox

    Do you see any errors reported in Error Console? If so, please paste them here.



    Quote Originally Posted by peter8rossi View Post
    Ok I have followed post #10 again but still no change. Here is the information requested:

    registry
    "C:\Documents and Settings\Peter\Local Settings\Application Data\Zimbra\zdesktop\win32\prism\zdclient.exe" -url "%1"

    Profile
    # Mozilla User Preferences

    /* Do not edit this file.
    *
    * If you make changes to this file while the application is running,
    * the changes will be overwritten when the application exits.
    *
    * To make a manual change to preferences, you can visit the URL about:config
    * For more information, see Customizing Mozilla
    */

    user_pref("app.update.lastUpdateTime.addon-background-update-timer", 1236268159);
    user_pref("app.update.lastUpdateTime.background-update-timer", 1236268760);
    user_pref("app.update.lastUpdateTime.blocklist-background-update-timer", 1236268159);
    user_pref("browser.places.importBookmarksHTML", true);
    user_pref("browser.places.importDefaults", false);
    user_pref("browser.places.leftPaneFolderId", -1);
    user_pref("browser.places.smartBookmarksVersion", 0);
    user_pref("browser.search.selectedEngine", "Inquisitor");
    user_pref("browser.startup.homepage", "http://localhost:7633/desktop/login.jsp?at=b83ae402-c064-47b0-a142-e441a0974183");
    user_pref("extensions.enabledItems", "prism-runtime@developer.mozilla.org:0.9.1,Inquisitor@yah oo:1.0.2,zimbradnd@zimbra.com:1.1.0");
    user_pref("extensions.lastAppVersion", "0.9.1");
    user_pref("inquisitor.data.prevsearchengine", "Inquisitor");
    user_pref("inquisitor.preferences.firstinstall", false);
    user_pref("intl.accept_languages", "en-US");
    user_pref("network.cookie.prefsMigrated", true);
    user_pref("prism.protocol.mailto", "http://localhost:7633/desktop/login.jsp?at=b83ae402-c064-47b0-a142-e441a0974183&mailto=%s");
    user_pref("spellchecker.dictionary", "en-US");

    Summary
    Firefox mailto - opens Zimbra but not in composer and no email address
    Internet Explorer and other Windows apps - opens Thunderbird and resets reg key to

    "C:\Program Files\Mozilla Thunderbird\thunderbird.exe" -osint -compose "%1"

    Can not set Zimbra as default mail application in Windows

  9. #19
    Join Date
    Feb 2009
    Posts
    14
    Rep Power
    6

    Default

    No errors but a few warnings:

    Warning: reference to undefined property AjxDebug.DBG1
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 317

    Warning: reference to undefined property AjxRpc.__rpcOutstanding[id]
    Source File: http://localhost:7633/zimbra/js/ajax...v=090303121838
    Line: 139

    Warning: reference to undefined property AjxDebug.DBG2
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 1000

    Warning: reference to undefined property AjxDebug.DBG2
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 198

    Warning: reference to undefined property nodeList[0]
    Source File: http://localhost:7633/zimbra/js/ajax...v=090303121838
    Line: 190

    Warning: reference to undefined property AjxDebug.DBG1
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 362

    Warning: reference to undefined property AjxDebug.DBG1
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 363

    Hope this helps. I can't post the content of the files as I get an error about too many image files?
    Last edited by peter8rossi; 03-06-2009 at 07:17 PM.

  10. #20
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Unfortunately no - those warnings are benign...

    Quote Originally Posted by peter8rossi View Post
    No errors but a few warnings:

    Warning: reference to undefined property AjxDebug.DBG1
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 317

    Warning: reference to undefined property AjxRpc.__rpcOutstanding[id]
    Source File: http://localhost:7633/zimbra/js/ajax...v=090303121838
    Line: 139

    Warning: reference to undefined property AjxDebug.DBG2
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 1000

    Warning: reference to undefined property AjxDebug.DBG2
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 198

    Warning: reference to undefined property nodeList[0]
    Source File: http://localhost:7633/zimbra/js/ajax...v=090303121838
    Line: 190

    Warning: reference to undefined property AjxDebug.DBG1
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 362

    Warning: reference to undefined property AjxDebug.DBG1
    Source File: http://localhost:7633/zimbra/js/zimb...v=090303121838
    Line: 363

    Hope this helps. I can't post the content of the files as I get an error about too many image files?

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 01:41 AM
  3. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  4. [SOLVED] Incoming Emails get deferred
    By andersen_hc in forum Administrators
    Replies: 11
    Last Post: 10-25-2007, 02:45 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •