Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: Bug 31450 followup

  1. #31
    Join Date
    Aug 2008
    Posts
    88
    Rep Power
    7

    Default Bug 31450 followup

    I have already downloaded and installed Zimbra desktop 1.0 latest build and it is sync...ing as I write this. I have also ensured that sync is ON for each of the folders. I hope that it pushes all my missing mails from local Zimbra desktop to Yahoo web server this time :-)

    However, to gain my confidence back, I have the following questions based on the new "logic" being used. I will appreciate if each of them can be responded separately (unless one response applies to all of them)

    a) If I create one or more folders locally on Zimbra desktop and set it to sync with Yahoo web server, will these folders get created on Yahoo web server during next send/receive ?

    b) If I create one or more folders on Yahoo web server, will these folders get created on Zimbra desktop and set to sync automatically during next send/receive ?

    c) Most important (this operation is most probably when previously I lost my mails from Yahoo web server). If I use basic / advanced search to search all mails belonging to any specific subject / sender / receiver or any combination thereof and MOVE ALL OF THEM TOGETHER (by selecting all of them at the same time) from whichever folder(s) they exist in to the newly created / already existing local folders on Zimbra desktop, will these moved mails also move correspondingly on Yahoo web server mailbox so as to remain in sync with the moved mails in local Zimbra desktop folders.

    The outcome of the sync getting completed AND answer to these questions will determine whether I use Zimbra desktop in a passive mode just to read mails going ahead (as I had stopped using it altogether after mails disappeared from Yahoo web server) or start using it in an active manner to fully utilize all the excellent features available.

    I will post a note when the sync is successful and the counts of all mails in my local folders match those on Yahoo web server. (as I observed that more than 1100+ people are following this thread.)
    Last edited by ezu; 02-04-2009 at 02:14 AM.

  2. #32
    Join Date
    Aug 2008
    Posts
    88
    Rep Power
    7

    Default Bug 31450 followup

    The sync is still going on after two days (I have 256 Kbps download / 64 Kbps upload connection and I do not think that I have those many mails for it to go on for two days. Even the first time when I downloaded (in July 2008 when I first started using Zimbra desktop), it completed much faster @75-100MB/hour download).

    As for moving messages, I have not done any of those yet after installing 1482. I just installed ZD and let it running (clicking send-receive) so that all my messages missing from Yahoo web server are uploaded to the server first. Once I see a green icon next to the account name in ZD, I am going to take a count of messages in each folder in Zimbra desktop and compare counts available in Yahoo web interface for each corresponding folder. Subsequent to that, I will open couple of random messages on Yahoo web server including attachments to ensure that everything is working fine.

    Only after that I will start moving and or playing with the new Zimbra desktop.

    As my Gmail had huge number of mails, I have "disabled" it by setting it to sync manually now. Currently, only account sync..ing is Yahoo Plus. All other smaller accounts (YMail, RocketMail etc.) are already in sync.

    I have attached zipped zdesktop.log (which is for today's log, I guess as it starts a new file every day) to the Bug 31450 in Bugzilla (comment #38 and 39).
    Last edited by ezu; 02-06-2009 at 12:58 AM.

  3. #33
    Join Date
    Aug 2008
    Posts
    88
    Rep Power
    7

    Default Bug 31450 followup

    There seems to be some problem for sure. It is more than 5 to 6 days now where my computer was on for almost 24 hours a day and still I cannot see a single mail which was missing from Yahoo web server in Yahoo mail when accessed from browser.

    Can you please look at the logs attached to the bug 31450 and tell me what could be wrong this time around.

    As of now, this is not resolved. None of the emails that were missing from the yahoo web server are back after a week of running Zimbra desktop almost continuously. I even increased the priority of Zimbra service and the client to run "Above Normal" for it to have more CPU. (In any case, this was the only active program running on the laptop as I was not using it for anything else at all).

    I will now have to wait for analysis of this "bug" by Zimbra and subsequent findings before any further action from my side.
    Last edited by ezu; 02-09-2009 at 06:13 PM.

  4. #34
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    OK, we'll take a look. Thanks!

  5. #35
    Join Date
    Aug 2008
    Posts
    88
    Rep Power
    7

    Thumbs up Bug 31450 followup

    Quote Originally Posted by jjzhuang View Post
    OK, we'll take a look. Thanks!
    Please let me know if you require any additional details. I might have much more in the other day-to-day logs also. What I had attached was zdesktop.log for a given day. Hopefully, it should have enough material to isolate and resolve the issue.

  6. #36
    Join Date
    Aug 2008
    Posts
    88
    Rep Power
    7

    Question Bug 31450 followup

    Quote Originally Posted by ezu View Post
    Please let me know if you require any additional details. I might have much more in the other day-to-day logs also. What I had attached was zdesktop.log for a given day. Hopefully, it should have enough material to isolate and resolve the issue.
    As per latest comments available in Bug 31450, this issue was caused by duplicate key issue if mail was moved from non-synchronized local Zimbra desktop folder to trash folder and is now resolved and will be available in upcoming RC2.

    This will definitely apply if I move a mail from non-synchronized folder to trash in the upcoming RC2.

    But what would happen to messages moved already long back in the local folders using previous releases of Zimbra desktop (around July 2008 time frame) and still available in local Zimbra desktop folders. How will the duplicate key issue be taken care of ? Will they get sync'ed back to the yahoo web server. At the end of the whole process, all local mails available and all yahoo web server mails available should be in perfect sync without missing or altering any original mails.

    I am also still wondering as to how this can STOP each and every mail available in local Zimbra desktop folder and not available in Yahoo web mail server to be pushed back to Yahoo web mail server. From what I know, if a mail cannot be pushed back for three times, it will be skipped and the process for next mail should continue. Does this mean that each and every mail in local Zimbra desktop folder not available on Yahoo web mail server has a duplicate key.
    Last edited by ezu; 02-17-2009 at 10:10 PM.

  7. #37
    Join Date
    Aug 2008
    Posts
    88
    Rep Power
    7

    Thumbs down Bug 31450 followup

    Quote Originally Posted by ezu View Post
    Please let me know if you require any additional details. I might have much more in the other day-to-day logs also. What I had attached was zdesktop.log for a given day. Hopefully, it should have enough material to isolate and resolve the issue.
    This narration has gone bit too long but for helping Zimbra and myself, I do not have any option but to write it in detail.

    I tried the latest build 1512 and also tried quite a few things more with it on my own to see if it works. But unfortunately, it has not worked yet.

    The folders available locally in Zimbra desktop are available on Yahoo web server but the mails in approximately 27 of these folders are not available on Yahoo web server.

    I tried the following.

    01) Install the latest build 1512 and try Send-Receive again. It failed.
    02) Disable automatic sync for all other accounts except Yahoo Plus (Set them to manual sync). It failed.
    03) Did an elaborate exercise of listing every folder available on Yahoo mail server, Zimbra desktop along with the mail count (both total and unread in each folder for both Yahoo mail server and Zimbra desktop) and found out exactly which folders are out of sync.
    04) Folders that I had created earlier on either Yahoo web server or Zimbra locally and set to sync later were available at both the places. I had created these folders long back (around September 2008) and moved messages back and forth from one folder to other to see if I can force Zimbra to sync them this way. This is the reason I had few extra folders with no messages in them. I double checked these folders once again on both Yahoo web server and Zimbra desktop and once I was satisfied that they did not have any messages at either place, I deleted these folders from Yahoo web server. This was almost instantaneously reflected in Zimbra desktop on next sync (within 5 minutes) and these folders disappeared from Zimbra desktop too. However, the mails that were available in some OTHER local folders on Zimbra desktop and not available on Yahoo web server did not get pushed back to Yahoo web server after this also. The sync process usually used to stop with a red circle in few minutes.
    05) I created one NEW folder on Yahoo web server (through browser) and waited for Zimbra desktop to create it. This also happened almost instantaenously within 5 minutes on next sync. This new folder was also set to sync automatically by Zimbra desktop itself on creation. As this folder was created freshly on Yahoo web server, neither Yahoo web server nor Zimbra desktop version of it had any messages.
    06) For test purposes, I moved 93 messages (all the messages from one folder) that were missing from Yahoo web server to the newly created folder. This was with the hope that on next sync these messages will get pushed back to newly created folder on Yahoo web server. However, the sync failed again and none of these messages were uploaded to the newly created folder on Yahoo web server.
    07) I decided that I should try setting sync off folder by folder for all folders and try to sync again to see if any particular folder was causing problem (ultimate aim was to have ONLY one folder (other than Inbox, Sent items as these were in sync already) to sync and see if missing messages are get pushed back.
    For this activity, I decided to start with Spam folder as it contained around 3000+ messages. I did try a shortcut for this by checking the Spam contents briefly on Yahoo web server through web browser and emptied Spam on Yahoo web server using web browser interface itself. On next sync with Yahoo web server, Zimbra desktop did start removing Spam mails from Zimbra local desktop. However, when it reached 68 mails from more than 3000+, the sync failed and the service stopped. I tried to restart the service and again tried to sync. It failed again. This made me think that there was some message in Spam folder which was causing the problem. I again tried a shortcut and emptied Spam folder on Zimbra desktop this time. (This will make it manually in sync with Yahoo web server as I had emptied the Spam folder on Yahoo web server minutes ago). However, this trick also did not work and on next sync after all the above, the service again stopped in few minutes and red circle appeared.

    At this point, I decided to take a break and submit this error to the forum along with re-opening the bug and attach the zdesktop.log and zdesktop.log.1 (for enabling Zimbra employees to analyze what is going on).

    However, I am next going to try to set sync off folder by folder on all folders and see if that works (may be later today or tomorrow). Before that, if you can let me know if you have already identified any problem based on the latest log contents, I can save myself some time trying folder by folder sync.

    As you may understand and appreciate, I am running out of patience now after having waited for more than seven months and still not reaching anywhere. I will appreciate if you can let me know as to what the issues could be and if there is any other workaround to resolve this (other than unending fix-verify-build-install-retest-relog in forum-reopen bug... cycle).

    I also wonder whether re-indexing may solve the problem (it should not result in more problems though).

    If there is no other workaround, final resolution that I can visualize is to re-mail each message missing from Yahoo web server to me using Zimbra desktop once again and once they appear in Yahoo web mail, suspend use of Zimbra desktop till all the problems are resolved and stability is reached.

    By the way, I have repeated this while re-opening the bug 31450 and attached the latest logs mentioned above to the bug.

  8. #38
    Join Date
    Aug 2008
    Posts
    88
    Rep Power
    7

    Unhappy Bug 31450 followup

    It has since been updated to build 1513 (from 1512) as I have opted to join beta testing during that install.

    However, no luck yet. I am not even sure as to what is the latest status as I have not got any response to the forum post or bugzilla attachment/comments.

Similar Threads

  1. 5.0.6 is out!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 05-23-2008, 01:16 PM
  2. 5.0.4 is live!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 03-24-2008, 03:27 PM
  3. 5.0.3/.4 is out!!!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 03-20-2008, 04:20 PM
  4. serious IMAP download bug (6326)
    By ericding in forum Developers
    Replies: 5
    Last Post: 04-05-2006, 10:34 AM
  5. i18n, bug 5912 and other considerations
    By Kafka in forum I18N/L10N - Translations
    Replies: 9
    Last Post: 02-22-2006, 03:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •