When setting up an GMX mail account via POP3 it only works when unchecking the box "leave message on server".

I on purpose want to have this function, the mails should leave on the server.

It seems, that this is a bug. Just by changing this setting (with the same account data) it changes between everything OK and saying "account datas are wrong".